aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNeel Chauhan <nc@FreeBSD.org>2023-01-29 02:40:15 +0000
committerNeel Chauhan <nc@FreeBSD.org>2023-01-29 03:20:24 +0000
commita327a063dab373a65e743d3cd2600e912732739d (patch)
tree7392dc2ac5a8d0565959cd4d9c5e0de803498ef3
parentb85fae622629c81a489ab0cabec6f055f4ddb414 (diff)
downloadports-a327a063dab373a65e743d3cd2600e912732739d.tar.gz
ports-a327a063dab373a65e743d3cd2600e912732739d.zip
net/geocode-glib2: New port
-rw-r--r--net/Makefile1
-rw-r--r--net/geocode-glib2/Makefile32
-rw-r--r--net/geocode-glib2/distinfo3
-rw-r--r--net/geocode-glib2/files/patch-meson.build10
-rw-r--r--net/geocode-glib2/pkg-descr5
-rw-r--r--net/geocode-glib2/pkg-plist39
6 files changed, 90 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 8d6100956692..a52b31226cb7 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -181,6 +181,7 @@
SUBDIR += gemserv
SUBDIR += geoclue
SUBDIR += geocode-glib
+ SUBDIR += geocode-glib2
SUBDIR += geoipupdate
SUBDIR += gerbera
SUBDIR += gfbgraph
diff --git a/net/geocode-glib2/Makefile b/net/geocode-glib2/Makefile
new file mode 100644
index 000000000000..d4c1c759d5b1
--- /dev/null
+++ b/net/geocode-glib2/Makefile
@@ -0,0 +1,32 @@
+PORTNAME= geocode-glib
+PORTVERSION= 3.26.4
+CATEGORIES= net devel gnome
+MASTER_SITES= GNOME
+PKGNAMESUFFIX= 2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Convenience library for the geocoding and reverse geocoding
+WWW= https://git.gnome.org/browse/geocode-glib
+
+LICENSE= LGPL20
+LICENSE_FILE= ${WRKSRC}/COPYING.LIB
+
+LIB_DEPENDS= libjson-glib-1.0.so:devel/json-glib \
+ libsoup-3.0.so:devel/libsoup3
+RUN_DEPENDS= geocode-glib>0:net/geocode-glib # for icons
+
+PORTSCOUT= limitw:1,even
+
+USES= gettext gnome localbase meson pkgconfig tar:xz
+USE_GNOME= glib20 introspection:build
+USE_LDCONFIG= yes
+MESON_ARGS= -Denable-installed-tests=false \
+ -Dsoup2=false
+
+OPTIONS_DEFINE= DOCS
+
+DOCS_BUILD_DEPENDS= gtkdoc-scan:textproc/gtk-doc
+DOCS_MESON_TRUE= enable-gtk-doc
+DOCSDIR= ${PREFIX}/share/gtk-doc/html/geocode-glib
+
+.include <bsd.port.mk>
diff --git a/net/geocode-glib2/distinfo b/net/geocode-glib2/distinfo
new file mode 100644
index 000000000000..876e008af334
--- /dev/null
+++ b/net/geocode-glib2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1668269418
+SHA256 (geocode-glib-3.26.4.tar.xz) = 2d9a6826d158470449a173871221596da0f83ebdcff98b90c7049089056a37aa
+SIZE (geocode-glib-3.26.4.tar.xz) = 75352
diff --git a/net/geocode-glib2/files/patch-meson.build b/net/geocode-glib2/files/patch-meson.build
new file mode 100644
index 000000000000..c4afd100ef0d
--- /dev/null
+++ b/net/geocode-glib2/files/patch-meson.build
@@ -0,0 +1,10 @@
+--- meson.build.orig 2023-01-29 02:37:22 UTC
++++ meson.build
+@@ -47,7 +47,6 @@ endif
+
+ subdir('geocode-glib')
+ subdir('po')
+-subdir('icons')
+
+ if get_option('enable-gtk-doc')
+ subdir('docs')
diff --git a/net/geocode-glib2/pkg-descr b/net/geocode-glib2/pkg-descr
new file mode 100644
index 000000000000..c507f7694711
--- /dev/null
+++ b/net/geocode-glib2/pkg-descr
@@ -0,0 +1,5 @@
+geocode-glib is a convenience library for the geocoding (finding longitude,
+and latitude from an address) and reverse geocoding (finding an address from
+coordinates). It uses Nominatim service to achieve that. It also caches
+(reverse-)geocoding requests for faster results and to avoid unnecessary server
+load.
diff --git a/net/geocode-glib2/pkg-plist b/net/geocode-glib2/pkg-plist
new file mode 100644
index 000000000000..8b302ca4b640
--- /dev/null
+++ b/net/geocode-glib2/pkg-plist
@@ -0,0 +1,39 @@
+include/geocode-glib-2.0/geocode-glib/geocode-backend.h
+include/geocode-glib-2.0/geocode-glib/geocode-bounding-box.h
+include/geocode-glib-2.0/geocode-glib/geocode-enum-types.h
+include/geocode-glib-2.0/geocode-glib/geocode-error.h
+include/geocode-glib-2.0/geocode-glib/geocode-forward.h
+include/geocode-glib-2.0/geocode-glib/geocode-glib.h
+include/geocode-glib-2.0/geocode-glib/geocode-location.h
+include/geocode-glib-2.0/geocode-glib/geocode-mock-backend.h
+include/geocode-glib-2.0/geocode-glib/geocode-nominatim.h
+include/geocode-glib-2.0/geocode-glib/geocode-place.h
+include/geocode-glib-2.0/geocode-glib/geocode-reverse.h
+lib/girepository-1.0/GeocodeGlib-2.0.typelib
+lib/libgeocode-glib-2.so
+lib/libgeocode-glib-2.so.0
+lib/libgeocode-glib-2.so.0.0.0
+libdata/pkgconfig/geocode-glib-2.0.pc
+share/gir-1.0/GeocodeGlib-2.0.gir
+%%PORTDOCS%%%%DOCSDIR%%-2/GeocodeBackend.html
+%%PORTDOCS%%%%DOCSDIR%%-2/GeocodeBoundingBox.html
+%%PORTDOCS%%%%DOCSDIR%%-2/GeocodeForward.html
+%%PORTDOCS%%%%DOCSDIR%%-2/GeocodeLocation.html
+%%PORTDOCS%%%%DOCSDIR%%-2/GeocodeNominatim.html
+%%PORTDOCS%%%%DOCSDIR%%-2/GeocodePlace.html
+%%PORTDOCS%%%%DOCSDIR%%-2/GeocodeReverse.html
+%%PORTDOCS%%%%DOCSDIR%%-2/annotation-glossary.html
+%%PORTDOCS%%%%DOCSDIR%%-2/api-index-full.html
+%%PORTDOCS%%%%DOCSDIR%%-2/ch01.html
+%%PORTDOCS%%%%DOCSDIR%%-2/geocode-glib-2-geocode-error.html
+%%PORTDOCS%%%%DOCSDIR%%-2/geocode-glib-2-geocode-mock-backend.html
+%%PORTDOCS%%%%DOCSDIR%%-2/geocode-glib-2.devhelp2
+%%PORTDOCS%%%%DOCSDIR%%-2/home.png
+%%PORTDOCS%%%%DOCSDIR%%-2/index.html
+%%PORTDOCS%%%%DOCSDIR%%-2/left-insensitive.png
+%%PORTDOCS%%%%DOCSDIR%%-2/left.png
+%%PORTDOCS%%%%DOCSDIR%%-2/right-insensitive.png
+%%PORTDOCS%%%%DOCSDIR%%-2/right.png
+%%PORTDOCS%%%%DOCSDIR%%-2/style.css
+%%PORTDOCS%%%%DOCSDIR%%-2/up-insensitive.png
+%%PORTDOCS%%%%DOCSDIR%%-2/up.png