aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-01-31 16:21:22 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-01-31 16:21:22 +0000
commita345c5cf11a8e516a8dfa0be19809270ca858e52 (patch)
tree1ac51e577ac231ed4e541100256dcf50303377ad
parent4645dcd3e04a81e0cc7d11e5040cfde85c313ba8 (diff)
downloadports-a345c5cf11a8e516a8dfa0be19809270ca858e52.tar.gz
ports-a345c5cf11a8e516a8dfa0be19809270ca858e52.zip
Tell Module::Build to use LOCALBASE/bin/perl and not
LOCALBASE/bin/perl5.xx.y. Add a QA check to test for it. Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=432931
-rw-r--r--Mk/Scripts/qa.sh5
-rw-r--r--Mk/Uses/perl5.mk3
2 files changed, 7 insertions, 1 deletions
diff --git a/Mk/Scripts/qa.sh b/Mk/Scripts/qa.sh
index 3330bdb7db51..004c56fec5cc 100644
--- a/Mk/Scripts/qa.sh
+++ b/Mk/Scripts/qa.sh
@@ -45,6 +45,11 @@ shebangonefile() {
case "${interp}" in
"") ;;
${LINUXBASE}/*) ;;
+ ${LOCALBASE}/bin/perl5.* | ${PREFIX}/bin/perl5.*)
+ err "'${interp}' is an invalid shebang for '${f#${STAGEDIR}${PREFIX}/}' you must use ${LOCALBASE}/bin/perl."
+ err "Either pass \${PERL} to the build or use USES=shebangfix"
+ rc=1
+ ;;
${LOCALBASE}/*) ;;
${PREFIX}/*) ;;
/bin/csh) ;;
diff --git a/Mk/Uses/perl5.mk b/Mk/Uses/perl5.mk
index 3649ec73a8b4..b95490aa67e2 100644
--- a/Mk/Uses/perl5.mk
+++ b/Mk/Uses/perl5.mk
@@ -192,7 +192,8 @@ CONFIGURE_ARGS+=--install_path lib="${PREFIX}/${SITE_PERL_REL}" \
--install_path script="${PREFIX}/bin" \
--install_path bin="${PREFIX}/bin" \
--install_path libdoc="${MAN3PREFIX}/man/man3" \
- --install_path bindoc="${MAN1PREFIX}/man/man1"
+ --install_path bindoc="${MAN1PREFIX}/man/man1" \
+ --perl="${PERL}"
CONFIGURE_SCRIPT?= Build.PL
PL_BUILD?= Build
CONFIGURE_ARGS+=--destdir ${STAGEDIR}