aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2022-09-29 22:48:40 +0000
committerBrooks Davis <brooks@FreeBSD.org>2022-09-29 22:48:40 +0000
commita3c9588e81ddae1fe37bb1f091b135c7b8e423d1 (patch)
tree2cd3e48c4f9f6a30278771fca7d4366f9fdf946f
parent38c131e442256c38b219a93018d0ff28f2c3bac7 (diff)
downloadports-a3c9588e81ddae1fe37bb1f091b135c7b8e423d1.tar.gz
ports-a3c9588e81ddae1fe37bb1f091b135c7b8e423d1.zip
devel/llvm-devel: simplify option declerations (NFC)
In for non-lite flavors, include and DEFINE and DEFAULT COMPILER_RT and OPENMP and then EXCLUDE them on 32-bit arm and all 32-bit systems respectively.
-rw-r--r--devel/llvm-devel/Makefile34
1 files changed, 14 insertions, 20 deletions
diff --git a/devel/llvm-devel/Makefile b/devel/llvm-devel/Makefile
index 44dfdb56e7fe..0058f2713183 100644
--- a/devel/llvm-devel/Makefile
+++ b/devel/llvm-devel/Makefile
@@ -82,26 +82,20 @@ GH_TAGNAME= ${LLVM_PROJECT_COMMIT}
OPTIONS_DEFINE= CLANG DOCS LLD STATIC_LIBS
OPTIONS_DEFAULT= CLANG LLD
.if !${FLAVOR:Mlite}
-OPTIONS_DEFINE_aarch64= COMPILER_RT OPENMP
-OPTIONS_DEFINE+= EXTRAS FLANG LIT LLDB MLIR
-OPTIONS_DEFINE_amd64= COMPILER_RT GOLD OPENMP
-OPTIONS_DEFINE_i386= COMPILER_RT
-OPTIONS_DEFINE_powerpc= COMPILER_RT GOLD
-OPTIONS_DEFINE_powerpc64= COMPILER_RT GOLD OPENMP
-OPTIONS_DEFINE_powerpc64le= COMPILER_RT GOLD OPENMP
-OPTIONS_DEFINE_riscv64= COMPILER_RT OPENMP
-OPTIONS_DEFAULT+= EXTRAS FLANG LIT LLDB STATIC_LIBS
-OPTIONS_DEFAULT_aarch64= COMPILER_RT OPENMP
-OPTIONS_DEFAULT_amd64= COMPILER_RT GOLD OPENMP
-OPTIONS_DEFAULT_i386= COMPILER_RT
-OPTIONS_DEFAULT_powerpc= COMPILER_RT GOLD
-OPTIONS_DEFAULT_powerpc64= COMPILER_RT GOLD OPENMP
-OPTIONS_DEFAULT_powerpc64le= COMPILER_RT GOLD OPENMP
-OPTIONS_DEFAULT_riscv64= COMPILER_RT OPENMP
-OPTIONS_EXCLUDE_armv6= FLANG
-OPTIONS_EXCLUDE_armv7= FLANG
-OPTIONS_EXCLUDE_i386= FLANG
-OPTIONS_EXCLUDE_powerpc= FLANG
+OPTIONS_DEFINE+= COMPILER_RT EXTRAS FLANG LIT LLDB MLIR OPENMP
+OPTIONS_DEFINE_amd64= GOLD
+OPTIONS_DEFINE_powerpc= GOLD
+OPTIONS_DEFINE_powerpc64= GOLD
+OPTIONS_DEFINE_powerpc64le= GOLD
+OPTIONS_DEFAULT+= COMPILER_RT EXTRAS FLANG LIT LLDB STATIC_LIBS OPENMP
+OPTIONS_DEFAULT_amd64= GOLD
+OPTIONS_DEFAULT_powerpc= GOLD
+OPTIONS_DEFAULT_powerpc64= GOLD
+OPTIONS_DEFAULT_powerpc64le= GOLD
+OPTIONS_EXCLUDE_armv6= COMPILER_RT FLANG OPENMP
+OPTIONS_EXCLUDE_armv7= COMPILER_RT FLANG OPENMP
+OPTIONS_EXCLUDE_i386= FLANG OPENMP
+OPTIONS_EXCLUDE_powerpc= FLANG OPENMP
OPTIONS_EXCLUDE_riscv64= LLDB
.endif
OPTIONS_SUB= yes