aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2022-10-02 05:56:31 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2022-10-02 05:56:31 +0000
commita3cc73641e651b122024f7dc0439eaa809ee049f (patch)
tree798f968567ccc89d7dcb331431cf47f6e338aa6e
parentdf8005b90fc19d8a475dfb433767aad479040d55 (diff)
downloadports-a3cc73641e651b122024f7dc0439eaa809ee049f.tar.gz
ports-a3cc73641e651b122024f7dc0439eaa809ee049f.zip
net-p2p/awgg: Re-add port: Advanced wget GUI
AWGG comes from Advanced Wget GUI. AWGG is a lightweight multiplatform and multilanguage download manager, basically a wget frontend and other tools like aria2, curl, youtube-dl and axel. AWGG is written in Free Pascal , using CodeTyphon and Lazarus IDE. Features: Status filter download. Batch download. Manage multiple downloads engines at the same time. Multiple schedules. Clipboard monitoring. Notification system. Proxy configuration. Multiple queues. Supports HTTP, HTTPS, FTP. Drop box
-rw-r--r--MOVED1
-rw-r--r--net-p2p/Makefile1
-rw-r--r--net-p2p/awgg/Makefile52
-rw-r--r--net-p2p/awgg/distinfo3
-rw-r--r--net-p2p/awgg/pkg-descr17
-rw-r--r--net-p2p/awgg/pkg-plist13
6 files changed, 86 insertions, 1 deletions
diff --git a/MOVED b/MOVED
index 55491c18266e..0530719eb10c 100644
--- a/MOVED
+++ b/MOVED
@@ -17575,7 +17575,6 @@ net/libmms||2022-09-30|Has expired: Obsolete, Microsoft deprecated MMS protocol
audio/mctoolame-decoder||2022-09-30|Has expired: Legacy and obscure audio format that never gained any traction
audio/mctoolame-encoder||2022-09-30|Has expired: Legacy and obscure audio format that never gained any traction
www/py-ws4py||2022-09-30|Has expired: Upstream abandoned
-net-p2p/awgg||2022-09-30|Has expired: Depends on expired ftp/axel
ftp/axel||2022-09-30|Has expired: Last release in 2009 and dead upstream, please consider using www/aria2
databases/py-bsddb3|databases/py-berkeleydb|2022-09-30|Has expired: Requires upstream EOLd db5. Use py-berkeleydb
graphics/megapov|graphics/povray37|2022-10-01|Has expired: Abandoned upstream. graphics/povray37 is the recommended replacement
diff --git a/net-p2p/Makefile b/net-p2p/Makefile
index ea3ed48e9b75..f9df23ecfd93 100644
--- a/net-p2p/Makefile
+++ b/net-p2p/Makefile
@@ -4,6 +4,7 @@
SUBDIR += amule-devel
SUBDIR += arbitrum-avm
SUBDIR += autoscan
+ SUBDIR += awgg
SUBDIR += bazarr
SUBDIR += bitcoin
SUBDIR += bitcoin-daemon
diff --git a/net-p2p/awgg/Makefile b/net-p2p/awgg/Makefile
new file mode 100644
index 000000000000..71e3b54b2fe8
--- /dev/null
+++ b/net-p2p/awgg/Makefile
@@ -0,0 +1,52 @@
+PORTNAME= awgg
+DISTVERSION= 0.6.0.6034-beta
+CATEGORIES= net-p2p
+PKGNAMESUFFIX= ${LAZARUS_PKGNAMESUFFIX}
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Advanced wget GUI
+WWW= https://github.com/Nenirey/AWGG
+
+LICENSE= GPLv2
+
+RUN_DEPENDS= aria2c:www/aria2 \
+ wget:ftp/wget \
+ curl:ftp/curl \
+ yt-dlp:www/yt-dlp
+
+gtk2_CONFLICTS_INSTALL= ${PORTNAME}-qt5
+qt5_CONFLICTS_INSTALL= ${PORTNAME}-gtk2
+
+USES= fpc gnome lazarus:flavors xorg
+USE_FPC= chm fcl-base fcl-db fcl-image fcl-json fcl-net fcl-registry \
+ fcl-web fcl-xml openssl pasjpeg regexpr rtl-extra rtl-objpas x11
+USE_XORG= x11
+USE_GITHUB= yes
+GH_ACCOUNT= Nenirey
+GH_PROJECT= AWGG
+GH_TAGNAME= 6daa550
+
+DESKTOP_ENTRIES="AWGG" \
+ "Advanced wget GUI" \
+ "${PREFIX}/share/pixmaps/AWGG16x16.png" \
+ "${PORTNAME}" \
+ "Network;P2P;" \
+ ${TRUE}
+
+USE_FPC_gtk2= cairo
+USE_GNOME_gtk2= cairo
+USE_FPC+= ${USE_FPC_${FLAVOR}}
+USE_GNOME+= ${USE_GNOME_${FLAVOR}}
+
+LAZBUILD_ARGS= -d
+LAZARUS_PROJECT_FILES= src/awgg.lpi
+
+post-patch:
+ ${REINPLACE_CMD} 's|/usr/bin/shutdown|/sbin/shutdown|g' ${WRKSRC}/src/fmain.pas
+ ${REINPLACE_CMD} 's|/usr|${LOCALBASE}|g' ${WRKSRC}/src/fmain.pas
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ cd ${WRKSRC}/pixmaps && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/share/pixmaps
+
+.include <bsd.port.mk>
diff --git a/net-p2p/awgg/distinfo b/net-p2p/awgg/distinfo
new file mode 100644
index 000000000000..d11a4f36ab93
--- /dev/null
+++ b/net-p2p/awgg/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1664687235
+SHA256 (Nenirey-AWGG-0.6.0.6034-beta-6daa550_GH0.tar.gz) = 8963afef1777d796080ecf17cfb838729af75aa77dd03b6c77327239ad987bb3
+SIZE (Nenirey-AWGG-0.6.0.6034-beta-6daa550_GH0.tar.gz) = 2469603
diff --git a/net-p2p/awgg/pkg-descr b/net-p2p/awgg/pkg-descr
new file mode 100644
index 000000000000..c3a7b80dc5e9
--- /dev/null
+++ b/net-p2p/awgg/pkg-descr
@@ -0,0 +1,17 @@
+AWGG comes from Advanced Wget GUI. AWGG is a lightweight multiplatform and
+multilanguage download manager, basically a wget frontend and other tools like
+aria2, curl, youtube-dl and axel. AWGG is written in Free Pascal , using
+CodeTyphon and Lazarus IDE.
+
+Features:
+
+ Status filter download.
+ Batch download.
+ Manage multiple downloads engines at the same time.
+ Multiple schedules.
+ Clipboard monitoring.
+ Notification system.
+ Proxy configuration.
+ Multiple queues.
+ Supports HTTP, HTTPS, FTP.
+ Drop box
diff --git a/net-p2p/awgg/pkg-plist b/net-p2p/awgg/pkg-plist
new file mode 100644
index 000000000000..f801bb8a9b12
--- /dev/null
+++ b/net-p2p/awgg/pkg-plist
@@ -0,0 +1,13 @@
+bin/awgg
+share/pixmaps/AWGG.ico
+share/pixmaps/AWGG128x128.png
+share/pixmaps/AWGG16x16.png
+share/pixmaps/AWGG256x256.png
+share/pixmaps/AWGG32x32.png
+share/pixmaps/AWGG36x36.png
+share/pixmaps/AWGG48x48.png
+share/pixmaps/AWGG64x64.png
+share/pixmaps/editcopy.png
+share/pixmaps/icongray.ico
+share/pixmaps/DropBox.png
+share/pixmaps/DropBox30x30.png