aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Moerz <freebsd@ny-central.org>2024-01-13 08:18:27 +0000
committerKoichiro Iwao <meta@FreeBSD.org>2024-01-24 01:55:54 +0000
commita3cf7b23ba323acfeb3a63735274a88897692d09 (patch)
treed92b3e15a14123b2364391f2e74644696ec95f10
parent287cc197bf62e523654f0f4ec5d51ba3a5e68b33 (diff)
downloadports-a3cf7b23ba323acfeb3a63735274a88897692d09.tar.gz
ports-a3cf7b23ba323acfeb3a63735274a88897692d09.zip
sysutils/vmstated: add new port
PR: 276291
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/vmstated/Makefile19
-rw-r--r--sysutils/vmstated/README.md38
-rw-r--r--sysutils/vmstated/distinfo3
-rw-r--r--sysutils/vmstated/pkg-descr4
-rw-r--r--sysutils/vmstated/pkg-plist8
6 files changed, 73 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index c770a710ad59..2598e42cd995 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -1589,6 +1589,7 @@
SUBDIR += vm-bhyve
SUBDIR += vm-bhyve-devel
SUBDIR += vmdktool
+ SUBDIR += vmstated
SUBDIR += vmtouch
SUBDIR += vobcopy
SUBDIR += volman
diff --git a/sysutils/vmstated/Makefile b/sysutils/vmstated/Makefile
new file mode 100644
index 000000000000..070caff80013
--- /dev/null
+++ b/sysutils/vmstated/Makefile
@@ -0,0 +1,19 @@
+PORTNAME= vmstated
+DISTVERSION= 0.04
+CATEGORIES= sysutils
+
+MAINTAINER= freebsd@ny-central.org
+COMMENT= Manages and runs bhyve virtual machines and infrastructure
+WWW= https://www.github.com/christian-moerz/vmstated
+
+LICENSE= BSD2CLAUSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= christian-moerz
+GH_PROJECT= vmstated
+GH_TAGNAME= ${DISTVERSION}
+
+post-patch:
+ ${REINPLACE_CMD} "s@PREFIX@${PREFIX}@g" "${WRKSRC}/rc/vmstated"
+
+.include <bsd.port.mk>
diff --git a/sysutils/vmstated/README.md b/sysutils/vmstated/README.md
new file mode 100644
index 000000000000..2750e950f1a9
--- /dev/null
+++ b/sysutils/vmstated/README.md
@@ -0,0 +1,38 @@
+## vmstated
+
+`vmstated` is a very simple bhyve virtual machine manager for FreeBSD.
+
+### How to compile
+
+Eventually, `vmstated` will be released via the regular ports channel; until then,
+one can run the following commands:
+
+```
+git clone https://github.com/christian-moerz/vmstated
+cd vmstated/port
+make package
+pkg install work/pkg/vmstated-0.01.pkg
+```
+
+To uninstall vmstated, use the usual pkg command
+
+```
+pkg deinstall vmstated
+```
+
+### How to get started
+
+Please refer to the man pages for `vmstated(8)` or `vmstatedctl(1)` for further
+details on how to use `vmstated`.
+
+To start `vmstated` run
+
+```
+sysrc vmstated_enable=YES
+service vmstated start
+```
+
+- Configuration files go under `/usr/local/etc/vmstated`.
+- Log files are under `/var/log/vmstated`
+- PID file and socket are under `/var/run/`
+
diff --git a/sysutils/vmstated/distinfo b/sysutils/vmstated/distinfo
new file mode 100644
index 000000000000..ab31c8872595
--- /dev/null
+++ b/sysutils/vmstated/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1705133490
+SHA256 (christian-moerz-vmstated-0.04_GH0.tar.gz) = 3858f64f70d73e9d5e734ed9c64e72024092f32700767214ed2202dad570971a
+SIZE (christian-moerz-vmstated-0.04_GH0.tar.gz) = 69102
diff --git a/sysutils/vmstated/pkg-descr b/sysutils/vmstated/pkg-descr
new file mode 100644
index 000000000000..8412dee99742
--- /dev/null
+++ b/sysutils/vmstated/pkg-descr
@@ -0,0 +1,4 @@
+vmstated is a user-space daemon that manages bhyve virtual
+machines. It provides hook scripts for easy network and storage setup
+and maintains records on a virtual machine's state while it is
+running.
diff --git a/sysutils/vmstated/pkg-plist b/sysutils/vmstated/pkg-plist
new file mode 100644
index 000000000000..08e330c201fc
--- /dev/null
+++ b/sysutils/vmstated/pkg-plist
@@ -0,0 +1,8 @@
+@mode 755
+bin/vmstatedctl
+etc/rc.d/vmstated
+@mode 750
+sbin/vmstated
+@mode 0444
+share/man/man1/vmstatedctl.1.gz
+share/man/man8/vmstated.8.gz