aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2024-10-01 13:20:31 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2024-10-01 13:34:05 +0000
commita416ffca6ce6b31318dce4324a4956f9dfd5a152 (patch)
tree8ef9cbe27569ca60f3d2b852570f43442b9aa1f4
parent7156ed22c8af9933256704576ddeec4e17ffb8d7 (diff)
downloadports-a416ffca6ce6b31318dce4324a4956f9dfd5a152.tar.gz
ports-a416ffca6ce6b31318dce4324a4956f9dfd5a152.zip
lang/guile3: Ignore on 32-bit platforms
- Fails to build on 32-bit platforms - Pet portlint/portclippy
-rw-r--r--lang/guile3/Makefile24
1 files changed, 13 insertions, 11 deletions
diff --git a/lang/guile3/Makefile b/lang/guile3/Makefile
index e1c0a8ccb7b3..b7fe90db599b 100644
--- a/lang/guile3/Makefile
+++ b/lang/guile3/Makefile
@@ -11,6 +11,9 @@ WWW= https://www.gnu.org/software/guile/
LICENSE= GPLv3 LGPL3
LICENSE_COMB= multi
+NOT_FOR_ARCHS= armv7 i386
+NOT_FOR_ARCHS_REASON= Does not build on armv7 and i386
+
USES= tar:lz
# The -aclocal slave port includes this file to get the version,
@@ -31,10 +34,17 @@ USES+= guile:${PORTVERSION:R},env \
pathfix pkgconfig readline localbase
CPE_VENDOR= gnu
USE_LDCONFIG= yes
+
GNU_CONFIGURE= yes
-GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
CONFIGURE_ARGS= --program-suffix=-${GUILE_VER} \
--enable-lto=no
+# eliminate some pointless configure warnings/errors
+CONFIGURE_ENV+= gl_cv_func_working_mktime=yes \
+ ac_cv_header_sys_timeb_h=0
+
+MAKE_JOBS_UNSAFE= yes
+INSTALL_TARGET= install-strip
+
# LTO is unconditionally off here because it fails to build with llvm,
# fails to build even with gcc on some arches (reported for armv7 in
# particular), and making it conditional on gcc/arch is trickier than
@@ -43,14 +53,6 @@ CONFIGURE_ARGS= --program-suffix=-${GUILE_VER} \
# tested build+run on more than just amd64/arm46.
LTO_UNSAFE= yes
-# eliminate some pointless configure warnings/errors
-CONFIGURE_ENV+= gl_cv_func_working_mktime=yes \
- ac_cv_header_sys_timeb_h=0
-
-MAKE_JOBS_UNSAFE= yes
-
-INSTALL_TARGET= install-strip
-
INFO= guile r5rs
INFO_PATH= ${GUILE_INFO_PATH}
@@ -61,8 +63,8 @@ OPTIONS_SUB= yes
MINIGMP_DESC= Use embedded mini-gmp rather than external libgmp
-MINIGMP_LIB_DEPENDS_OFF= libgmp.so:math/gmp
-MINIGMP_CONFIGURE_ENABLE= mini-gmp
+MINIGMP_LIB_DEPENDS_OFF= libgmp.so:math/gmp
+MINIGMP_CONFIGURE_ENABLE= mini-gmp
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls