aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-08-08 14:35:52 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-08-08 14:54:05 +0000
commita46a6f7c53d3a3107ad1f19b59b0e99c7f722e63 (patch)
tree469aae62177e14592807f73e9c419f73374b0307
parentc182482e031941efd34272de2f86957074be9996 (diff)
downloadports-a46a6f7c53d3a3107ad1f19b59b0e99c7f722e63.tar.gz
ports-a46a6f7c53d3a3107ad1f19b59b0e99c7f722e63.zip
devel/py-flit: Update to 3.3.0
-rw-r--r--devel/py-flit/Makefile4
-rw-r--r--devel/py-flit/distinfo6
-rw-r--r--devel/py-flit/files/setup.py8
3 files changed, 9 insertions, 9 deletions
diff --git a/devel/py-flit/Makefile b/devel/py-flit/Makefile
index dce29c8cf9d8..e2af4cce8307 100644
--- a/devel/py-flit/Makefile
+++ b/devel/py-flit/Makefile
@@ -1,7 +1,7 @@
# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
PORTNAME= flit
-PORTVERSION= 3.2.0
+PORTVERSION= 3.3.0
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,7 +13,7 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}docutils>=0:textproc/py-docutils@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}flit-core>=${PORTVERSION}<3.3:devel/py-flit-core@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}flit-core>=${PORTVERSION}:devel/py-flit-core@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}toml>=0:textproc/py-toml@${PY_FLAVOR}
diff --git a/devel/py-flit/distinfo b/devel/py-flit/distinfo
index e0923bbb5772..f8c8b31a360f 100644
--- a/devel/py-flit/distinfo
+++ b/devel/py-flit/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1619198495
-SHA256 (flit-3.2.0.tar.gz) = 592464c9268bbacec9bc67b5a3ae62e6e090aeec1563e69501df338a1728e551
-SIZE (flit-3.2.0.tar.gz) = 115192
+TIMESTAMP = 1628103106
+SHA256 (flit-3.3.0.tar.gz) = 65fbe22aaa7f880b776b20814bd80b0afbf91d1f95b17235b608aa256325ce57
+SIZE (flit-3.3.0.tar.gz) = 117809
diff --git a/devel/py-flit/files/setup.py b/devel/py-flit/files/setup.py
index aee70ac43151..e11df8b4a5b7 100644
--- a/devel/py-flit/files/setup.py
+++ b/devel/py-flit/files/setup.py
@@ -10,10 +10,10 @@ package_data = \
{'': ['*'], 'flit': ['license_templates/*']}
install_requires = \
-['flit_core>=3.2.0', 'requests', 'docutils', 'toml']
+['flit_core>=3.3.0', 'requests', 'docutils', 'toml']
extras_require = \
-{":python_version in '3.3 3.4 3.5'": ['zipfile36'],
+{":python_version == '3.5'": ['zipfile36'],
'doc': ['sphinx', 'sphinxcontrib_github_alt', 'pygments-github-lexers'],
'test': ['testpath', 'responses', 'pytest>=2.7.3', 'pytest-cov']}
@@ -21,7 +21,7 @@ entry_points = \
{'console_scripts': ['flit = flit:main']}
setup(name='flit',
- version='3.2.0',
+ version='3.3.0',
description='A simple packaging tool for simple packages.',
author='Thomas Kluyver',
author_email='thomas@kluyver.me.uk',
@@ -31,5 +31,5 @@ setup(name='flit',
install_requires=install_requires,
extras_require=extras_require,
entry_points=entry_points,
- python_requires='>=3.5',
+ python_requires='>=3.6',
)