aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2023-04-26 11:33:48 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2023-04-26 12:53:34 +0000
commita4781a12220e51f01fea3fe97be8e4913ca74e18 (patch)
tree18f043bf5ab34cc41e2b282397c71e455f7d5447
parentc3434ed5107137e901f5777086b89e1f382061d7 (diff)
downloadports-a4781a12220e51f01fea3fe97be8e4913ca74e18.tar.gz
ports-a4781a12220e51f01fea3fe97be8e4913ca74e18.zip
lang/ruby30: enable libunwind on powerpc
-rw-r--r--Mk/Uses/ruby.mk2
-rw-r--r--lang/ruby30/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/Mk/Uses/ruby.mk b/Mk/Uses/ruby.mk
index 9aee42814ac0..bce78c7ed640 100644
--- a/Mk/Uses/ruby.mk
+++ b/Mk/Uses/ruby.mk
@@ -149,7 +149,7 @@ RUBY?= ${LOCALBASE}/bin/ruby${RUBY_SUFFIX}
# Ruby 3.0
#
RUBY_DISTVERSION= 3.0.6
-RUBY_PORTREVISION= 0
+RUBY_PORTREVISION= 1
. elif ${RUBY_VER} == 3.1
#
# Ruby 3.1
diff --git a/lang/ruby30/Makefile b/lang/ruby30/Makefile
index e3fc6cc8ab7d..7a6038bc3bb8 100644
--- a/lang/ruby30/Makefile
+++ b/lang/ruby30/Makefile
@@ -91,7 +91,7 @@ _SUF2= ,${PORTEPOCH}
#.endif
# keep in sync with all platforms where libunwind is available
-.if ${ARCH} == aarch64 || ${ARCH} == amd64 || ${ARCH} == armv7 || ${ARCH} == i386 || ${ARCH} == powerpc64 || ${ARCH} == powerpc64le
+.if ${ARCH} == aarch64 || ${ARCH} == amd64 || ${ARCH} == armv7 || ${ARCH} == i386 || ${ARCH} == powerpc || ${ARCH} == powerpc64 || ${ARCH} == powerpc64le
LIB_DEPENDS+= libunwind.so:devel/libunwind
.endif