aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Rabson <dfr@FreeBSD.org>2022-11-16 12:46:31 +0000
committerDave Cottlehuber <dch@FreeBSD.org>2022-11-16 12:46:31 +0000
commita521f78f6a37e98a28da2dfd18db2948f1b18795 (patch)
treeec3e6ac4d78341c631ad524f99856baabdc622b2
parentda130a1d6225ef328a5592c1149dcb2eb8d12bd5 (diff)
downloadports-a521f78f6a37e98a28da2dfd18db2948f1b18795.tar.gz
ports-a521f78f6a37e98a28da2dfd18db2948f1b18795.zip
sysutils/skopeo: new port
Command line utility to inspect images and repositories directly on Docker registries without the need to pull them. PR: 267184 Reviewed by: arrowd Reviewed by: dch Sponsored by: SkunkWerks, GmbH Differential Revision: https://reviews.freebsd.org/D37324
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/skopeo/Makefile30
-rw-r--r--sysutils/skopeo/distinfo3
-rw-r--r--sysutils/skopeo/pkg-descr2
-rw-r--r--sysutils/skopeo/pkg-plist16
5 files changed, 52 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index c521a51ad61c..050c44b93fc4 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -1328,6 +1328,7 @@
SUBDIR += signon-plugin-oauth2
SUBDIR += signon-qt5
SUBDIR += signon-ui
+ SUBDIR += skopeo
SUBDIR += slack
SUBDIR += sleuthkit
SUBDIR += slst
diff --git a/sysutils/skopeo/Makefile b/sysutils/skopeo/Makefile
new file mode 100644
index 000000000000..82d251f4bf56
--- /dev/null
+++ b/sysutils/skopeo/Makefile
@@ -0,0 +1,30 @@
+PORTNAME= skopeo
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.10.0
+CATEGORIES= sysutils
+
+MAINTAINER= dfr@FreeBSD.org
+COMMENT= Inspect container images and repositories on registries
+WWW= https://github.com/containers
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= bash:shells/bash \
+ curl:ftp/curl \
+ go-md2man:textproc/go-md2man
+LIB_DEPENDS= libgpgme.so:security/gpgme
+RUN_DEPENDS= ${LOCALBASE}/etc/containers/containers.conf.sample:sysutils/containers-common
+
+USES= gmake go:modules,no_targets pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= containers
+GH_PROJECT= skopeo
+
+do-install:
+ ${SETENV} ${MAKE_ENV} ${GO_ENV} ${GMAKE} -C ${WRKSRC} \
+ DESTDIR=${STAGEDIR} GOCACHE=${WRKDIR}.gocache \
+ GO=${GO_CMD} install-binary install-docs install-completions
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/containers/registries.d
+ ${INSTALL_DATA} ${WRKSRC}/default.yaml ${STAGEDIR}${PREFIX}/etc/containers/registries.d/default.yaml
+
+.include <bsd.port.mk>
diff --git a/sysutils/skopeo/distinfo b/sysutils/skopeo/distinfo
new file mode 100644
index 000000000000..839ad97f7b12
--- /dev/null
+++ b/sysutils/skopeo/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1666523319
+SHA256 (containers-skopeo-v1.10.0_GH0.tar.gz) = c3d15ec25c028980b795a0ccdcd48296287b8467fe24a7bc319f5fc87378fe8c
+SIZE (containers-skopeo-v1.10.0_GH0.tar.gz) = 6460856
diff --git a/sysutils/skopeo/pkg-descr b/sysutils/skopeo/pkg-descr
new file mode 100644
index 000000000000..a1f5eb8a2977
--- /dev/null
+++ b/sysutils/skopeo/pkg-descr
@@ -0,0 +1,2 @@
+Command line utility to inspect images and repositories directly on Docker
+registries without the need to pull them.
diff --git a/sysutils/skopeo/pkg-plist b/sysutils/skopeo/pkg-plist
new file mode 100644
index 000000000000..708fe0bcc58e
--- /dev/null
+++ b/sysutils/skopeo/pkg-plist
@@ -0,0 +1,16 @@
+bin/skopeo
+etc/containers/registries.d/default.yaml
+share/bash-completion/completions/skopeo
+share/fish/vendor_completions.d/skopeo.fish
+share/man/man1/skopeo-copy.1.gz
+share/man/man1/skopeo-delete.1.gz
+share/man/man1/skopeo-inspect.1.gz
+share/man/man1/skopeo-list-tags.1.gz
+share/man/man1/skopeo-login.1.gz
+share/man/man1/skopeo-logout.1.gz
+share/man/man1/skopeo-manifest-digest.1.gz
+share/man/man1/skopeo-standalone-sign.1.gz
+share/man/man1/skopeo-standalone-verify.1.gz
+share/man/man1/skopeo-sync.1.gz
+share/man/man1/skopeo.1.gz
+share/zsh/site-functions/_skopeo