aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-11-06 17:46:50 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-11-10 06:20:12 +0000
commita55c182ab0a7408eda8401a60a99d3b43ed49ce8 (patch)
tree45f963da3d7b34df6ed32d81778c2a6388c8a0bc
parent4027ae5056a912be257bb4129178332031fb48d6 (diff)
downloadports-a55c182ab0a7408eda8401a60a99d3b43ed49ce8.tar.gz
ports-a55c182ab0a7408eda8401a60a99d3b43ed49ce8.zip
comms/spandsp: Update to 3.0.0
Patch consumers and bump PORTREVISION where appropriate. PR: 258999 Reported by: jailbird@fdf.net (maintainer) Reviewed by: madpilot@
-rw-r--r--audio/baresip/Makefile2
-rw-r--r--comms/spandsp/Makefile18
-rw-r--r--comms/spandsp/distinfo5
-rw-r--r--comms/spandsp/files/patch-Makefile.am6
-rw-r--r--comms/spandsp/files/patch-configure.ac37
-rw-r--r--comms/spandsp/pkg-plist18
-rw-r--r--misc/libsupertone/Makefile2
-rw-r--r--net/asterisk16/Makefile1
-rw-r--r--net/asterisk16/files/patch-res_res__fax__spandsp.c62
-rw-r--r--net/asterisk18/Makefile1
-rw-r--r--net/asterisk18/files/patch-res_res__fax__spandsp.c62
-rw-r--r--net/mediastreamer/Makefile2
-rw-r--r--net/opal/Makefile2
-rw-r--r--net/opal/files/patch-plugins_fax_fax__spandsp_spandsp__fax.cpp153
-rw-r--r--net/sems/Makefile1
-rw-r--r--net/wireshark/Makefile1
-rw-r--r--net/yate/Makefile1
17 files changed, 321 insertions, 53 deletions
diff --git a/audio/baresip/Makefile b/audio/baresip/Makefile
index cca1f6baf8f2..30f8f07fdd83 100644
--- a/audio/baresip/Makefile
+++ b/audio/baresip/Makefile
@@ -1,6 +1,6 @@
PORTNAME= baresip
PORTVERSION= 0.5.8
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= audio
MASTER_SITES= http://www.creytiv.com/pub/
diff --git a/comms/spandsp/Makefile b/comms/spandsp/Makefile
index fea700f1eaa2..84d75333f3fe 100644
--- a/comms/spandsp/Makefile
+++ b/comms/spandsp/Makefile
@@ -1,20 +1,28 @@
# Created by: wlloyd@slap.net
PORTNAME= spandsp
-PORTVERSION= 0.0.6
+DISTVERSION= ${SPANDSP_VERSION}.g20211014
CATEGORIES= comms
-MASTER_SITES= http://www.soft-switch.org/downloads/spandsp/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= jailbird@fdf.net
COMMENT= DSP library and software FAX machine
LICENSE= LGPL21
LIB_DEPENDS= libtiff.so:graphics/tiff
+USES= autoreconf gmake jpeg libtool localbase
+
+USE_GITHUB= yes
+GH_ACCOUNT= freeswitch
+GH_TAGNAME= ${GITHUB_COMMIT}
+GITHUB_COMMIT= 284fe91
+
+USE_LDCONFIG= yes
+
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= autoreconf gmake libtool localbase
-USE_LDCONFIG= yes
+
+SPANDSP_VERSION= 3.0.0
.include <bsd.port.mk>
diff --git a/comms/spandsp/distinfo b/comms/spandsp/distinfo
index b486ff476e6a..3c66f956f62e 100644
--- a/comms/spandsp/distinfo
+++ b/comms/spandsp/distinfo
@@ -1,2 +1,3 @@
-SHA256 (spandsp-0.0.6.tar.gz) = cc053ac67e8ac4bb992f258fd94f275a7872df959f6a87763965feabfdcc9465
-SIZE (spandsp-0.0.6.tar.gz) = 3309837
+TIMESTAMP = 1634216290
+SHA256 (freeswitch-spandsp-3.0.0.g20211014-284fe91_GH0.tar.gz) = 288b12eb058d615c526e85fe0fe339293e5713b3513e7918043e93e52e4efd49
+SIZE (freeswitch-spandsp-3.0.0.g20211014-284fe91_GH0.tar.gz) = 3584374
diff --git a/comms/spandsp/files/patch-Makefile.am b/comms/spandsp/files/patch-Makefile.am
index ce87f18afc76..6b2648aa852f 100644
--- a/comms/spandsp/files/patch-Makefile.am
+++ b/comms/spandsp/files/patch-Makefile.am
@@ -1,6 +1,6 @@
---- Makefile.am.orig 2014-09-03 14:15:04.000000000 +0300
-+++ Makefile.am 2014-09-03 14:15:16.000000000 +0300
-@@ -61,7 +61,7 @@ SUBDIRS = src $(MAYBE_DOC) $(MAYBE_TESTD
+--- Makefile.am.orig 2021-08-14 20:26:24 UTC
++++ Makefile.am
+@@ -60,7 +60,7 @@ SUBDIRS = src $(MAYBE_DOC) $(MAYBE_TESTS)
DIST_SUBDIRS = src doc test-data spandsp-sim tests
diff --git a/comms/spandsp/files/patch-configure.ac b/comms/spandsp/files/patch-configure.ac
deleted file mode 100644
index 6863077083ad..000000000000
--- a/comms/spandsp/files/patch-configure.ac
+++ /dev/null
@@ -1,37 +0,0 @@
---- configure.ac.orig 2014-11-11 15:56:10.000000000 +0100
-+++ configure.ac 2014-11-11 15:58:13.000000000 +0100
-@@ -198,7 +198,6 @@ AC_CHECK_HEADERS([stdlib.h])
- AC_CHECK_HEADERS([string.h])
- AC_CHECK_HEADERS([strings.h])
- AC_CHECK_HEADERS([malloc.h])
--AC_CHECK_HEADERS([tgmath.h], [INSERT_TGMATH_HEADER="#include <tgmath.h>"])
- AC_CHECK_HEADERS([math.h], [INSERT_MATH_HEADER="#include <math.h>"])
- AC_CHECK_HEADERS([float.h])
- AC_CHECK_HEADERS([fcntl.h])
-@@ -331,7 +330,7 @@ AX_CHECK_EXPORT_CAPABILITY([$host],
-
- case "${ax_cv_c_compiler_vendor}" in
- gnu)
-- COMP_VENDOR_CFLAGS="-std=gnu99 -ffast-math -Wall -Wunused-variable -Wunused-but-set-variable -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes $COMP_VENDOR_CFLAGS"
-+ COMP_VENDOR_CFLAGS="-std=gnu99 -ffast-math -Wall -Wunused-variable -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes $COMP_VENDOR_CFLAGS"
- if test "$enable_avx" = "yes" ; then
- COMP_VENDOR_CFLAGS="-mavx $COMP_VENDOR_CFLAGS"
- fi
-@@ -392,7 +391,7 @@ sun)
- REMOVE_FROM_VAR(CFLAGS, -Xc)
- ;;
- intel)
-- COMP_VENDOR_CFLAGS="-std=c99 -D_POSIX_C_SOURCE=2 -D_GNU_SOURCE=1 -Wall -Wunused-variable -Wunused-but-set-variable -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes $COMP_VENDOR_CFLAGS"
-+ COMP_VENDOR_CFLAGS="-std=c99 -D_POSIX_C_SOURCE=2 -D_GNU_SOURCE=1 -Wall -Wunused-variable -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes $COMP_VENDOR_CFLAGS"
- if test "$enable_avx" = "yes" ; then
- COMP_VENDOR_CFLAGS="-mavx $COMP_VENDOR_CFLAGS"
- fi
-@@ -426,7 +425,7 @@ intel)
- COMP_VENDOR_LDFLAGS=
- ;;
- *)
-- COMP_VENDOR_CFLAGS="-std=c99 -Wall -Wunused-variable -Wunused-but-set-variable -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes $COMP_VENDOR_CFLAGS"
-+ COMP_VENDOR_CFLAGS="-std=c99 -Wall -Wunused-variable -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes $COMP_VENDOR_CFLAGS"
- COMP_VENDOR_LDFLAGS=
- ;;
- esac
diff --git a/comms/spandsp/pkg-plist b/comms/spandsp/pkg-plist
index 26cc7a306f4e..f983fa3af474 100644
--- a/comms/spandsp/pkg-plist
+++ b/comms/spandsp/pkg-plist
@@ -1,5 +1,6 @@
include/spandsp.h
include/spandsp/adsi.h
+include/spandsp/alloc.h
include/spandsp/arctan2.h
include/spandsp/async.h
include/spandsp/at_interpreter.h
@@ -14,6 +15,7 @@ include/spandsp/complex_filters.h
include/spandsp/complex_vector_float.h
include/spandsp/crc.h
include/spandsp/dc_restore.h
+include/spandsp/data_modems.h
include/spandsp/dds.h
include/spandsp/dtmf.h
include/spandsp/echo.h
@@ -84,6 +86,7 @@ include/spandsp/private/awgn.h
include/spandsp/private/bell_r2_mf.h
include/spandsp/private/bert.h
include/spandsp/private/bitstream.h
+include/spandsp/private/data_modems.h
include/spandsp/private/dtmf.h
include/spandsp/private/echo.h
include/spandsp/private/fax.h
@@ -102,6 +105,9 @@ include/spandsp/private/modem_connect_tones.h
include/spandsp/private/modem_echo.h
include/spandsp/private/noise.h
include/spandsp/private/oki_adpcm.h
+include/spandsp/private/playout.h
+include/spandsp/private/plc.h
+include/spandsp/private/power_meter.h
include/spandsp/private/queue.h
include/spandsp/private/schedule.h
include/spandsp/private/sig_tone.h
@@ -120,6 +126,10 @@ include/spandsp/private/t4_rx.h
include/spandsp/private/t4_t6_decode.h
include/spandsp/private/t4_t6_encode.h
include/spandsp/private/t4_tx.h
+include/spandsp/private/t42.h
+include/spandsp/private/t43.h
+include/spandsp/private/t81_t82_arith_coding.h
+include/spandsp/private/t85.h
include/spandsp/private/time_scale.h
include/spandsp/private/timezone.h
include/spandsp/private/tone_detect.h
@@ -143,10 +153,14 @@ include/spandsp/t4_rx.h
include/spandsp/t4_t6_decode.h
include/spandsp/t4_t6_encode.h
include/spandsp/t4_tx.h
+include/spandsp/t42.h
+include/spandsp/t43.h
+include/spandsp/t81_t82_arith_coding.h
+include/spandsp/t85.h
include/spandsp/timezone.h
include/spandsp/v18.h
lib/libspandsp.a
lib/libspandsp.so
-lib/libspandsp.so.2
-lib/libspandsp.so.2.0.0
+lib/libspandsp.so.3
+lib/libspandsp.so.3.0.0
libdata/pkgconfig/spandsp.pc
diff --git a/misc/libsupertone/Makefile b/misc/libsupertone/Makefile
index 50f0470f0355..6fa204d32581 100644
--- a/misc/libsupertone/Makefile
+++ b/misc/libsupertone/Makefile
@@ -2,7 +2,7 @@
PORTNAME= libsupertone
PORTVERSION= 0.0.2
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= misc
MASTER_SITES= http://www.soft-switch.org/downloads/unicall/
diff --git a/net/asterisk16/Makefile b/net/asterisk16/Makefile
index e6cd9b6db497..2c26caf0037e 100644
--- a/net/asterisk16/Makefile
+++ b/net/asterisk16/Makefile
@@ -1,5 +1,6 @@
PORTNAME= asterisk
PORTVERSION= 16.22.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= https://downloads.asterisk.org/pub/telephony/%SUBDIR%/:DEFAULT,g729
MASTER_SITE_SUBDIR= asterisk/ \
diff --git a/net/asterisk16/files/patch-res_res__fax__spandsp.c b/net/asterisk16/files/patch-res_res__fax__spandsp.c
new file mode 100644
index 000000000000..7efe45d3e616
--- /dev/null
+++ b/net/asterisk16/files/patch-res_res__fax__spandsp.c
@@ -0,0 +1,62 @@
+--- res/res_fax_spandsp.c.orig 2021-11-02 08:40:01 UTC
++++ res/res_fax_spandsp.c
+@@ -167,8 +167,8 @@ struct spandsp_pvt {
+ static int spandsp_v21_new(struct spandsp_pvt *p);
+ static void session_destroy(struct spandsp_pvt *p);
+ static int t38_tx_packet_handler(t38_core_state_t *t38_core_state, void *data, const uint8_t *buf, int len, int count);
+-static void t30_phase_e_handler(t30_state_t *t30_state, void *data, int completion_code);
+-static void spandsp_log(int level, const char *msg);
++static void t30_phase_e_handler(void *data, int completion_code);
++static void spandsp_log(void *user_data, int level, const char *msg);
+ static int update_stats(struct spandsp_pvt *p, int completion_code);
+ static int spandsp_modems(struct ast_fax_session_details *details);
+
+@@ -375,10 +375,11 @@ static int update_stats(struct spandsp_pvt *p, int com
+ * This function pulls stats from the spandsp stack and stores them for res_fax
+ * to use later.
+ */
+-static void t30_phase_e_handler(t30_state_t *t30_state, void *data, int completion_code)
++static void t30_phase_e_handler(void *data, int completion_code)
+ {
+ struct ast_fax_session *s = data;
+ struct spandsp_pvt *p = s->tech_pvt;
++ t30_state_t *t30_state = p->t30_state;
+ char headerinfo[T30_MAX_PAGE_HEADER_INFO + 1];
+ const char *c;
+ t30_stats_t stats;
+@@ -430,7 +431,7 @@ static void t30_phase_e_handler(t30_state_t *t30_state
+ *
+ * \note This function is a callback function called by spandsp.
+ */
+-static void spandsp_log(int level, const char *msg)
++static void spandsp_log(void *user_data, int level, const char *msg)
+ {
+ if (level == SPAN_LOG_ERROR) {
+ ast_log(LOG_ERROR, "%s", msg);
+@@ -449,7 +450,7 @@ static void set_logging(logging_state_t *state, struct
+ level = SPAN_LOG_DEBUG_3;
+ }
+
+- span_log_set_message_handler(state, spandsp_log);
++ span_log_set_message_handler(state, spandsp_log, NULL);
+ span_log_set_level(state, SPAN_LOG_SHOW_SEVERITY | SPAN_LOG_SHOW_PROTOCOL | level);
+ }
+
+@@ -479,7 +480,7 @@ static void set_file(t30_state_t *t30_state, struct as
+ static void set_ecm(t30_state_t *t30_state, struct ast_fax_session_details *details)
+ {
+ t30_set_ecm_capability(t30_state, details->option.ecm);
+- t30_set_supported_compressions(t30_state, T30_SUPPORT_T4_1D_COMPRESSION | T30_SUPPORT_T4_2D_COMPRESSION | T30_SUPPORT_T6_COMPRESSION);
++ t30_set_supported_compressions(t30_state, T4_COMPRESSION_T4_1D | T4_COMPRESSION_T4_2D | T4_COMPRESSION_T6);
+ }
+
+ static int spandsp_v21_new(struct spandsp_pvt *p)
+@@ -1256,7 +1257,7 @@ static int load_module(void)
+ }
+
+ /* prevent logging to stderr */
+- span_set_message_handler(NULL);
++ span_set_message_handler(NULL, NULL);
+
+ return AST_MODULE_LOAD_SUCCESS;
+ }
diff --git a/net/asterisk18/Makefile b/net/asterisk18/Makefile
index 9e8daffc76cf..066d77629b52 100644
--- a/net/asterisk18/Makefile
+++ b/net/asterisk18/Makefile
@@ -1,5 +1,6 @@
PORTNAME= asterisk
PORTVERSION= 18.8.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= https://downloads.asterisk.org/pub/telephony/%SUBDIR%/:DEFAULT,g729
MASTER_SITE_SUBDIR= asterisk/ \
diff --git a/net/asterisk18/files/patch-res_res__fax__spandsp.c b/net/asterisk18/files/patch-res_res__fax__spandsp.c
new file mode 100644
index 000000000000..5ad7b22a40ad
--- /dev/null
+++ b/net/asterisk18/files/patch-res_res__fax__spandsp.c
@@ -0,0 +1,62 @@
+--- res/res_fax_spandsp.c.orig 2021-11-02 08:42:19 UTC
++++ res/res_fax_spandsp.c
+@@ -167,8 +167,8 @@ struct spandsp_pvt {
+ static int spandsp_v21_new(struct spandsp_pvt *p);
+ static void session_destroy(struct spandsp_pvt *p);
+ static int t38_tx_packet_handler(t38_core_state_t *t38_core_state, void *data, const uint8_t *buf, int len, int count);
+-static void t30_phase_e_handler(t30_state_t *t30_state, void *data, int completion_code);
+-static void spandsp_log(int level, const char *msg);
++static void t30_phase_e_handler(void *data, int completion_code);
++static void spandsp_log(void *user_data, int level, const char *msg);
+ static int update_stats(struct spandsp_pvt *p, int completion_code);
+ static int spandsp_modems(struct ast_fax_session_details *details);
+
+@@ -375,10 +375,11 @@ static int update_stats(struct spandsp_pvt *p, int com
+ * This function pulls stats from the spandsp stack and stores them for res_fax
+ * to use later.
+ */
+-static void t30_phase_e_handler(t30_state_t *t30_state, void *data, int completion_code)
++static void t30_phase_e_handler(void *data, int completion_code)
+ {
+ struct ast_fax_session *s = data;
+ struct spandsp_pvt *p = s->tech_pvt;
++ t30_state_t *t30_state = p->t30_state;
+ char headerinfo[T30_MAX_PAGE_HEADER_INFO + 1];
+ const char *c;
+ t30_stats_t stats;
+@@ -430,7 +431,7 @@ static void t30_phase_e_handler(t30_state_t *t30_state
+ *
+ * \note This function is a callback function called by spandsp.
+ */
+-static void spandsp_log(int level, const char *msg)
++static void spandsp_log(void *user_data, int level, const char *msg)
+ {
+ if (level == SPAN_LOG_ERROR) {
+ ast_log(LOG_ERROR, "%s", msg);
+@@ -449,7 +450,7 @@ static void set_logging(logging_state_t *state, struct
+ level = SPAN_LOG_DEBUG_3;
+ }
+
+- span_log_set_message_handler(state, spandsp_log);
++ span_log_set_message_handler(state, spandsp_log, NULL);
+ span_log_set_level(state, SPAN_LOG_SHOW_SEVERITY | SPAN_LOG_SHOW_PROTOCOL | level);
+ }
+
+@@ -479,7 +480,7 @@ static void set_file(t30_state_t *t30_state, struct as
+ static void set_ecm(t30_state_t *t30_state, struct ast_fax_session_details *details)
+ {
+ t30_set_ecm_capability(t30_state, details->option.ecm);
+- t30_set_supported_compressions(t30_state, T30_SUPPORT_T4_1D_COMPRESSION | T30_SUPPORT_T4_2D_COMPRESSION | T30_SUPPORT_T6_COMPRESSION);
++ t30_set_supported_compressions(t30_state, T4_COMPRESSION_T4_1D | T4_COMPRESSION_T4_2D | T4_COMPRESSION_T6);
+ }
+
+ static int spandsp_v21_new(struct spandsp_pvt *p)
+@@ -1256,7 +1257,7 @@ static int load_module(void)
+ }
+
+ /* prevent logging to stderr */
+- span_set_message_handler(NULL);
++ span_set_message_handler(NULL, NULL);
+
+ return AST_MODULE_LOAD_SUCCESS;
+ }
diff --git a/net/mediastreamer/Makefile b/net/mediastreamer/Makefile
index 8296916b6484..98affa033a07 100644
--- a/net/mediastreamer/Makefile
+++ b/net/mediastreamer/Makefile
@@ -2,7 +2,7 @@
PORTNAME= mediastreamer
PORTVERSION= 2.16.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= net
MASTER_SITES= https://www.linphone.org/releases/sources/mediastreamer/
diff --git a/net/opal/Makefile b/net/opal/Makefile
index b63dc9ffce3b..7533159ed87e 100644
--- a/net/opal/Makefile
+++ b/net/opal/Makefile
@@ -2,7 +2,7 @@
PORTNAME= opal
PORTVERSION= 3.10.10
-PORTREVISION= 28
+PORTREVISION= 29
CATEGORIES= net
MASTER_SITES= GNOME
diff --git a/net/opal/files/patch-plugins_fax_fax__spandsp_spandsp__fax.cpp b/net/opal/files/patch-plugins_fax_fax__spandsp_spandsp__fax.cpp
new file mode 100644
index 000000000000..7e74990ce577
--- /dev/null
+++ b/net/opal/files/patch-plugins_fax_fax__spandsp_spandsp__fax.cpp
@@ -0,0 +1,153 @@
+--- plugins/fax/fax_spandsp/spandsp_fax.cpp.orig 2013-02-20 02:18:10 UTC
++++ plugins/fax/fax_spandsp/spandsp_fax.cpp
+@@ -82,7 +82,7 @@ static PluginCodec_LogFunction LogFunction;
+ LogFunction(level, __FILE__, __LINE__, "FaxCodec", strm.str().c_str()); \
+ } else (void)0
+
+-static void SpanDSP_Message(int level, const char *text)
++static void SpanDSP_Message(void *user_data, int level, const char *text)
+ {
+ if (*text != '\0' && LogFunction != NULL) {
+ if (level >= SPAN_LOG_DEBUG)
+@@ -117,7 +117,7 @@ static void SpanDSP_Message(int level, const char *tex
+
+ static void InitLogging(logging_state_t * logging, const std::string & tag)
+ {
+- span_log_set_message_handler(logging, SpanDSP_Message);
++ span_log_set_message_handler(logging, SpanDSP_Message, NULL);
+
+ int level = SPAN_LOG_SHOW_SEVERITY | SPAN_LOG_SHOW_PROTOCOL | SPAN_LOG_DEBUG;
+
+@@ -807,7 +807,7 @@ class MyStats : private t30_stats_t (public)
+ strm << "-1 (In progress)";
+ strm << "\n"
+ "Bit Rate=" << stats.bit_rate << "\n"
+- "Encoding=" << stats.encoding << ' ' << CompressionNames[stats.encoding&3] << "\n"
++ "Encoding=" << stats.compression << ' ' << CompressionNames[stats.compression&3] << "\n"
+ "Error Correction=" << stats.error_correcting_mode << "\n"
+ "Tx Pages=" << (stats.m_receiving ? -1 : stats.pages_tx) << "\n"
+ "Rx Pages=" << (stats.m_receiving ? stats.pages_rx : -1) << "\n"
+@@ -839,25 +839,27 @@ class FaxTIFF : public FaxSpanDSP
+ char m_phase;
+
+ protected:
++ t30_state_t * m_t30State;
++
+ FaxTIFF()
+ : m_receiving(false)
+ , m_stationIdentifer("-")
+- , m_supported_image_sizes(T30_SUPPORT_US_LETTER_LENGTH |
+- T30_SUPPORT_US_LEGAL_LENGTH |
+- T30_SUPPORT_UNLIMITED_LENGTH |
+- T30_SUPPORT_A4_LENGTH |
+- T30_SUPPORT_B4_LENGTH |
+- T30_SUPPORT_215MM_WIDTH |
+- T30_SUPPORT_255MM_WIDTH |
+- T30_SUPPORT_303MM_WIDTH)
+- , m_supported_resolutions(T30_SUPPORT_STANDARD_RESOLUTION |
+- T30_SUPPORT_FINE_RESOLUTION |
+- T30_SUPPORT_SUPERFINE_RESOLUTION |
+- T30_SUPPORT_R8_RESOLUTION |
+- T30_SUPPORT_R16_RESOLUTION)
+- , m_supported_compressions(T30_SUPPORT_T4_1D_COMPRESSION |
+- T30_SUPPORT_T4_2D_COMPRESSION |
+- T30_SUPPORT_T6_COMPRESSION)
++ , m_supported_image_sizes(T4_SUPPORT_LENGTH_US_LETTER |
++ T4_SUPPORT_LENGTH_US_LEGAL |
++ T4_SUPPORT_LENGTH_UNLIMITED |
++ T4_SUPPORT_LENGTH_A4 |
++ T4_SUPPORT_LENGTH_B4 |
++ T4_SUPPORT_WIDTH_215MM |
++ T4_SUPPORT_WIDTH_255MM |
++ T4_SUPPORT_WIDTH_303MM)
++ , m_supported_resolutions(T4_RESOLUTION_R8_STANDARD |
++ T4_RESOLUTION_R8_FINE |
++ T4_RESOLUTION_R8_SUPERFINE |
++ T4_RESOLUTION_200_400 |
++ T4_RESOLUTION_400_400)
++ , m_supported_compressions(T4_COMPRESSION_T4_1D |
++ T4_COMPRESSION_T4_2D |
++ T4_COMPRESSION_T6)
+ , m_phase('A')
+ {
+ }
+@@ -932,6 +934,7 @@ class FaxTIFF : public FaxSpanDSP
+ PTRACE(3, m_tag << " Set transmit TIFF file to \"" << m_tiffFileName << '"');
+ }
+
++ m_t30State = t30state;
+ t30_set_phase_b_handler(t30state, PhaseB, this);
+ t30_set_phase_d_handler(t30state, PhaseD, this);
+ t30_set_phase_e_handler(t30state, PhaseE, this);
+@@ -948,7 +951,7 @@ class FaxTIFF : public FaxSpanDSP
+
+ t30_set_supported_modems(t30state, m_supported_modems);
+ t30_set_supported_image_sizes(t30state, m_supported_image_sizes);
+- t30_set_supported_resolutions(t30state, m_supported_resolutions);
++ t30_set_supported_bilevel_resolutions(t30state, m_supported_resolutions);
+ t30_set_supported_compressions(t30state, m_supported_compressions);
+ t30_set_ecm_capability(t30state, m_useECM);
+
+@@ -983,50 +986,50 @@ class FaxTIFF : public FaxSpanDSP
+ bool IsReceiving() const { return m_receiving; }
+
+
+- static int PhaseB(t30_state_t * t30state, void * user_data, int result)
++ static int PhaseB(void * user_data, int result)
+ {
+ if (user_data != NULL)
+- ((FaxTIFF *)user_data)->PhaseB(t30state, result);
++ ((FaxTIFF *)user_data)->PhaseB(result);
+ return T30_ERR_OK;
+ }
+
+- static int PhaseD(t30_state_t * t30state, void * user_data, int result)
++ static int PhaseD(void * user_data, int result)
+ {
+ if (user_data != NULL)
+- ((FaxTIFF *)user_data)->PhaseD(t30state, result);
++ ((FaxTIFF *)user_data)->PhaseD(result);
+ return T30_ERR_OK;
+ }
+
+- static void PhaseE(t30_state_t * t30state, void * user_data, int result)
++ static void PhaseE(void * user_data, int result)
+ {
+ if (user_data != NULL)
+- ((FaxTIFF *)user_data)->PhaseE(t30state, result);
++ ((FaxTIFF *)user_data)->PhaseE(result);
+ }
+
+
+ private:
+- void PhaseB(t30_state_t * t30state, int)
++ void PhaseB(int)
+ {
+ m_phase = 'B';
+ PTRACE(3, m_tag << " SpanDSP entered Phase B:\n"
+- << MyStats(t30state, m_completed, m_receiving, m_phase));
++ << MyStats(this->m_t30State, m_completed, m_receiving, m_phase));
+ }
+
+- void PhaseD(t30_state_t * t30state, int)
++ void PhaseD(int)
+ {
+ m_phase = 'D';
+ PTRACE(3, m_tag << " SpanDSP entered Phase D:\n"
+- << MyStats(t30state, m_completed, m_receiving, m_phase));
++ << MyStats(this->m_t30State, m_completed, m_receiving, m_phase));
+ }
+
+- void PhaseE(t30_state_t * t30state, int result)
++ void PhaseE(int result)
+ {
+ if (result >= 0)
+ m_completed = true; // Finished, exit codec loops
+
+ m_phase = 'E';
+ PTRACE(3, m_tag << " SpanDSP entered Phase E:\n"
+- << MyStats(t30state, m_completed, m_receiving, m_phase));
++ << MyStats(this->m_t30State, m_completed, m_receiving, m_phase));
+ }
+ };
+
diff --git a/net/sems/Makefile b/net/sems/Makefile
index e712b34c8947..8e04acc48f8e 100644
--- a/net/sems/Makefile
+++ b/net/sems/Makefile
@@ -2,6 +2,7 @@
PORTNAME= sems
DISTVERSION= ${SEMS_VERSION}.g20200510
+PORTREVISION= 1
CATEGORIES= net
MAINTAINER= nwhitehorn@FreeBSD.org
diff --git a/net/wireshark/Makefile b/net/wireshark/Makefile
index 6bbc31c07903..7afe05b110d1 100644
--- a/net/wireshark/Makefile
+++ b/net/wireshark/Makefile
@@ -2,6 +2,7 @@
PORTNAME?= wireshark
PORTVERSION= 3.4.9
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.wireshark.org/download/src/ \
http://ftp.uni-kl.de/pub/wireshark/src/ \
diff --git a/net/yate/Makefile b/net/yate/Makefile
index 48169a364bdc..5ff7898bfd47 100644
--- a/net/yate/Makefile
+++ b/net/yate/Makefile
@@ -2,6 +2,7 @@
PORTNAME= yate
PORTVERSION= 6.4.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://yate.null.ro/tarballs/yate6/
DISTNAME= ${PORTNAME}-${PORTVERSION}-1