aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2021-12-21 21:52:07 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2021-12-22 17:04:26 +0000
commita59c3bf8a31f17d91f05b0ef628ba3e0f78e912f (patch)
treeda6dfb7a8c0d5824deec3037f99ba885fc9ec66c
parent32b5ce56b22698a654e2e2b878c614bc52abd07d (diff)
downloadports-a59c3bf8a31f17d91f05b0ef628ba3e0f78e912f.tar.gz
ports-a59c3bf8a31f17d91f05b0ef628ba3e0f78e912f.zip
www/gitlab-ce: update to 14.6.0
-rw-r--r--www/gitlab-ce/Makefile29
-rw-r--r--www/gitlab-ce/distinfo6
-rw-r--r--www/gitlab-ce/files/gitlab.in4
-rw-r--r--www/gitlab-ce/files/patch-Gemfile19
-rw-r--r--www/gitlab-ce/files/patch-config_gitlab.yml.example29
-rw-r--r--www/gitlab-ce/pkg-message6
6 files changed, 62 insertions, 31 deletions
diff --git a/www/gitlab-ce/Makefile b/www/gitlab-ce/Makefile
index 606b29514973..fcd2607e0ac4 100644
--- a/www/gitlab-ce/Makefile
+++ b/www/gitlab-ce/Makefile
@@ -1,8 +1,8 @@
# Created by: Torsten Zuehlsdorff <tz@FreeBSD.org>
PORTNAME= gitlab-ce
-PORTVERSION= 14.5.2
-PORTREVISION= 1
+PORTVERSION= 14.6.0
+PORTREVISION= 0
CATEGORIES= www devel
MAINTAINER= mfechner@FreeBSD.org
@@ -15,9 +15,9 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
# which makes maintaining this long list much easier!
MY_DEPENDS= git>=2.32.0:devel/git \
gitaly>=${PORTVERSION}:devel/gitaly \
- gitlab-elasticsearch-indexer>=2.16.0:textproc/gitlab-elasticsearch-indexer \
+ gitlab-elasticsearch-indexer>=2.17.0:textproc/gitlab-elasticsearch-indexer \
gitlab-agent>=14.4.0:net/gitlab-agent \
- gitlab-pages>=1.48.0:www/gitlab-pages \
+ gitlab-pages>=1.49.0:www/gitlab-pages \
gitlab-shell>=13.22.0:devel/gitlab-shell \
gitlab-workhorse>=${PORTVERSION}:www/gitlab-workhorse \
redis>=6.0.14:databases/redis \
@@ -114,7 +114,7 @@ MY_DEPENDS= git>=2.32.0:devel/git \
rubygem-faraday_middleware-aws-sigv403>=0.3.0<0.4:devel/rubygem-faraday_middleware-aws-sigv403 \
rubygem-html-pipeline>=2.13.2<2.14:textproc/rubygem-html-pipeline \
rubygem-deckar01-task_list=2.3.1:www/rubygem-deckar01-task_list \
- rubygem-gitlab-markup>=1.7.1<1.8.0:textproc/rubygem-gitlab-markup \
+ rubygem-gitlab-markup>=1.8.0<1.9.0:textproc/rubygem-gitlab-markup \
rubygem-github-markup17>=1.7.0<1.8.0:textproc/rubygem-github-markup17 \
rubygem-commonmarker>=0.23.2<0.24:textproc/rubygem-commonmarker \
rubygem-kramdown>=2.3.1<2.4:textproc/rubygem-kramdown \
@@ -137,12 +137,12 @@ MY_DEPENDS= git>=2.32.0:devel/git \
rubygem-diff_match_patch>=0.1.0<0.2.0:textproc/rubygem-diff_match_patch \
rubygem-rack>=2.2.3<2.3,3:www/rubygem-rack \
rubygem-rack-timeout>=0.5.1<0.6:www/rubygem-rack-timeout \
- rubygem-puma>=5.3.1<5.4:www/rubygem-puma \
+ rubygem-puma>=5.5.2<5.6:www/rubygem-puma \
rubygem-puma_worker_killer>=0.3.1:www/rubygem-puma_worker_killer \
rubygem-sd_notify>=0.1.0<0.2:devel/rubygem-sd_notify \
rubygem-state_machines-activerecord>=0.8.0<0.9.0:databases/rubygem-state_machines-activerecord \
- rubygem-acts-as-taggable-on>=7.0<8.0:www/rubygem-acts-as-taggable-on \
- rubygem-sidekiq62>=6.2.2<6.3:devel/rubygem-sidekiq62 \
+ rubygem-acts-as-taggable-on>=8.1<8.2:www/rubygem-acts-as-taggable-on \
+ rubygem-sidekiq>=6.3<6.4:devel/rubygem-sidekiq \
rubygem-sidekiq-cron>=1.0<2.0:devel/rubygem-sidekiq-cron \
rubygem-redis-namespace>=1.8.1<1.9.0:databases/rubygem-redis-namespace \
rubygem-gitlab-sidekiq-fetcher>=0.8.0<0.9:devel/rubygem-gitlab-sidekiq-fetcher \
@@ -204,7 +204,7 @@ MY_DEPENDS= git>=2.32.0:devel/git \
rubygem-webrick>=1.6.1:www/rubygem-webrick \
rubygem-prometheus-client-mmap>=0.15.0<0.16.0:devel/rubygem-prometheus-client-mmap \
rubygem-warning>=1.2.0<1.3:devel/rubygem-warning \
- rubygem-license_finder>=6.0<7:devel/rubygem-license_finder \
+ rubygem-gitlab-license_finder>=6.14.2.1<7:devel/rubygem-gitlab-license_finder \
rubygem-octokit>=4.20<5.0:net/rubygem-octokit \
rubygem-gitlab-mail_room>=0.0.9<0.1.0:mail/rubygem-gitlab-mail_room \
rubygem-email_reply_trimmer>=0.1<1.0:mail/rubygem-email_reply_trimmer \
@@ -218,12 +218,12 @@ MY_DEPENDS= git>=2.32.0:devel/git \
rubygem-oauth2>=1.4.7<2.0:net/rubygem-oauth2 \
rubygem-health_check>=3.0<4:devel/rubygem-health_check \
rubygem-vmstat>=2.3.0<2.4.0:sysutils/rubygem-vmstat \
- rubygem-sys-filesystem>=1.1.9<1.2.0:sysutils/rubygem-sys-filesystem \
+ rubygem-sys-filesystem>=1.4.3<1.5:sysutils/rubygem-sys-filesystem \
rubygem-net-ntp>0:net/rubygem-net-ntp \
rubygem-net-ssh>=6.0<7,2:security/rubygem-net-ssh \
rubygem-sshkey>=2.0<3.0:security/rubygem-sshkey \
rubygem-ed25519>=1.2<2.0:security/rubygem-ed25519 \
- rubygem-bcrypt_pbkdf>=1.0<2.0:security/rubygem-bcrypt_pbkdf \
+ rubygem-bcrypt_pbkdf>=1.1<2.0:security/rubygem-bcrypt_pbkdf \
rubygem-spamcheck>=0.1.0<0.2:net/rubygem-spamcheck \
rubygem-gitaly>=14.4.0.pre.rc43<14.5.0:net/rubygem-gitaly \
rubygem-kas-grpc>=0.0.2,1<0.0.3,1:net/rubygem-kas-grpc \
@@ -234,7 +234,7 @@ MY_DEPENDS= git>=2.32.0:devel/git \
rubygem-flipper-active_record-rails61>=0.21.0<0.22:databases/rubygem-flipper-active_record-rails61 \
rubygem-flipper-active_support_cache_store-rails61>=0.21.0<0.22:devel/rubygem-flipper-active_support_cache_store-rails61 \
rubygem-unleash>=3.2.2<3.3:devel/rubygem-unleash \
- rubygem-gitlab-experiment>=0.6.4<0.7:devel/rubygem-gitlab-experiment \
+ rubygem-gitlab-experiment>=0.6.5<0.7:devel/rubygem-gitlab-experiment \
rubygem-lograge-rails61>=0.11.2<1.0:www/rubygem-lograge-rails61 \
rubygem-grape_logging>=1.7<2.0:devel/rubygem-grape_logging \
rubygem-gitlab-net-dns>=0.9.1<0.10:dns/rubygem-gitlab-net-dns \
@@ -253,7 +253,7 @@ MY_DEPENDS= git>=2.32.0:devel/git \
rubygem-webauthn>=2.3<3:security/rubygem-webauthn \
rubygem-ipaddress>=0.8.3<0.9:net/rubygem-ipaddress \
rubygem-parslet1>=1.8<2:textproc/rubygem-parslet1 \
- rubygem-ipynbdiff>=0.3.7<0.3.8:devel/rubygem-ipynbdiff
+ rubygem-ipynbdiff>=0.3.8<0.3.9:devel/rubygem-ipynbdiff
BUILD_DEPENDS= gem:devel/ruby-gems \
${MY_DEPENDS}
@@ -274,7 +274,7 @@ USE_GITLAB= yes
GL_ACCOUNT= gitlab-org
GL_PROJECT= gitlab-foss
# Find the here: https://gitlab.com/gitlab-org/gitlab-foss/-/tags
-GL_COMMIT= 76ceea558aae5013c4e16b3b2f97363608765c21
+GL_COMMIT= 3bc07a0be9ce3b8f736890a0513283f04796b37e
USERS= git
GROUPS= git
@@ -364,6 +364,7 @@ post-install:
@${ECHO_CMD} "@dir ${WWWDIR_REL}/public" >> ${TMPPLIST}
@${ECHO_CMD} "@dir ${WWWDIR_REL}/public/assets" >> ${TMPPLIST}
@${ECHO_CMD} "@dir(,,700) ${WWWDIR_REL}/public/uploads" >> ${TMPPLIST}
+ @${ECHO_CMD} "@dir ${WWWDIR_REL}/qa/knapsack/gcs" >> ${TMPPLIST}
@${ECHO_CMD} "@dir ${WWWDIR_REL}/qa/qa/specs/features/api/2_plan" >> ${TMPPLIST}
@${ECHO_CMD} "@dir ${WWWDIR_REL}/qa/qa/specs/features/api/4_verify" >> ${TMPPLIST}
@${ECHO_CMD} "@dir ${WWWDIR_REL}/qa/qa/specs/features/api/5_package" >> ${TMPPLIST}
diff --git a/www/gitlab-ce/distinfo b/www/gitlab-ce/distinfo
index 109e0a3f40c9..e9b835cf058d 100644
--- a/www/gitlab-ce/distinfo
+++ b/www/gitlab-ce/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1638857691
-SHA256 (gitlab-org-gitlab-foss-76ceea558aae5013c4e16b3b2f97363608765c21_GL0.tar.gz) = 7a0aef3dcbff8c923521c432b35e43fd99b404677dacfc2a09e6fcec965402be
-SIZE (gitlab-org-gitlab-foss-76ceea558aae5013c4e16b3b2f97363608765c21_GL0.tar.gz) = 102154920
+TIMESTAMP = 1640119232
+SHA256 (gitlab-org-gitlab-foss-3bc07a0be9ce3b8f736890a0513283f04796b37e_GL0.tar.gz) = 16d1e20df3196903d6a6845d622107f62feaab64492ecbcad9aa130f0e6a0771
+SIZE (gitlab-org-gitlab-foss-3bc07a0be9ce3b8f736890a0513283f04796b37e_GL0.tar.gz) = 101490610
diff --git a/www/gitlab-ce/files/gitlab.in b/www/gitlab-ce/files/gitlab.in
index 65591c1429d9..1d81fc3a85df 100644
--- a/www/gitlab-ce/files/gitlab.in
+++ b/www/gitlab-ce/files/gitlab.in
@@ -393,7 +393,7 @@ start_gitlab() {
if [ "$sidekiq_status" = "0" ]; then
echo "The Sidekiq job dispatcher is already running with pid $spid, not restarting"
else
- RAILS_ENV=$RAILS_ENV SIDEKIQ_WORKERS=$SIDEKIQ_WORKERS bin/background_jobs start &
+ RAILS_ENV=$RAILS_ENV SIDEKIQ_WORKERS=$SIDEKIQ_WORKERS bin/background_jobs start > /dev/null &
fi
if [ "$gitlab_workhorse_status" = "0" ]; then
@@ -556,7 +556,7 @@ reload_gitlab(){
echo "Done."
echo "Restarting GitLab Sidekiq since it isn't capable of reloading its config..."
- RAILS_ENV=$RAILS_ENV SIDEKIQ_WORKERS=$SIDEKIQ_WORKERS bin/background_jobs restart
+ RAILS_ENV=$RAILS_ENV SIDEKIQ_WORKERS=$SIDEKIQ_WORKERS bin/background_jobs restart & /dev/null &
if [ "$mail_room_enabled" != true ]; then
echo "Restarting GitLab MailRoom since it isn't capable of reloading its config..."
diff --git a/www/gitlab-ce/files/patch-Gemfile b/www/gitlab-ce/files/patch-Gemfile
index 260e33f1bc43..de7b3a0bd6e1 100644
--- a/www/gitlab-ce/files/patch-Gemfile
+++ b/www/gitlab-ce/files/patch-Gemfile
@@ -1,4 +1,4 @@
---- Gemfile.orig 2021-12-01 10:42:56 UTC
+--- Gemfile.orig 2021-12-21 14:06:23 UTC
+++ Gemfile
@@ -89,7 +89,7 @@ gem 'gpgme', '~> 2.0.19'
# GitLab fork with several improvements to original library. For full list of changes
@@ -9,7 +9,7 @@
# API
gem 'grape', '~> 1.5.2'
-@@ -103,7 +103,6 @@ gem 'graphql', '~> 1.11.8'
+@@ -103,7 +103,6 @@ gem 'graphql', '~> 1.11.10'
# https://gitlab.com/gitlab-org/gitlab/issues/31747
gem 'graphiql-rails', '~> 1.4.10'
gem 'apollo_upload_server', '~> 2.1.0'
@@ -17,7 +17,7 @@
gem 'graphlient', '~> 0.4.0' # Used by BulkImport feature (group::import)
gem 'hashie'
-@@ -330,112 +329,14 @@ gem 'batch-loader', '~> 2.0.1'
+@@ -330,117 +329,14 @@ gem 'batch-loader', '~> 2.0.1'
gem 'peek', '~> 1.1'
# Snowplow events tracking
@@ -68,7 +68,7 @@
- gem 'spring', '~> 2.1.0'
- gem 'spring-commands-rspec', '~> 1.0.4'
-
-- gem 'gitlab-styles', '~> 6.4.0', require: false
+- gem 'gitlab-styles', '~> 6.6.0', require: false
-
- gem 'haml_lint', '~> 0.36.0', require: false
- gem 'bundler-audit', '~> 0.7.0.1', require: false
@@ -92,17 +92,22 @@
-end
-
-group :development, :test, :danger do
-- gem 'gitlab-dangerfiles', '~> 2.5.0', require: false
+- gem 'gitlab-dangerfiles', '~> 2.6.1', require: false
-end
-
-group :development, :test, :coverage do
- gem 'simplecov', '~> 0.18.5', require: false
+- gem 'simplecov-lcov', '~> 0.8.0', require: false
- gem 'simplecov-cobertura', '~> 1.3.1', require: false
+- gem 'undercover', '~> 0.4.4', require: false
-end
-
-# Gems required in omnibus-gitlab pipeline
-group :development, :test, :omnibus do
-- gem 'license_finder', '~> 6.0', require: false
+- # Using a fork until https://github.com/pivotal/LicenseFinder/pull/816 is
+- # resolved. For details, check discussion in
+- # https://gitlab.com/gitlab-org/gitlab/-/merge_requests/74881
+- gem 'gitlab-license_finder', '~> 6.0', require: false
-end
-
-group :test do
@@ -131,7 +136,7 @@
gem 'octokit', '~> 4.15'
# https://gitlab.com/gitlab-org/gitlab/issues/207207
-@@ -483,9 +384,9 @@ gem 'gitaly', '~> 14.4.0.pre.rc43'
+@@ -488,9 +384,9 @@ gem 'gitaly', '~> 14.4.0.pre.rc43'
# KAS GRPC protocol definitions
gem 'kas-grpc', '~> 0.0.2'
diff --git a/www/gitlab-ce/files/patch-config_gitlab.yml.example b/www/gitlab-ce/files/patch-config_gitlab.yml.example
index ee2087c0b875..fedef1cb7416 100644
--- a/www/gitlab-ce/files/patch-config_gitlab.yml.example
+++ b/www/gitlab-ce/files/patch-config_gitlab.yml.example
@@ -1,4 +1,4 @@
---- config/gitlab.yml.example.orig 2021-12-01 10:42:56 UTC
+--- config/gitlab.yml.example.orig 2021-12-21 14:06:23 UTC
+++ config/gitlab.yml.example
@@ -1133,14 +1133,14 @@ production: &base
# real path not the symlink.
@@ -66,7 +66,32 @@
## Webpack settings
# If enabled, this will tell rails to serve frontend assets from the webpack-dev-server running
-@@ -1464,13 +1464,13 @@ test:
+@@ -1255,16 +1255,16 @@ production: &base
+
+ # Sidekiq exporter is webserver built in to Sidekiq to expose Prometheus metrics
+ sidekiq_exporter:
+- # enabled: true
+- # log_enabled: false
+- # address: localhost
+- # port: 8082
++ enabled: true
++ log_enabled: false
++ address: localhost
++ port: 8082
+
+ sidekiq_health_checks:
+- # enabled: true
+- # log_enabled: false
+- # address: localhost
+- # port: 8082
++ enabled: true
++ log_enabled: false
++ address: localhost
++ port: 8082
+
+ # Web exporter is a dedicated Rack server running alongside Puma to expose Prometheus metrics
+ # It runs alongside the `/metrics` endpoints to ease the publish of metrics
+@@ -1470,13 +1470,13 @@ test:
gitaly_address: unix:tmp/tests/gitaly/praefect.socket
gitaly:
diff --git a/www/gitlab-ce/pkg-message b/www/gitlab-ce/pkg-message
index faedfb188f16..cf177d55075a 100644
--- a/www/gitlab-ce/pkg-message
+++ b/www/gitlab-ce/pkg-message
@@ -6,7 +6,7 @@ Gitlab was installed successfully.
You now need to set up the various components of Gitlab, so please
follow the instructions in the guide at:
-https://gitlab.fechner.net/mfechner/Gitlab-docu/blob/master/install/14.5-freebsd.md
+https://gitlab.fechner.net/mfechner/Gitlab-docu/blob/master/install/14.6-freebsd.md
EOM
type: install
}
@@ -18,9 +18,9 @@ EOM
{
message: <<EOM
If you just installed an major upgrade of GitLab, for example you
-switched from 12.6.x to 12.7.x, please follow the instructions in the guide at:
+switched from 14.5.x to 14.6.x, please follow the instructions in the guide at:
-https://gitlab.fechner.net/mfechner/Gitlab-docu/blob/master/update/14.4-14.5-freebsd.md
+https://gitlab.fechner.net/mfechner/Gitlab-docu/blob/master/update/14.5-14.6-freebsd.md
If you just installed an minor upgrade of GitLab please follow
the instructions in the guide at: