aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRainer Hurling <rhurlin@FreeBSD.org>2023-10-30 16:59:22 +0000
committerRainer Hurling <rhurlin@FreeBSD.org>2023-10-30 17:07:30 +0000
commita5b13ac5f0508383b447fc52b994975662f94f0f (patch)
tree998a82cdf25eea95806f3229a5450b1f57d7fd4f
parent1d03b8604e8a0185ad027f7fae1d075ca4d3d03b (diff)
downloadports-a5b13ac5f0508383b447fc52b994975662f94f0f.tar.gz
ports-a5b13ac5f0508383b447fc52b994975662f94f0f.zip
graphics/qgis: Readd patch to fix flex version
For FreeBSD versions < 1300501 the existing version of FLEX in base is unsufficient. Readd old patch to install the ports version of FLEX. CMake Error at /usr/local/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:230 (message): Could NOT find FLEX: Found unsuitable version "2.5.37", but required is at least "2.6" (found /usr/bin/flex) Call Stack (most recent call first): /usr/local/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:598 (_FPHSA_FAILURE_MESSAGE) /usr/local/share/cmake/Modules/FindFLEX.cmake:269 (FIND_PACKAGE_HANDLE_STANDARD_ARGS) CMakeLists.txt:339 (find_package) Thanks to Martin Birgmeier <d8zNeCFG@aon.at> for reporting. PR: 274793
-rw-r--r--graphics/qgis/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/graphics/qgis/Makefile b/graphics/qgis/Makefile
index f3ce0f39b2f4..6a6c40892a08 100644
--- a/graphics/qgis/Makefile
+++ b/graphics/qgis/Makefile
@@ -1,5 +1,6 @@
PORTNAME= qgis
DISTVERSION= 3.34.0
+PORTREVISION= 1
CATEGORIES= graphics geography
MASTER_SITES= https://qgis.org/downloads/
@@ -157,6 +158,13 @@ SERVER_CMAKE_BOOL= WITH_SERVER WITH_SERVER_PLUGINS WITH_QSPATIALITE
.include <bsd.port.pre.mk>
+# QGIS requires flex >= 2.5.6, see
+# https://github.com/qgis/QGIS/blob/fb0f334b06e0828e5695ffcaa7c7eb82d6516cb0/INSTALL.md
+.if (${OPSYS} == FreeBSD && ${OSVERSION} < 1300501)
+BUILD_DEPENDS+= ${LOCALBASE}/bin/flex:textproc/flex
+CMAKE_ARGS+= -DFLEX_EXECUTABLE:FILEPATH=${LOCALBASE}/bin/flex
+.endif
+
pre-patch:
# Only PostgreSQL Client headers, not Server
@${REINPLACE_CMD} -e 's|set(POSTGRES_INCLUDE_DIR \$${PostgreSQL_INCLUDE_DIRS})|set(POSTGRES_INCLUDE ${LOCALBASE}/include)|g' \