aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2022-09-10 15:45:01 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2022-09-10 15:45:01 +0000
commita5e2bf07b0d859aa952f9e36c8cddde02e036fe7 (patch)
treefd2f16ebf228099e03abca7c0c353dfbee0a6dc4
parentd560a8cfa2eb8adef1a41120816dfefe9654bf59 (diff)
downloadports-a5e2bf07b0d859aa952f9e36c8cddde02e036fe7.tar.gz
ports-a5e2bf07b0d859aa952f9e36c8cddde02e036fe7.zip
x11/xfce4-windowck-plugin: Add new XFCE plugin
Xfce panel plugin which allows to put the maximized window title and windows buttons on the panel. Original plugin's features: - Show the title and buttons of the maximized window on the panel. - Allow window actions on buttons and title clicks (activate, (un)maximize, close). - Allow window action menu on left button click. - Title formatting options. - xfwm4/unity theming support for buttons. Home page: https://gitlab.xfce.org/panel-plugins/xfce4-windowck-plugin
-rw-r--r--x11/Makefile1
-rw-r--r--x11/xfce4-windowck-plugin/Makefile32
-rw-r--r--x11/xfce4-windowck-plugin/distinfo3
-rw-r--r--x11/xfce4-windowck-plugin/pkg-descr12
-rw-r--r--x11/xfce4-windowck-plugin/pkg-plist209
5 files changed, 257 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index d7dbf4814d9a..29ff223cf291 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -483,6 +483,7 @@
SUBDIR += xfce4-terminal
SUBDIR += xfce4-verve-plugin
SUBDIR += xfce4-whiskermenu-plugin
+ SUBDIR += xfce4-windowck-plugin
SUBDIR += xfd
SUBDIR += xfishtank
SUBDIR += xforward
diff --git a/x11/xfce4-windowck-plugin/Makefile b/x11/xfce4-windowck-plugin/Makefile
new file mode 100644
index 000000000000..58b888b3832c
--- /dev/null
+++ b/x11/xfce4-windowck-plugin/Makefile
@@ -0,0 +1,32 @@
+PORTNAME= xfce4-windowck-plugin
+PORTVERSION= 0.5.0
+CATEGORIES= x11 xfce
+MASTER_SITES= XFCE/panel-plugins
+DIST_SUBDIR= xfce4
+
+MAINTAINER= xfce@FreeBSD.org
+COMMENT= Puts the maximized window title and windows buttons on the panel
+WWW= https://gitlab.xfce.org/panel-plugins/xfce4-windowck-plugin
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libharfbuzz.so:print/harfbuzz
+BUILD_DEPENDS= xdt-csource:devel/xfce4-dev-tools
+
+USES= gettext-tools gmake gnome libtool python:3.7+,build pkgconfig \
+ shebangfix tar:bzip2 xfce xorg
+USE_GNOME= cairo gdkpixbuf2 glib20 gtk30 libwnck3 intltool
+USE_XFCE= panel
+USE_XORG= x11
+SHEBANG_GLOB= *.py
+
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
+
+NLS_USES= gettext-runtime
+NLS_CONFIGURE_ENABLE= nls
+
+.include <bsd.port.mk>
diff --git a/x11/xfce4-windowck-plugin/distinfo b/x11/xfce4-windowck-plugin/distinfo
new file mode 100644
index 000000000000..9229b5c2d031
--- /dev/null
+++ b/x11/xfce4-windowck-plugin/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1662801978
+SHA256 (xfce4/xfce4-windowck-plugin-0.5.0.tar.bz2) = e94697d2d89ec9aeeed0477e98d2fe3fc6fd32c8bc9a357a07798921b7bc8ea6
+SIZE (xfce4/xfce4-windowck-plugin-0.5.0.tar.bz2) = 404966
diff --git a/x11/xfce4-windowck-plugin/pkg-descr b/x11/xfce4-windowck-plugin/pkg-descr
new file mode 100644
index 000000000000..1267d21c5b29
--- /dev/null
+++ b/x11/xfce4-windowck-plugin/pkg-descr
@@ -0,0 +1,12 @@
+Xfce panel plugin which allows to put the maximized window title
+and windows buttons on the panel.
+
+
+Original plugin's features:
+
+ - Show the title and buttons of the maximized window on the panel.
+ - Allow window actions on buttons and title clicks
+ (activate, (un)maximize, close).
+ - Allow window action menu on left button click.
+ - Title formatting options.
+ - xfwm4/unity theming support for buttons.
diff --git a/x11/xfce4-windowck-plugin/pkg-plist b/x11/xfce4-windowck-plugin/pkg-plist
new file mode 100644
index 000000000000..746ef427e207
--- /dev/null
+++ b/x11/xfce4-windowck-plugin/pkg-plist
@@ -0,0 +1,209 @@
+lib/xfce4/panel/plugins/libwckbuttons.so
+lib/xfce4/panel/plugins/libwckmenu.so
+lib/xfce4/panel/plugins/libwindowck.so
+share/icons/hicolor/48x48/apps/wckbuttons-plugin.png
+share/icons/hicolor/48x48/apps/windowck-plugin.png
+%%NLS%%share/locale/bg/LC_MESSAGES/xfce4-windowck-plugin.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/xfce4-windowck-plugin.mo
+%%NLS%%share/locale/de/LC_MESSAGES/xfce4-windowck-plugin.mo
+%%NLS%%share/locale/es/LC_MESSAGES/xfce4-windowck-plugin.mo
+%%NLS%%share/locale/et/LC_MESSAGES/xfce4-windowck-plugin.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/xfce4-windowck-plugin.mo
+%%NLS%%share/locale/he/LC_MESSAGES/xfce4-windowck-plugin.mo
+%%NLS%%share/locale/ie/LC_MESSAGES/xfce4-windowck-plugin.mo
+%%NLS%%share/locale/it/LC_MESSAGES/xfce4-windowck-plugin.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/xfce4-windowck-plugin.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/xfce4-windowck-plugin.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/xfce4-windowck-plugin.mo
+%%NLS%%share/locale/ms/LC_MESSAGES/xfce4-windowck-plugin.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/xfce4-windowck-plugin.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/xfce4-windowck-plugin.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/xfce4-windowck-plugin.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/xfce4-windowck-plugin.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/xfce4-windowck-plugin.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/xfce4-windowck-plugin.mo
+%%NLS%%share/locale/ru_RU/LC_MESSAGES/xfce4-windowck-plugin.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/xfce4-windowck-plugin.mo
+%%NLS%%share/locale/sl/LC_MESSAGES/xfce4-windowck-plugin.mo
+%%NLS%%share/locale/sq/LC_MESSAGES/xfce4-windowck-plugin.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/xfce4-windowck-plugin.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/xfce4-windowck-plugin.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/xfce4-windowck-plugin.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/xfce4-windowck-plugin.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/xfce4-windowck-plugin.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/xfce4-windowck-plugin.mo
+share/themes/Windowck-dark/unity/close.png
+share/themes/Windowck-dark/unity/close_focused_normal.png
+share/themes/Windowck-dark/unity/close_focused_prelight.png
+share/themes/Windowck-dark/unity/close_focused_pressed.png
+share/themes/Windowck-dark/unity/close_unfocused.png
+share/themes/Windowck-dark/unity/maximize.png
+share/themes/Windowck-dark/unity/maximize_focused_normal.png
+share/themes/Windowck-dark/unity/maximize_focused_prelight.png
+share/themes/Windowck-dark/unity/maximize_focused_pressed.png
+share/themes/Windowck-dark/unity/maximize_unfocused.png
+share/themes/Windowck-dark/unity/menu.png
+share/themes/Windowck-dark/unity/menu_focused_normal.png
+share/themes/Windowck-dark/unity/menu_focused_prelight.png
+share/themes/Windowck-dark/unity/menu_focused_pressed.png
+share/themes/Windowck-dark/unity/menu_unfocused.png
+share/themes/Windowck-dark/unity/minimize.png
+share/themes/Windowck-dark/unity/minimize_focused_normal.png
+share/themes/Windowck-dark/unity/minimize_focused_prelight.png
+share/themes/Windowck-dark/unity/minimize_focused_pressed.png
+share/themes/Windowck-dark/unity/minimize_unfocused.png
+share/themes/Windowck-dark/unity/unmaximize.png
+share/themes/Windowck-dark/unity/unmaximize_focused_normal.png
+share/themes/Windowck-dark/unity/unmaximize_focused_prelight.png
+share/themes/Windowck-dark/unity/unmaximize_focused_pressed.png
+share/themes/Windowck-dark/unity/unmaximize_unfocused.png
+share/themes/Windowck-dark/xfwm4/bottom-active.xpm
+share/themes/Windowck-dark/xfwm4/bottom-inactive.xpm
+share/themes/Windowck-dark/xfwm4/bottom-left-active.xpm
+share/themes/Windowck-dark/xfwm4/bottom-left-inactive.xpm
+share/themes/Windowck-dark/xfwm4/bottom-right-active.xpm
+share/themes/Windowck-dark/xfwm4/bottom-right-inactive.xpm
+share/themes/Windowck-dark/xfwm4/close-active.xpm
+share/themes/Windowck-dark/xfwm4/close-inactive.xpm
+share/themes/Windowck-dark/xfwm4/close-prelight.xpm
+share/themes/Windowck-dark/xfwm4/close-pressed.xpm
+share/themes/Windowck-dark/xfwm4/hide-active.xpm
+share/themes/Windowck-dark/xfwm4/hide-inactive.xpm
+share/themes/Windowck-dark/xfwm4/hide-prelight.xpm
+share/themes/Windowck-dark/xfwm4/hide-pressed.xpm
+share/themes/Windowck-dark/xfwm4/left-active.xpm
+share/themes/Windowck-dark/xfwm4/left-inactive.xpm
+share/themes/Windowck-dark/xfwm4/maximize-active.xpm
+share/themes/Windowck-dark/xfwm4/maximize-inactive.xpm
+share/themes/Windowck-dark/xfwm4/maximize-prelight.xpm
+share/themes/Windowck-dark/xfwm4/maximize-pressed.xpm
+share/themes/Windowck-dark/xfwm4/maximize-toggled-active.xpm
+share/themes/Windowck-dark/xfwm4/maximize-toggled-inactive.xpm
+share/themes/Windowck-dark/xfwm4/maximize-toggled-prelight.xpm
+share/themes/Windowck-dark/xfwm4/maximize-toggled-pressed.xpm
+share/themes/Windowck-dark/xfwm4/menu-active.xpm
+share/themes/Windowck-dark/xfwm4/menu-inactive.xpm
+share/themes/Windowck-dark/xfwm4/menu-prelight.xpm
+share/themes/Windowck-dark/xfwm4/menu-pressed.xpm
+share/themes/Windowck-dark/xfwm4/right-active.xpm
+share/themes/Windowck-dark/xfwm4/right-inactive.xpm
+share/themes/Windowck-dark/xfwm4/shade-active.xpm
+share/themes/Windowck-dark/xfwm4/shade-inactive.xpm
+share/themes/Windowck-dark/xfwm4/shade-prelight.xpm
+share/themes/Windowck-dark/xfwm4/shade-pressed.xpm
+share/themes/Windowck-dark/xfwm4/shade-toggled-active.xpm
+share/themes/Windowck-dark/xfwm4/shade-toggled-inactive.xpm
+share/themes/Windowck-dark/xfwm4/shade-toggled-prelight.xpm
+share/themes/Windowck-dark/xfwm4/shade-toggled-pressed.xpm
+share/themes/Windowck-dark/xfwm4/stick-active.xpm
+share/themes/Windowck-dark/xfwm4/stick-inactive.xpm
+share/themes/Windowck-dark/xfwm4/stick-prelight.xpm
+share/themes/Windowck-dark/xfwm4/stick-pressed.xpm
+share/themes/Windowck-dark/xfwm4/stick-toggled-active.xpm
+share/themes/Windowck-dark/xfwm4/stick-toggled-inactive.xpm
+share/themes/Windowck-dark/xfwm4/stick-toggled-prelight.xpm
+share/themes/Windowck-dark/xfwm4/stick-toggled-pressed.xpm
+share/themes/Windowck-dark/xfwm4/themerc
+share/themes/Windowck-dark/xfwm4/title-1-active.xpm
+share/themes/Windowck-dark/xfwm4/title-1-inactive.xpm
+share/themes/Windowck-dark/xfwm4/title-2-active.xpm
+share/themes/Windowck-dark/xfwm4/title-2-inactive.xpm
+share/themes/Windowck-dark/xfwm4/title-3-active.xpm
+share/themes/Windowck-dark/xfwm4/title-3-inactive.xpm
+share/themes/Windowck-dark/xfwm4/title-4-active.xpm
+share/themes/Windowck-dark/xfwm4/title-4-inactive.xpm
+share/themes/Windowck-dark/xfwm4/title-5-active.xpm
+share/themes/Windowck-dark/xfwm4/title-5-inactive.xpm
+share/themes/Windowck-dark/xfwm4/top-left-active.xpm
+share/themes/Windowck-dark/xfwm4/top-left-inactive.xpm
+share/themes/Windowck-dark/xfwm4/top-right-active.xpm
+share/themes/Windowck-dark/xfwm4/top-right-inactive.xpm
+share/themes/Windowck/unity/close.png
+share/themes/Windowck/unity/close_focused_normal.png
+share/themes/Windowck/unity/close_focused_prelight.png
+share/themes/Windowck/unity/close_focused_pressed.png
+share/themes/Windowck/unity/close_unfocused.png
+share/themes/Windowck/unity/maximize.png
+share/themes/Windowck/unity/maximize_focused_normal.png
+share/themes/Windowck/unity/maximize_focused_prelight.png
+share/themes/Windowck/unity/maximize_focused_pressed.png
+share/themes/Windowck/unity/maximize_unfocused.png
+share/themes/Windowck/unity/menu.png
+share/themes/Windowck/unity/menu_focused_normal.png
+share/themes/Windowck/unity/menu_focused_prelight.png
+share/themes/Windowck/unity/menu_focused_pressed.png
+share/themes/Windowck/unity/menu_unfocused.png
+share/themes/Windowck/unity/minimize.png
+share/themes/Windowck/unity/minimize_focused_normal.png
+share/themes/Windowck/unity/minimize_focused_prelight.png
+share/themes/Windowck/unity/minimize_focused_pressed.png
+share/themes/Windowck/unity/minimize_unfocused.png
+share/themes/Windowck/unity/unmaximize.png
+share/themes/Windowck/unity/unmaximize_focused_normal.png
+share/themes/Windowck/unity/unmaximize_focused_prelight.png
+share/themes/Windowck/unity/unmaximize_focused_pressed.png
+share/themes/Windowck/unity/unmaximize_unfocused.png
+share/themes/Windowck/xfwm4/bottom-active.xpm
+share/themes/Windowck/xfwm4/bottom-inactive.xpm
+share/themes/Windowck/xfwm4/bottom-left-active.xpm
+share/themes/Windowck/xfwm4/bottom-left-inactive.xpm
+share/themes/Windowck/xfwm4/bottom-right-active.xpm
+share/themes/Windowck/xfwm4/bottom-right-inactive.xpm
+share/themes/Windowck/xfwm4/close-active.xpm
+share/themes/Windowck/xfwm4/close-inactive.xpm
+share/themes/Windowck/xfwm4/close-prelight.xpm
+share/themes/Windowck/xfwm4/close-pressed.xpm
+share/themes/Windowck/xfwm4/hide-active.xpm
+share/themes/Windowck/xfwm4/hide-inactive.xpm
+share/themes/Windowck/xfwm4/hide-prelight.xpm
+share/themes/Windowck/xfwm4/hide-pressed.xpm
+share/themes/Windowck/xfwm4/left-active.xpm
+share/themes/Windowck/xfwm4/left-inactive.xpm
+share/themes/Windowck/xfwm4/maximize-active.xpm
+share/themes/Windowck/xfwm4/maximize-inactive.xpm
+share/themes/Windowck/xfwm4/maximize-prelight.xpm
+share/themes/Windowck/xfwm4/maximize-pressed.xpm
+share/themes/Windowck/xfwm4/maximize-toggled-active.xpm
+share/themes/Windowck/xfwm4/maximize-toggled-inactive.xpm
+share/themes/Windowck/xfwm4/maximize-toggled-prelight.xpm
+share/themes/Windowck/xfwm4/maximize-toggled-pressed.xpm
+share/themes/Windowck/xfwm4/menu-active.xpm
+share/themes/Windowck/xfwm4/menu-inactive.xpm
+share/themes/Windowck/xfwm4/menu-prelight.xpm
+share/themes/Windowck/xfwm4/menu-pressed.xpm
+share/themes/Windowck/xfwm4/right-active.xpm
+share/themes/Windowck/xfwm4/right-inactive.xpm
+share/themes/Windowck/xfwm4/shade-active.xpm
+share/themes/Windowck/xfwm4/shade-inactive.xpm
+share/themes/Windowck/xfwm4/shade-prelight.xpm
+share/themes/Windowck/xfwm4/shade-pressed.xpm
+share/themes/Windowck/xfwm4/shade-toggled-active.xpm
+share/themes/Windowck/xfwm4/shade-toggled-inactive.xpm
+share/themes/Windowck/xfwm4/shade-toggled-prelight.xpm
+share/themes/Windowck/xfwm4/shade-toggled-pressed.xpm
+share/themes/Windowck/xfwm4/stick-active.xpm
+share/themes/Windowck/xfwm4/stick-inactive.xpm
+share/themes/Windowck/xfwm4/stick-prelight.xpm
+share/themes/Windowck/xfwm4/stick-pressed.xpm
+share/themes/Windowck/xfwm4/stick-toggled-active.xpm
+share/themes/Windowck/xfwm4/stick-toggled-inactive.xpm
+share/themes/Windowck/xfwm4/stick-toggled-prelight.xpm
+share/themes/Windowck/xfwm4/stick-toggled-pressed.xpm
+share/themes/Windowck/xfwm4/themerc
+share/themes/Windowck/xfwm4/title-1-active.xpm
+share/themes/Windowck/xfwm4/title-1-inactive.xpm
+share/themes/Windowck/xfwm4/title-2-active.xpm
+share/themes/Windowck/xfwm4/title-2-inactive.xpm
+share/themes/Windowck/xfwm4/title-3-active.xpm
+share/themes/Windowck/xfwm4/title-3-inactive.xpm
+share/themes/Windowck/xfwm4/title-4-active.xpm
+share/themes/Windowck/xfwm4/title-4-inactive.xpm
+share/themes/Windowck/xfwm4/title-5-active.xpm
+share/themes/Windowck/xfwm4/title-5-inactive.xpm
+share/themes/Windowck/xfwm4/top-left-active.xpm
+share/themes/Windowck/xfwm4/top-left-inactive.xpm
+share/themes/Windowck/xfwm4/top-right-active.xpm
+share/themes/Windowck/xfwm4/top-right-inactive.xpm
+share/xfce4/panel/plugins/wckbuttons.desktop
+share/xfce4/panel/plugins/wckmenu-plugin.desktop
+share/xfce4/panel/plugins/windowck-plugin.desktop