aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@fuz.su>2022-11-12 16:16:17 +0000
committerKoichiro Iwao <meta@FreeBSD.org>2022-12-05 06:25:59 +0000
commita61ecde1c605d0eea2f5daf7516eff383d6d508a (patch)
tree6c36f04cc526c18da3a6f9e383847b9fc4605264
parent54c3365e5a98640d0e3e93788ec873f5e9c7725a (diff)
downloadports-a61ecde1c605d0eea2f5daf7516eff383d6d508a.tar.gz
ports-a61ecde1c605d0eea2f5daf7516eff383d6d508a.zip
lang/see: fix build on armv7 arm64 riscv64
Add missing architecture cases to dtoa_config.h. PR: 267729
-rw-r--r--lang/see/Makefile3
-rw-r--r--lang/see/files/patch-libsee_dtoa__config.h12
2 files changed, 12 insertions, 3 deletions
diff --git a/lang/see/Makefile b/lang/see/Makefile
index bc7cd72ca56a..a4a6c5be6d36 100644
--- a/lang/see/Makefile
+++ b/lang/see/Makefile
@@ -18,9 +18,6 @@ LICENSE_FILE_BSD3CLAUSE= ${WRKSRC}/COPYING
LICENSE_FILE_DTOA.C= ${WRKSRC}/COPYING
LICENSE_PERMS_DTOA.C= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-BROKEN_aarch64= fails to build: error: "Exactly one of IEEE_8087, IEEE_MC68k, VAX, or IBM should be defined."
-BROKEN_riscv64= fails to build: error: "Exactly one of IEEE_8087, IEEE_MC68k, VAX, or IBM should be defined."
-
OPTIONS_DEFINE= GC DEBUG DOCS
OPTIONS_DEFAULT= GC
GC_DESC= Use Boehm-Weiser garbage collection package
diff --git a/lang/see/files/patch-libsee_dtoa__config.h b/lang/see/files/patch-libsee_dtoa__config.h
new file mode 100644
index 000000000000..3dd1dd64d754
--- /dev/null
+++ b/lang/see/files/patch-libsee_dtoa__config.h
@@ -0,0 +1,12 @@
+--- libsee/dtoa_config.h.orig 2022-11-12 15:54:29 UTC
++++ libsee/dtoa_config.h
+@@ -11,7 +11,8 @@
+
+ #include <see/type.h>
+
+-#if defined(__i386__) || defined(__amd64__) || defined(__ia64__) || defined(__alpha__)
++#if defined(__i386__) || defined(__amd64__) || defined(__ia64__) || defined(__alpha__) \
++ || defined(__arm__) || defined(__aarch64__) || defined(__riscv)
+ # define IEEE_8087
+ #endif
+