aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-11-01 05:30:13 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-11-01 05:30:13 +0000
commita6509f48443ae46b2fbc39a88603b40be5e5fa54 (patch)
tree9256e2f4f35ce2ab1e8b537de425e19c682def4c
parent40b96315e04e2f00ea94d61018b86ebe51c9366e (diff)
databases/postgis32: Fix build on FreeBSD 12 by using c++14 explicitly
The error message is as follows: cc -std=c++11 -x c++ -I../../liblwgeom -Iinclude -I/usr/local/include -I/usr/local/include -I/usr/local/include -I/usr/local/include/libxml2 -I/usr/local/include -I/usr/local/include -I/usr/local/include/json-c -I/usr/local/include -DNDEBUG -I/usr/local/include -isystem /usr/local/include -O2 -pipe -fstack-protector-strong -isystem /usr/local/include -fno-strict-aliasing -isystem /usr/local/include -fPIC -DPIC -c -o flatgeobuf_c.o flatgeobuf_c.cpp In file included from flatgeobuf_c.cpp:26: In file included from ./feature_generated.h:7: In file included from include/flatbuffers/flatbuffers.h:20: In file included from include/flatbuffers/base.h:241: In file included from /usr/local/include/absl/strings/string_view.h:39: In file included from /usr/local/include/absl/base/attributes.h:37: In file included from /usr/local/include/absl/base/config.h:86: /usr/local/include/absl/base/policy_checks.h:79:2: error: "C++ versions less than C++14 are not supported." #error "C++ versions less than C++14 are not supported." ^ 1 error generated. gmake[4]: *** [Makefile:50: flatgeobuf_c.o] Error 1 gmake[4]: Leaving directory '/wrkdirs/usr/ports/databases/postgis32/work/postgis-3.2.5/deps/flatgeobuf' gmake[3]: *** [Makefile:213: ../deps/flatgeobuf/libflatgeobuf.la] Error 2 gmake[3]: Leaving directory '/wrkdirs/usr/ports/databases/postgis32/work/postgis-3.2.5/postgis' gmake[2]: *** [GNUmakefile:22: all] Error 1 gmake[2]: Leaving directory '/wrkdirs/usr/ports/databases/postgis32/work/postgis-3.2.5' gmake[1]: *** [Makefile:6: all] Error 2 gmake[1]: Leaving directory '/wrkdirs/usr/ports/databases/postgis32/work/postgis-3.2.5' ===> Compilation failed unexpectedly. Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to the maintainer. *** Error code 1 Approved by: portmgr (blanket)
-rw-r--r--databases/postgis32/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/databases/postgis32/Makefile b/databases/postgis32/Makefile
index a32b2f920dad..7cb6b83f51c3 100644
--- a/databases/postgis32/Makefile
+++ b/databases/postgis32/Makefile
@@ -17,13 +17,14 @@ LIB_DEPENDS= libproj.so:graphics/proj \
libjson-c.so:devel/json-c \
libgdal.so:graphics/gdal
-USES= alias compiler:c++11-lang cpe gmake gnome iconv:wchar_t libtool:keepla \
+USES= alias compiler:c++14-lang cpe gmake gnome iconv:wchar_t libtool:keepla \
localbase perl5 pkgconfig pgsql:11+ shebangfix
USE_GNOME= libxml2
USE_PERL5= build
GNU_CONFIGURE= yes
CONFIGURE_ARGS= ${ICONV_CONFIGURE_BASE} NUMERICFLAGS=${PORTVERSION}
+USE_CXXSTD= c++14
SHEBANG_FILES= extensions/address_standardizer/*.pl raster/test/regress/*.pl \
raster/test/regress/loader/*.pl regress/run_test.pl \
utils/postgis_restore.pl.in utils/*.pl