aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNeel Chauhan <nc@FreeBSD.org>2021-04-27 20:50:18 +0000
committerNeel Chauhan <nc@FreeBSD.org>2021-04-27 20:50:18 +0000
commita69f7dd95d51844481bd34bdfa12fef3898c7174 (patch)
treef029c4625e2746da74faa072559bd4ef2f3d6800
parentf9c69bda0f4038520cc33004b89ebcefdb0876e8 (diff)
downloadports-a69f7dd95d51844481bd34bdfa12fef3898c7174.tar.gz
ports-a69f7dd95d51844481bd34bdfa12fef3898c7174.zip
New port: security/p5-Crypt-JWT
JSON Web Token (JWT, JWS, JWE) as defined by RFC7519, RFC7515, RFC7516 implements the Perl interface to: * JSON Web Token (JWT) * JSON Web Signature (JWS) * JSON Web Encryption (JWE) As defined by RFC7519, RFC7515, RFC7516. The module implements all (100%) algorithms defined in RFC7518 - JSON Web Algorithms (JWA). This module supports Compact JWS/JWE and flattened JWS/JWE JSON serialization, general JSON serialization is not supported yet. PR: 255447 Submitted by: Sergei Vyshenski <svysh.fbsd@gmail.com>
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Crypt-JWT/Makefile25
-rw-r--r--security/p5-Crypt-JWT/distinfo3
-rw-r--r--security/p5-Crypt-JWT/pkg-descr15
-rw-r--r--security/p5-Crypt-JWT/pkg-plist4
5 files changed, 48 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 6801e3770b33..3b2843941aff 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -517,6 +517,7 @@
SUBDIR += p5-Crypt-IDEA
SUBDIR += p5-Crypt-Imail
SUBDIR += p5-Crypt-Juniper
+ SUBDIR += p5-Crypt-JWT
SUBDIR += p5-Crypt-Khazad
SUBDIR += p5-Crypt-LE
SUBDIR += p5-Crypt-LibSCEP
diff --git a/security/p5-Crypt-JWT/Makefile b/security/p5-Crypt-JWT/Makefile
new file mode 100644
index 000000000000..03ce998e7a40
--- /dev/null
+++ b/security/p5-Crypt-JWT/Makefile
@@ -0,0 +1,25 @@
+# Created by: Sergei Vyshenski
+
+PORTNAME= Crypt-JWT
+PORTVERSION= 0.032
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= svysh.fbsd@gmail.com
+COMMENT= JSON Web Token (JWT, JWS, JWE) as defined by RFC7519, RFC7515, RFC7516
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-CryptX>=0.067:security/p5-CryptX \
+ p5-JSON>=0:converters/p5-JSON
+
+USES= perl5
+USE_PERL5= configure
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-JWT/distinfo b/security/p5-Crypt-JWT/distinfo
new file mode 100644
index 000000000000..5ee12d0434b3
--- /dev/null
+++ b/security/p5-Crypt-JWT/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1619536946
+SHA256 (Crypt-JWT-0.032.tar.gz) = 1d3e0f11aba0a946e39578abf8b3c45ef1a2fd0ad87245f5c1da75a660f035ca
+SIZE (Crypt-JWT-0.032.tar.gz) = 83732
diff --git a/security/p5-Crypt-JWT/pkg-descr b/security/p5-Crypt-JWT/pkg-descr
new file mode 100644
index 000000000000..e0f6a355be83
--- /dev/null
+++ b/security/p5-Crypt-JWT/pkg-descr
@@ -0,0 +1,15 @@
+JSON Web Token (JWT, JWS, JWE) as defined by RFC7519, RFC7515, RFC7516
+implements the Perl interface to:
+
+ * JSON Web Token (JWT)
+ * JSON Web Signature (JWS)
+ * JSON Web Encryption (JWE)
+
+As defined by RFC7519, RFC7515, RFC7516.
+
+The module implements all (100%) algorithms defined in RFC7518 - JSON
+Web Algorithms (JWA). This module supports Compact JWS/JWE and
+flattened JWS/JWE JSON serialization, general JSON serialization
+is not supported yet.
+
+WWW: https://metacpan.org/release/Crypt-JWT
diff --git a/security/p5-Crypt-JWT/pkg-plist b/security/p5-Crypt-JWT/pkg-plist
new file mode 100644
index 000000000000..b9feeba7add1
--- /dev/null
+++ b/security/p5-Crypt-JWT/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/Crypt/JWT.pm
+%%SITE_PERL%%/Crypt/KeyWrap.pm
+%%PERL5_MAN3%%/Crypt::JWT.3.gz
+%%PERL5_MAN3%%/Crypt::KeyWrap.3.gz