aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-12-30 08:36:10 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-12-30 09:04:00 +0000
commita6a8beb91d722617499cb2f7db717298d51b91d6 (patch)
treefe4afdaff07c6752b751b43ffe047e4e9ea9195c
parenta314895d38bdc755b3afa078ca11409de7440813 (diff)
science/p5-Geo-Coordinates-Transform: Add p5-Geo-Coordinates-Transform 0.10
There are several formats used to present geographic coordinates. Geo::Coordinates::Transform converts a list of provided latitude and longitude coordinates in any of the three formats above (mixed input is ok) and converts to the desired format. Note that special characters or non-numerical characters such as " will throw an warning and return NaN for that list item. In addition, the input does not interpert N,S,W,E designators but expects coordinates to be in positive or negative representation. Format of the output can be controlled via input arguments in the constructor. The arguments are expected to be in the form of a hash reference.
-rw-r--r--science/Makefile1
-rw-r--r--science/p5-Geo-Coordinates-Transform/Makefile19
-rw-r--r--science/p5-Geo-Coordinates-Transform/distinfo3
-rw-r--r--science/p5-Geo-Coordinates-Transform/pkg-descr12
-rw-r--r--science/p5-Geo-Coordinates-Transform/pkg-plist2
5 files changed, 37 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 4d6572989c77..e0461a394c02 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -259,6 +259,7 @@
SUBDIR += p5-Geo-Calc
SUBDIR += p5-Geo-Coordinates-Converter
SUBDIR += p5-Geo-Coordinates-Converter-iArea
+ SUBDIR += p5-Geo-Coordinates-Transform
SUBDIR += p5-Geo-WebService-Elevation-USGS
SUBDIR += p5-Mcstas-Tools
SUBDIR += p5-PerlMol
diff --git a/science/p5-Geo-Coordinates-Transform/Makefile b/science/p5-Geo-Coordinates-Transform/Makefile
new file mode 100644
index 000000000000..1c3e6294d480
--- /dev/null
+++ b/science/p5-Geo-Coordinates-Transform/Makefile
@@ -0,0 +1,19 @@
+PORTNAME= Geo-Coordinates-Transform
+PORTVERSION= 0.10
+CATEGORIES= science perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Transform Latitude/Longitude between various different coordinate functions
+WWW= https://metacpan.org/dist/Geo-Coordinates-Transform
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+
+USES= perl5
+USE_PERL5= configure
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/science/p5-Geo-Coordinates-Transform/distinfo b/science/p5-Geo-Coordinates-Transform/distinfo
new file mode 100644
index 000000000000..10808eea3947
--- /dev/null
+++ b/science/p5-Geo-Coordinates-Transform/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1669057507
+SHA256 (Geo-Coordinates-Transform-0.10.tar.gz) = d4cfee41cded0e06cf7e5ab5f5f35f54c3c28f89cf4287e6b306f5fb2c9446c6
+SIZE (Geo-Coordinates-Transform-0.10.tar.gz) = 4319
diff --git a/science/p5-Geo-Coordinates-Transform/pkg-descr b/science/p5-Geo-Coordinates-Transform/pkg-descr
new file mode 100644
index 000000000000..7711ddfe0dea
--- /dev/null
+++ b/science/p5-Geo-Coordinates-Transform/pkg-descr
@@ -0,0 +1,12 @@
+There are several formats used to present geographic coordinates.
+
+Geo::Coordinates::Transform converts a list of provided latitude and longitude
+coordinates in any of the three formats above (mixed input is ok) and converts
+to the desired format. Note that special characters or non-numerical characters
+such as " will throw an warning and return NaN for that list item.
+
+In addition, the input does not interpert N,S,W,E designators but expects
+coordinates to be in positive or negative representation.
+
+Format of the output can be controlled via input arguments in the constructor.
+The arguments are expected to be in the form of a hash reference.
diff --git a/science/p5-Geo-Coordinates-Transform/pkg-plist b/science/p5-Geo-Coordinates-Transform/pkg-plist
new file mode 100644
index 000000000000..01c0e32c7b33
--- /dev/null
+++ b/science/p5-Geo-Coordinates-Transform/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Geo/Coordinates/Transform.pm
+%%PERL5_MAN3%%/Geo::Coordinates::Transform.3.gz