aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:00:57 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:00:57 +0000
commita6d02c9e56aa4626276d3eedf0396269dc3e6264 (patch)
tree98fb5b5b059de86bdb48a81d93bbbe6e43a72cfa
parent17740ec85afede8a94774e7f7c190e351ec6f04b (diff)
downloadports-a6d02c9e56aa4626276d3eedf0396269dc3e6264.tar.gz
ports-a6d02c9e56aa4626276d3eedf0396269dc3e6264.zip
devel/py-wsme: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for package change
-rw-r--r--devel/py-wsme/Makefile8
-rw-r--r--devel/py-wsme/files/patch-setup.cfg9
2 files changed, 15 insertions, 2 deletions
diff --git a/devel/py-wsme/Makefile b/devel/py-wsme/Makefile
index d1bba29e8d4c..cb95c0b286d7 100644
--- a/devel/py-wsme/Makefile
+++ b/devel/py-wsme/Makefile
@@ -1,5 +1,6 @@
PORTNAME= wsme
PORTVERSION= 0.11.0
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,15 +13,18 @@ WWW= https://opendev.org/x/wsme
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=0:devel/py-pbr@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=0:devel/py-pbr@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}netaddr>=0.7.12:net/py-netaddr@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytz>=0,1:devel/py-pytz@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}simplegeneric>=0:devel/py-simplegeneric@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}webob>=1.8.0:www/py-webob@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
+MAKE_ENV= PBR_VERSION=${PORTVERSION}
NO_ARCH= yes
.include <bsd.port.mk>
diff --git a/devel/py-wsme/files/patch-setup.cfg b/devel/py-wsme/files/patch-setup.cfg
new file mode 100644
index 000000000000..77bd9f107a86
--- /dev/null
+++ b/devel/py-wsme/files/patch-setup.cfg
@@ -0,0 +1,9 @@
+--- setup.cfg.orig 2021-07-27 16:41:34 UTC
++++ setup.cfg
+@@ -1,5 +1,5 @@
+ [metadata]
+-name = WSME
++name = wsme
+ author = Christophe de Vienne
+ author-email = python-wsme@googlegroups.com
+ summary = Simplify the writing of REST APIs, and extend them with additional protocols.