aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-01-22 05:41:08 +0000
committerJan Beich <jbeich@FreeBSD.org>2022-02-21 16:10:45 +0000
commita7011e478978bdf10607e39066e2f7a6fa444cd4 (patch)
treebb943d652a742a52f4029b1d2e9f88ed7c70e812
parent04167ca4eaa634d8e741f24fd5d9dff7e4b6ac32 (diff)
downloadports-a7011e478978bdf10607e39066e2f7a6fa444cd4.tar.gz
ports-a7011e478978bdf10607e39066e2f7a6fa444cd4.zip
x11/way-displays: add new port
way-displays: Auto Manage Your Wayland Displays 1. Sets preferred mode or highest at maximum refresh 1. Arranges in a row or a column 1. Auto scales based on DPI: 96 is a scale of 1 1. Reacts when displays are plugged/unplugged 1. Reacts when laptop lid is closed/opened Works out of the box: no configuration required. Wayland successor to xlayoutdisplay, inspired by kanshi. https://github.com/alex-courtis/way-displays
-rw-r--r--x11/Makefile1
-rw-r--r--x11/way-displays/Makefile41
-rw-r--r--x11/way-displays/distinfo5
-rw-r--r--x11/way-displays/pkg-descr13
4 files changed, 60 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index d3610ad6f528..6c4783b0c77a 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -380,6 +380,7 @@
SUBDIR += virtualgl
SUBDIR += wallutils
SUBDIR += wapanel
+ SUBDIR += way-displays
SUBDIR += waybar
SUBDIR += wayland-logout
SUBDIR += wayout
diff --git a/x11/way-displays/Makefile b/x11/way-displays/Makefile
new file mode 100644
index 000000000000..ca9cec454c48
--- /dev/null
+++ b/x11/way-displays/Makefile
@@ -0,0 +1,41 @@
+PORTNAME= way-displays
+DISTVERSION= 1.3.0
+CATEGORIES= x11
+
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+PATCHFILES+= 90081b314a75.patch:-p1 # https://github.com/alex-courtis/way-displays/pull/21
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Auto Manage Your Wayland Displays
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libepoll-shim.so:devel/libepoll-shim \
+ libinotify.so:devel/libinotify \
+ libudev.so:devel/libudev-devd \
+ libyaml-cpp.so:devel/yaml-cpp \
+ libwayland-client.so:graphics/wayland \
+ libinput.so:x11/libinput
+
+USES= compiler:c11 gmake localbase:ldflags
+USE_GITHUB= yes
+GH_ACCOUNT= alex-courtis
+MAKE_ENV= VERSION="${DISTVERSIONFULL}"
+MAKE_ARGS= CC="${CC}" CXX="${CXX}" OFLAGS=
+CFLAGS+= -isystem${LOCALBASE}/include/libepoll-shim
+LDFLAGS+= -lepoll-shim -linotify
+PLIST_FILES= bin/${PORTNAME} \
+ "@sample ${ETCDIR}/cfg.yaml.sample"
+
+post-patch:
+# Respect PREFIX for system-wide config
+ @${REINPLACE_CMD} 's,/usr/local,${PREFIX},' ${WRKSRC}/src/cfg.cpp
+
+post-install:
+# Let @sample handle default files under etc/
+ @for f in ${STAGEDIR}${ETCDIR}/*; do \
+ ${MV} $$f $$f.sample; \
+ done
+
+.include <bsd.port.mk>
diff --git a/x11/way-displays/distinfo b/x11/way-displays/distinfo
new file mode 100644
index 000000000000..f40b3f213a23
--- /dev/null
+++ b/x11/way-displays/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1642830068
+SHA256 (alex-courtis-way-displays-1.3.0_GH0.tar.gz) = 4a757f079e14bcfcd2804fed0a4a6190535ae059b45e3d73e5b298bba306201b
+SIZE (alex-courtis-way-displays-1.3.0_GH0.tar.gz) = 54611
+SHA256 (90081b314a75.patch) = 0dd16e43b035bda5c3568d661202f6d18053ab7c8e51be5b3e04d7d8bee93214
+SIZE (90081b314a75.patch) = 1245
diff --git a/x11/way-displays/pkg-descr b/x11/way-displays/pkg-descr
new file mode 100644
index 000000000000..b9a6aa207ca3
--- /dev/null
+++ b/x11/way-displays/pkg-descr
@@ -0,0 +1,13 @@
+way-displays: Auto Manage Your Wayland Displays
+
+1. Sets preferred mode or highest at maximum refresh
+1. Arranges in a row or a column
+1. Auto scales based on DPI: 96 is a scale of 1
+1. Reacts when displays are plugged/unplugged
+1. Reacts when laptop lid is closed/opened
+
+Works out of the box: no configuration required.
+
+Wayland successor to xlayoutdisplay, inspired by kanshi.
+
+WWW: https://github.com/alex-courtis/way-displays