aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-12-25 18:07:09 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-12-25 18:11:58 +0000
commita73a30364c9eebfc9be16aeb87d9308206e49e64 (patch)
tree7012b7c977932cf8a64564b4f62585ee5e600d31
parent145ca54873489e7d45eac99de62f733a54dc294d (diff)
downloadports-a73a30364c9eebfc9be16aeb87d9308206e49e64.tar.gz
ports-a73a30364c9eebfc9be16aeb87d9308206e49e64.zip
*/horde-*: Mark BROKEN
As part of removal of php74 the initial thought was to remove the horde framework entirely. However considering the fact that the forks of horde with php8 compatibility from https://github.com/maintaina-com will soon be merged upstream we are not removing the ports but keeping them in BROKEN state as the ports build perfectly while fails to run under php80. Also mark the ports DEPRECATED in case the patches do not get merged upstream. Also set the EXPIRATION_DATE to 2023-03-31. In case someone is willing to convert the ports to use maintaina-com fork feel free to update accordingly. Approved by: portmgr (blanket infrastructure) Sponsored by: Bounce Experts
-rw-r--r--deskutils/horde-groupware/Makefile5
-rw-r--r--deskutils/horde-kronolith/Makefile5
-rw-r--r--deskutils/horde-mnemo/Makefile5
-rw-r--r--deskutils/horde-nag/Makefile5
-rw-r--r--devel/horde-content/Makefile5
-rw-r--r--devel/horde-timeobjects/Makefile5
-rw-r--r--devel/horde-whups/Makefile5
-rw-r--r--ftp/horde-gollem/Makefile5
-rw-r--r--mail/horde-imp/Makefile5
-rw-r--r--mail/horde-ingo/Makefile5
-rw-r--r--mail/horde-turba/Makefile5
-rw-r--r--mail/horde-webmail/Makefile5
-rw-r--r--www/horde-ansel/Makefile5
-rw-r--r--www/horde-base/Makefile5
-rw-r--r--www/horde-passwd/Makefile5
-rw-r--r--www/horde-trean/Makefile5
-rw-r--r--www/horde-wicked/Makefile5
17 files changed, 68 insertions, 17 deletions
diff --git a/deskutils/horde-groupware/Makefile b/deskutils/horde-groupware/Makefile
index b31f1073c009..a9b423e23ef5 100644
--- a/deskutils/horde-groupware/Makefile
+++ b/deskutils/horde-groupware/Makefile
@@ -7,7 +7,9 @@ MAINTAINER= horde@FreeBSD.org
COMMENT= Horde Groupware
WWW= https://www.horde.org/apps/groupware/
-IGNORE_WITH_PHP=80 81 82
+DEPRECATED= Requires php74
+EXPIRATION_DATE= 2023-03-31
+BROKEN= runtime error with php80
USES= horde cpe php
USE_HORDE_BUILD= Horde_Role
@@ -21,6 +23,7 @@ USE_HORDE_RUN= Horde_Role \
timeobjects \
trean \
turba
+IGNORE_WITH_PHP=81 82
CONFLICTS= horde-webmail-[456]*
diff --git a/deskutils/horde-kronolith/Makefile b/deskutils/horde-kronolith/Makefile
index e33a624afd58..71997d0a4b41 100644
--- a/deskutils/horde-kronolith/Makefile
+++ b/deskutils/horde-kronolith/Makefile
@@ -10,7 +10,9 @@ WWW= https://www.horde.org/apps/kronolith/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-IGNORE_WITH_PHP=80 81 82
+DEPRECATED= Requires php74
+EXPIRATION_DATE= 2023-03-31
+BROKEN= runtime error with php80
RUN_DEPENDS+= ${PEARDIR}/Date.php:devel/pear-Date@${PHP_FLAVOR}
@@ -49,6 +51,7 @@ USE_HORDE_RUN= Horde_Role \
Horde_Util \
Horde_View
USE_PHP= gettext json simplexml
+IGNORE_WITH_PHP=81 82
OPTIONS_DEFINE= DATE_HOLIDAYS TIMEOBJECTS XMLWRITER
OPTIONS_DEFAULT= DATE_HOLIDAYS TIMEOBJECTS
diff --git a/deskutils/horde-mnemo/Makefile b/deskutils/horde-mnemo/Makefile
index a941d0180619..f0afec7323a2 100644
--- a/deskutils/horde-mnemo/Makefile
+++ b/deskutils/horde-mnemo/Makefile
@@ -11,7 +11,9 @@ WWW= https://www.horde.org/apps/mnemo/
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-IGNORE_WITH_PHP=80 81 82
+DEPRECATED= Requires php74
+EXPIRATION_DATE= 2023-03-31
+BROKEN= runtime error with php80
USES= horde php cpe
USE_HORDE_BUILD= Horde_Role
@@ -34,6 +36,7 @@ USE_HORDE_RUN= Horde_Role \
Horde_Text_Filter \
Horde_Util
USE_PHP= gettext
+IGNORE_WITH_PHP=81 82
OPTIONS_DEFINE= PDF
OPTIONS_DEFAULT= PDF
diff --git a/deskutils/horde-nag/Makefile b/deskutils/horde-nag/Makefile
index 4f8c3d00fb71..cb2b4596ceee 100644
--- a/deskutils/horde-nag/Makefile
+++ b/deskutils/horde-nag/Makefile
@@ -10,7 +10,9 @@ WWW= https://www.horde.org/apps/nag/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-IGNORE_WITH_PHP=80 81 82
+DEPRECATED= Requires php74
+EXPIRATION_DATE= 2023-03-31
+BROKEN= runtime error with php80
USES= horde php cpe
USE_HORDE_BUILD= Horde_Role
@@ -39,5 +41,6 @@ USE_HORDE_RUN= Horde_Role \
Horde_Util \
Horde_View
USE_PHP= gettext
+IGNORE_WITH_PHP=81 82
.include <bsd.port.mk>
diff --git a/devel/horde-content/Makefile b/devel/horde-content/Makefile
index ff6b243a6c48..e8cd3d4d2a07 100644
--- a/devel/horde-content/Makefile
+++ b/devel/horde-content/Makefile
@@ -7,7 +7,9 @@ MAINTAINER= horde@FreeBSD.org
COMMENT= Horde tagging application
WWW= https://pear.horde.org
-IGNORE_WITH_PHP=80 81 82
+DEPRECATED= Requires php74
+EXPIRATION_DATE= 2023-03-31
+BROKEN= runtime error with php80
USES= horde php cpe
USE_HORDE_BUILD= Horde_Role
@@ -20,6 +22,7 @@ USE_HORDE_RUN= Horde_Role \
Horde_Rdo \
Horde_Util
USE_PHP= gettext json
+IGNORE_WITH_PHP=81 82
CONFLICTS_INSTALL= php*-horde-content
diff --git a/devel/horde-timeobjects/Makefile b/devel/horde-timeobjects/Makefile
index 5f5d2371516b..b4eb9388b915 100644
--- a/devel/horde-timeobjects/Makefile
+++ b/devel/horde-timeobjects/Makefile
@@ -9,7 +9,9 @@ WWW= https://www.horde.org/
LICENSE= BSD2CLAUSE
-IGNORE_WITH_PHP=80 81 82
+DEPRECATED= Requires php74
+EXPIRATION_DATE= 2023-03-31
+BROKEN= runtime error with php80
USES= cpe horde php
CPE_VENDOR= horde
@@ -21,5 +23,6 @@ USE_HORDE_RUN= Horde_Role \
Horde_Url \
Horde_Util
USE_PHP= gettext
+IGNORE_WITH_PHP=81 82
.include <bsd.port.mk>
diff --git a/devel/horde-whups/Makefile b/devel/horde-whups/Makefile
index a367dba9510b..ac65add8e0bf 100644
--- a/devel/horde-whups/Makefile
+++ b/devel/horde-whups/Makefile
@@ -10,7 +10,9 @@ WWW= https://www.horde.org/apps/whups/
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-IGNORE_WITH_PHP=80 81 82
+DEPRECATED= Requires php74
+EXPIRATION_DATE= 2023-03-31
+BROKEN= runtime error with php80
USES= horde php cpe
USE_PHP= gettext json
@@ -39,5 +41,6 @@ USE_HORDE_RUN= Horde_Role \
Horde_Util \
Horde_Vfs \
Horde_View
+IGNORE_WITH_PHP=81 82
.include <bsd.port.mk>
diff --git a/ftp/horde-gollem/Makefile b/ftp/horde-gollem/Makefile
index 02d3efcd8178..e9bb168c2c23 100644
--- a/ftp/horde-gollem/Makefile
+++ b/ftp/horde-gollem/Makefile
@@ -10,7 +10,9 @@ WWW= https://www.horde.org/apps/gollem/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-IGNORE_WITH_PHP=80 81 82
+DEPRECATED= Requires php74
+EXPIRATION_DATE= 2023-03-31
+BROKEN= runtime error with php80
USES= horde php cpe
USE_HORDE_BUILD= Horde_Role
@@ -35,5 +37,6 @@ USE_HORDE_RUN= Horde_Role \
USE_HORDE_RUN+= Horde_Db \
Horde_Share
USE_PHP= gettext json
+IGNORE_WITH_PHP=81 82
.include <bsd.port.mk>
diff --git a/mail/horde-imp/Makefile b/mail/horde-imp/Makefile
index 2284229e40b3..142c2e08302a 100644
--- a/mail/horde-imp/Makefile
+++ b/mail/horde-imp/Makefile
@@ -11,7 +11,9 @@ WWW= https://www.horde.org/apps/imp/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-IGNORE_WITH_PHP=80 81 82
+DEPRECATED= Requires php74
+EXPIRATION_DATE= 2023-03-31
+BROKEN= runtime error with php80
USES= horde cpe php
USE_HORDE_BUILD= Horde_Role
@@ -53,6 +55,7 @@ USE_HORDE_RUN= Horde_Role \
Horde_Util \
Horde_Vfs \
Horde_View
+IGNORE_WITH_PHP=81 82
CONFLICTS_INSTALL= php*-horde-imp
diff --git a/mail/horde-ingo/Makefile b/mail/horde-ingo/Makefile
index b2a23ab11f83..0edcea24fb99 100644
--- a/mail/horde-ingo/Makefile
+++ b/mail/horde-ingo/Makefile
@@ -10,7 +10,9 @@ WWW= https://www.horde.org/apps/ingo/
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-IGNORE_WITH_PHP=80 81 82
+DEPRECATED= Requires php74
+EXPIRATION_DATE= 2023-03-31
+BROKEN= runtime error with php80
# Optional but we want it
RUN_DEPENDS+= ${PEARDIR}/Net/Sieve.php:net/pear-Net_Sieve@${PHP_FLAVOR} \
@@ -32,6 +34,7 @@ USE_HORDE_RUN= Horde_Role \
Horde_Share \
Horde_Util
USE_PHP= gettext
+IGNORE_WITH_PHP=81 82
CONFLICTS_INSTALL= php*-horde-ingo
diff --git a/mail/horde-turba/Makefile b/mail/horde-turba/Makefile
index b200431dc1a2..0cfbe2cfa3b6 100644
--- a/mail/horde-turba/Makefile
+++ b/mail/horde-turba/Makefile
@@ -10,7 +10,9 @@ WWW= https://www.horde.org/apps/turba/
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-IGNORE_WITH_PHP=80 81 82
+DEPRECATED= Requires php74
+EXPIRATION_DATE= 2023-03-31
+BROKEN= runtime error with php80
USES= horde php cpe
USE_HORDE_BUILD= Horde_Role
@@ -38,6 +40,7 @@ USE_HORDE_RUN= Horde_Role \
Horde_Util \
Horde_View
USE_PHP= gettext hash json
+IGNORE_WITH_PHP=81 82
NO_ARCH= yes
diff --git a/mail/horde-webmail/Makefile b/mail/horde-webmail/Makefile
index a40b17059ee8..c033f0a5d0f8 100644
--- a/mail/horde-webmail/Makefile
+++ b/mail/horde-webmail/Makefile
@@ -7,7 +7,9 @@ MAINTAINER= horde@FreeBSD.org
COMMENT= Horde Groupware Webmail Edition
WWW= https://www.horde.org/apps/webmail/
-IGNORE_WITH_PHP=80 81 82
+DEPRECATED= Requires php74
+EXPIRATION_DATE= 2023-03-31
+BROKEN= runtime error with php80
USES= horde cpe php
CPE_PRODUCT= groupware
@@ -25,6 +27,7 @@ USE_HORDE_RUN= Horde_Role \
timeobjects \
trean \
turba
+IGNORE_WITH_PHP=81 82
CONFLICTS= horde-groupware-[456]*
diff --git a/www/horde-ansel/Makefile b/www/horde-ansel/Makefile
index 6f3657367c08..9581e15bb5ac 100644
--- a/www/horde-ansel/Makefile
+++ b/www/horde-ansel/Makefile
@@ -10,7 +10,9 @@ WWW= https://www.horde.org/apps/ansel/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-IGNORE_WITH_PHP=80 81 82
+DEPRECATED= Requires php74
+EXPIRATION_DATE= 2023-03-31
+BROKEN= runtime error with php80
USES= horde cpe php
USE_PHP= gettext hash
@@ -39,6 +41,7 @@ USE_HORDE_RUN= Horde_Role \
Horde_Util \
Horde_View \
Horde_Vfs
+IGNORE_WITH_PHP=81 82
CONFLICTS_INSTALL= php*-horde-ansel # bin/AnselPublish.scpt bin/ansel bin/ansel-convert-sql-shares-to-sqlng bin/ansel-exif-to-tags bin/ansel-garbage-collection
diff --git a/www/horde-base/Makefile b/www/horde-base/Makefile
index 02bc93c821dd..8f3142eb1f4a 100644
--- a/www/horde-base/Makefile
+++ b/www/horde-base/Makefile
@@ -9,7 +9,9 @@ WWW= https://www.horde.org/apps/horde/
LICENSE= GPLv2
-IGNORE_WITH_PHP=80 81 82
+DEPRECATED= Requires php74
+EXPIRATION_DATE= 2023-03-31
+BROKEN= runtime error with php80
RUN_DEPENDS= ${PEARDIR}/Net/DNS2.php:dns/pear-Net_DNS2@${PHP_FLAVOR}
@@ -49,6 +51,7 @@ USE_HORDE_RUN= Horde_Role \
# Optional in package but we want them in
USE_HORDE_RUN+= Horde_Feed
USE_PHP= filter gettext hash
+IGNORE_WITH_PHP=81 82
CONFLICTS_INSTALL= php*-horde
diff --git a/www/horde-passwd/Makefile b/www/horde-passwd/Makefile
index 2f2a0c2404ce..4e3019c4d8a4 100644
--- a/www/horde-passwd/Makefile
+++ b/www/horde-passwd/Makefile
@@ -10,7 +10,9 @@ WWW= https://www.horde.org/apps/passwd/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-IGNORE_WITH_PHP=80 81 82
+DEPRECATED= Requires php74
+EXPIRATION_DATE= 2023-03-31
+BROKEN= runtime error with php80
USES= horde cpe php
USE_PHP= gettext
@@ -23,5 +25,6 @@ USE_HORDE_RUN= Horde_Role \
Horde_Injector \
Horde_Util \
Horde_View
+IGNORE_WITH_PHP=81 82
.include <bsd.port.mk>
diff --git a/www/horde-trean/Makefile b/www/horde-trean/Makefile
index c73727c9a672..61a33e7e58de 100644
--- a/www/horde-trean/Makefile
+++ b/www/horde-trean/Makefile
@@ -10,7 +10,9 @@ WWW= https://www.horde.org/apps/trean/
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-IGNORE_WITH_PHP=80 81 82
+DEPRECATED= Requires php74
+EXPIRATION_DATE= 2023-03-31
+BROKEN= runtime error with php80
USES= horde cpe php
USE_HORDE_BUILD= Horde_Role
@@ -32,5 +34,6 @@ USE_HORDE_RUN= Horde_Role \
Horde_Vfs \
Horde_View
USE_PHP= gettext json
+IGNORE_WITH_PHP=81 82
.include <bsd.port.mk>
diff --git a/www/horde-wicked/Makefile b/www/horde-wicked/Makefile
index e72886470f17..96ea72e47567 100644
--- a/www/horde-wicked/Makefile
+++ b/www/horde-wicked/Makefile
@@ -10,7 +10,9 @@ WWW= https://www.horde.org/apps/wicked/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-IGNORE_WITH_PHP=80 81 82
+DEPRECATED= Requires php74
+EXPIRATION_DATE= 2023-03-31
+BROKEN= runtime error with php80
RUN_DEPENDS+= ${PEARDIR}/Text/Wiki.php:www/pear-Text_Wiki@${PHP_FLAVOR}
@@ -37,5 +39,6 @@ USE_HORDE_RUN= Horde_Role \
Horde_Util \
Horde_Vfs
USE_PHP= gettext
+IGNORE_WITH_PHP=81 82
.include <bsd.port.mk>