aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-10-05 06:45:41 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-10-05 06:46:30 +0000
commita7c2ddb5a20181f1835216965d25d526c9fcc50c (patch)
tree86ef5cb2a5809a4464e71a4a439d2cfa6b02d647
parenta7bdad22b93e664542e5ff364f2badde32060f28 (diff)
textproc/py-citeproc-py-styles: Unbreak
Python version comparison procedure thinks that the version 2.6.2 is greater than 6.0.0 for some reason. Reported by: fallout
-rw-r--r--textproc/py-citeproc-py-styles/files/patch-setup.py13
1 files changed, 13 insertions, 0 deletions
diff --git a/textproc/py-citeproc-py-styles/files/patch-setup.py b/textproc/py-citeproc-py-styles/files/patch-setup.py
new file mode 100644
index 000000000000..bcc2ddb8b4b9
--- /dev/null
+++ b/textproc/py-citeproc-py-styles/files/patch-setup.py
@@ -0,0 +1,13 @@
+- fix the problem that Python thinks that the version 2.6.2 is greater than 6.0.0 for pytest-runner
+
+--- setup.py.orig 2022-10-05 06:44:42 UTC
++++ setup.py
+@@ -27,7 +27,7 @@ for reqs in extras_require.values():
+ extras_require['all'].extend(reqs)
+
+ setup_requires = [
+- 'pytest-runner>=2.6.2',
++ 'pytest-runner',
+ ]
+
+ install_requires = [