aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-29 16:30:26 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-29 16:33:07 +0000
commita7d6e28815df99cb877ce0f8a6a864b6cfcf7e0b (patch)
tree8e0290a8f8ac5980ad8744c5d3e80b255ee08dc3
parent664232b984f9ef65af6339e4a23e9f83a2b05915 (diff)
downloadports-a7d6e28815df99cb877ce0f8a6a864b6cfcf7e0b.tar.gz
ports-a7d6e28815df99cb877ce0f8a6a864b6cfcf7e0b.zip
security/rubygem-omniauth-alicloud: Fix gemspec for rubygem-omniauth-oauth2 1.8.0 update
- Bump PORTREVISION for package change The code is identical in 1.7.1 and 1.8.0. The only different is omniauth version (~> 2.0). Reference: https://github.com/omniauth/omniauth-oauth2/compare/v1.7.3...v1.8.0
-rw-r--r--security/rubygem-omniauth-alicloud/Makefile3
-rw-r--r--security/rubygem-omniauth-alicloud/files/patch-gemspec11
2 files changed, 13 insertions, 1 deletions
diff --git a/security/rubygem-omniauth-alicloud/Makefile b/security/rubygem-omniauth-alicloud/Makefile
index 8e7f8f2757cf..55b25405b947 100644
--- a/security/rubygem-omniauth-alicloud/Makefile
+++ b/security/rubygem-omniauth-alicloud/Makefile
@@ -2,6 +2,7 @@
PORTNAME= omniauth-alicloud
PORTVERSION= 1.0.1
+PORTREVISION= 1
CATEGORIES= security rubygems
MASTER_SITES= RG
@@ -11,7 +12,7 @@ COMMENT= Wrapper the AliCloud Oauth2 API
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-RUN_DEPENDS= rubygem-omniauth-oauth2>=1.7.1<1.8:net/rubygem-omniauth-oauth2
+RUN_DEPENDS= rubygem-omniauth-oauth2>=1.7.1<1.8.1:net/rubygem-omniauth-oauth2
USES= gem
USE_RUBY= yes
diff --git a/security/rubygem-omniauth-alicloud/files/patch-gemspec b/security/rubygem-omniauth-alicloud/files/patch-gemspec
new file mode 100644
index 000000000000..0544987827b0
--- /dev/null
+++ b/security/rubygem-omniauth-alicloud/files/patch-gemspec
@@ -0,0 +1,11 @@
+--- omniauth-alicloud.gemspec.orig 2022-06-24 14:19:41 UTC
++++ omniauth-alicloud.gemspec
+@@ -24,7 +24,7 @@ Gem::Specification.new do |s|
+ end
+
+ if s.respond_to? :add_runtime_dependency then
+- s.add_runtime_dependency(%q<omniauth-oauth2>.freeze, ["~> 1.7.1"])
++ s.add_runtime_dependency(%q<omniauth-oauth2>.freeze, [">= 1.7.1", "< 1.8.1"])
+ else
+ s.add_dependency(%q<omniauth-oauth2>.freeze, ["~> 1.7.1"])
+ end