aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNeel Chauhan <nc@FreeBSD.org>2022-07-23 20:49:29 +0000
committerNeel Chauhan <nc@FreeBSD.org>2022-07-23 20:49:29 +0000
commita87b17148e63e359c426eab9e67d954bc090bfe5 (patch)
treec38b1be9a03f5aed746c4ad769c764100f8c3424
parent9da256a46aa0dd84a5605dcc4defcbbe4b855548 (diff)
downloadports-a87b17148e63e359c426eab9e67d954bc090bfe5.tar.gz
ports-a87b17148e63e359c426eab9e67d954bc090bfe5.zip
emulators/dosbox-x: Update to 0.84.1
-rw-r--r--emulators/dosbox-x/Makefile2
-rw-r--r--emulators/dosbox-x/distinfo6
-rw-r--r--emulators/dosbox-x/files/patch-src_cpu_core__dyn__x86_risc__x86.h (renamed from emulators/dosbox-x/files/patch-src_cpu_core_dyn_x86_risc_x86.h)6
-rw-r--r--emulators/dosbox-x/files/patch-src_gui_sdl__gui.cpp38
-rw-r--r--emulators/dosbox-x/files/patch-src_output_output__surface.cpp12
-rw-r--r--emulators/dosbox-x/pkg-plist23
6 files changed, 51 insertions, 36 deletions
diff --git a/emulators/dosbox-x/Makefile b/emulators/dosbox-x/Makefile
index f72bc7ee6f77..e91328bd2b16 100644
--- a/emulators/dosbox-x/Makefile
+++ b/emulators/dosbox-x/Makefile
@@ -1,6 +1,6 @@
PORTNAME= dosbox-x
DISTVERSIONPREFIX= ${PORTNAME}-v
-DISTVERSION= 0.84.0
+DISTVERSION= 0.84.1
CATEGORIES= emulators
MAINTAINER= nc@FreeBSD.org
diff --git a/emulators/dosbox-x/distinfo b/emulators/dosbox-x/distinfo
index a7ef853f7ab5..12c5ae8e5236 100644
--- a/emulators/dosbox-x/distinfo
+++ b/emulators/dosbox-x/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1654118426
-SHA256 (joncampbell123-dosbox-x-dosbox-x-v0.84.0_GH0.tar.gz) = 564fbf8f0ab090c8b32bc38637c8204358c386b9cbffcb4f99a81bc82fddbad7
-SIZE (joncampbell123-dosbox-x-dosbox-x-v0.84.0_GH0.tar.gz) = 65495321
+TIMESTAMP = 1658608171
+SHA256 (joncampbell123-dosbox-x-dosbox-x-v0.84.1_GH0.tar.gz) = d5ba5b3d87b0dc69d70f6c9701eec36772bbc3716e0b201b74ec73d4b3ff38cc
+SIZE (joncampbell123-dosbox-x-dosbox-x-v0.84.1_GH0.tar.gz) = 67617800
diff --git a/emulators/dosbox-x/files/patch-src_cpu_core_dyn_x86_risc_x86.h b/emulators/dosbox-x/files/patch-src_cpu_core__dyn__x86_risc__x86.h
index 2d0948efeb73..97e89e49f431 100644
--- a/emulators/dosbox-x/files/patch-src_cpu_core_dyn_x86_risc_x86.h
+++ b/emulators/dosbox-x/files/patch-src_cpu_core__dyn__x86_risc__x86.h
@@ -1,6 +1,6 @@
---- src/cpu/core_dyn_x86/risc_x86.h.orig 2014-12-31 12:59:53.015190887 +0000
-+++ src/cpu/core_dyn_x86/risc_x86.h 2014-12-31 13:00:30.953180886 +0000
-@@ -138,7 +138,7 @@
+--- src/cpu/core_dyn_x86/risc_x86.h.orig 2022-07-01 13:24:06 UTC
++++ src/cpu/core_dyn_x86/risc_x86.h
+@@ -137,7 +137,7 @@ return_address:
"run_return_adress: \n"
"popl %%ebp \n"
:"=a" (retval), "=c" (tempflags)
diff --git a/emulators/dosbox-x/files/patch-src_gui_sdl__gui.cpp b/emulators/dosbox-x/files/patch-src_gui_sdl__gui.cpp
index 75caa4925894..9c5d8ba5efca 100644
--- a/emulators/dosbox-x/files/patch-src_gui_sdl__gui.cpp
+++ b/emulators/dosbox-x/files/patch-src_gui_sdl__gui.cpp
@@ -1,33 +1,31 @@
---- src/gui/sdl_gui.cpp.orig 2022-05-01 06:25:42 UTC
+--- src/gui/sdl_gui.cpp.orig 2022-07-23 20:37:25 UTC
+++ src/gui/sdl_gui.cpp
-@@ -3059,7 +3059,7 @@ class ConfigurationWindow : public GUI::ToplevelWindow
- std::string url = "https://dosbox-x.com/";
- #if defined(WIN32)
- ShellExecute(NULL, "open", url.c_str(), NULL, NULL, SW_SHOWNORMAL);
--#elif defined(LINUX)
-+#elif defined(LINUX) || defined(__FreeBSD__)
- system(("xdg-open "+url).c_str());
- #elif defined(MACOSX)
- system(("open "+url).c_str());
-@@ -3475,7 +3475,11 @@ void GUI_Shortcut(int select) {
- PIC_AddEvent(RunCfgTool, 100);
+@@ -3563,6 +3563,7 @@ void GUI_Shortcut(int select) {
+ shortcutid=select;
+ shortcut=true;
+ sel = select;
++#ifndef __FreeBSD__
+ #if defined(USE_TTF)
+ if (ttf.inUse && !confres) {
+ ttf_switch_off();
+@@ -3572,12 +3573,14 @@ void GUI_Shortcut(int select) {
} else
#endif
-+#ifdef __FreeBSD__
-+ RunCfgTool(0);
-+#else
RunCfgTool(NULL);
+#endif
}
void GUI_Run(bool pressed) {
-@@ -3490,5 +3494,9 @@ void GUI_Run(bool pressed) {
- PIC_AddEvent(RunCfgTool, 100);
+ if (pressed || running) return;
+
+ sel = -1;
++#ifndef __FreeBSD__
+ #if defined(USE_TTF)
+ if (ttf.inUse) {
+ ttf_switch_off();
+@@ -3587,4 +3590,5 @@ void GUI_Run(bool pressed) {
} else
#endif
-+#ifdef __FreeBSD__
-+ RunCfgTool(0);
-+#else
RunCfgTool(NULL);
+#endif
}
diff --git a/emulators/dosbox-x/files/patch-src_output_output__surface.cpp b/emulators/dosbox-x/files/patch-src_output_output__surface.cpp
new file mode 100644
index 000000000000..a6b183a465ed
--- /dev/null
+++ b/emulators/dosbox-x/files/patch-src_output_output__surface.cpp
@@ -0,0 +1,12 @@
+--- src/output/output_surface.cpp.orig 2022-07-23 20:42:49 UTC
++++ src/output/output_surface.cpp
+@@ -24,7 +24,9 @@ void OUTPUT_SURFACE_Initialize()
+ // blitting the wrong dimensions to the window and trigger an X11 BadValue error.
+ // Set up an error handler that prints the error to STDERR and then returns,
+ // instead of the default handler which prints an error and exit()s this program.
++#ifndef __FreeBSD__
+ X11_ErrorHandlerInstall();
++#endif
+ #endif
+ }
+
diff --git a/emulators/dosbox-x/pkg-plist b/emulators/dosbox-x/pkg-plist
index 2573a48e524a..79e1cdff4fea 100644
--- a/emulators/dosbox-x/pkg-plist
+++ b/emulators/dosbox-x/pkg-plist
@@ -4,8 +4,11 @@ share/applications/com.dosbox_x.DOSBox-X.desktop
share/bash-completion/completions/dosbox-x
%%DATADIR%%/CHANGELOG
%%DATADIR%%/FREECG98.BMP
+%%DATADIR%%/Nouveau_IBM.ttf
+%%DATADIR%%/SarasaGothicFixed.ttf
%%DATADIR%%/dosbox-x.reference.conf
%%DATADIR%%/dosbox-x.reference.full.conf
+%%DATADIR%%/drivez/readme.txt
%%DATADIR%%/glshaders/ScanLine.glsl
%%DATADIR%%/glshaders/advinterp2x.glsl
%%DATADIR%%/glshaders/advinterp3x.glsl
@@ -45,14 +48,16 @@ share/bash-completion/completions/dosbox-x
%%DATADIR%%/glshaders/yee64.glsl
%%DATADIR%%/glshaders/yeetron.glsl
%%DATADIR%%/glshaders/zfast_crt.glsl
-%%DATADIR%%/translations/en_US.lng
-%%DATADIR%%/translations/es_ES.lng
-%%DATADIR%%/translations/fr_FR.lng
-%%DATADIR%%/translations/ja_JP.lng
-%%DATADIR%%/translations/ko_KR.lng
-%%DATADIR%%/translations/pt_BR.lng
-%%DATADIR%%/translations/tr_TR.lng
-%%DATADIR%%/translations/zh_CN.lng
-%%DATADIR%%/translations/zh_TW.lng
+%%DATADIR%%/languages/en_US.lng
+%%DATADIR%%/languages/es_ES.lng
+%%DATADIR%%/languages/fr_FR.lng
+%%DATADIR%%/languages/ja_JP.lng
+%%DATADIR%%/languages/ko_KR.lng
+%%DATADIR%%/languages/pt_BR.lng
+%%DATADIR%%/languages/tr_TR.lng
+%%DATADIR%%/languages/zh_CN.lng
+%%DATADIR%%/languages/zh_TW.lng
+%%DATADIR%%/wqy_11pt.bdf
+%%DATADIR%%/wqy_12pt.bdf
share/icons/hicolor/scalable/apps/dosbox-x.svg
share/metainfo/com.dosbox_x.DOSBox-X.metainfo.xml