aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesús Daniel Colmenares Oviedo <DtxdF@disroot.org>2023-09-15 01:39:23 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-09-17 15:23:14 +0000
commita87df9468d4b3c40b33ff3572ee1647cd7d9974c (patch)
tree3fc2e8256b46f1bf8ed87717a60e69e0fecb09f7
parent323a2ea41fc42319e6bf0e31d965d48dab01146c (diff)
downloadports-a87df9468d4b3c40b33ff3572ee1647cd7d9974c.tar.gz
ports-a87df9468d4b3c40b33ff3572ee1647cd7d9974c.zip
www/dasherr: New port: Lightweight dashboard for self-hosted services (and bookmarks)
Dasherr is a minimal and lightweight dashboard for your self-hosted services (and bookmarks). Features: * Loads instantly + Remains light on resources * Responsive design (uses Bootstrap framework) * Shows Temperature, CPU load and Memory used by tapping into Glances API (default 5s updates) * Built-in online check of services (checked only at time of page load/refresh, to minimize background activity & load) * Several built-in Themes (easy to edit & add your own) * Wallpaper backgrounds supported * FontAwesome icons (also supports Self-hosted/Web image icons) * All settings in a single easy to edit json file, with built-in editor * Support for alternate configurations without needing multiple Dasherr installations WWW: https://github.com/erohtar/Dasherr/ PR: 272777
-rw-r--r--www/Makefile1
-rw-r--r--www/dasherr/Makefile24
-rw-r--r--www/dasherr/distinfo3
-rw-r--r--www/dasherr/pkg-descr17
-rw-r--r--www/dasherr/pkg-plist19
5 files changed, 64 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index bd973807ceb4..213d6cb4822f 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -127,6 +127,7 @@
SUBDIR += ctemplate
SUBDIR += cutelyst
SUBDIR += darkhttpd
+ SUBDIR += dasherr
SUBDIR += davical
SUBDIR += davix
SUBDIR += dddbl
diff --git a/www/dasherr/Makefile b/www/dasherr/Makefile
new file mode 100644
index 000000000000..12ae4ccbaac0
--- /dev/null
+++ b/www/dasherr/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= dasherr
+DISTVERSION= 1.05.01
+CATEGORIES= www
+MASTER_SITES= https://github.com/erohtar/Dasherr/releases/download/v${DISTVERSION}/
+DISTNAME= ${PORTNAME}.${DISTVERSION}
+
+MAINTAINER= DtxdF@disroot.org
+COMMENT= Lightweight dashboard for self-hosted services (and bookmarks)
+WWW= https://github.com/erohtar/Dasherr/
+
+LICENSE= GPLv3
+
+USES= php zip
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+WRKSRC= ${WRKDIR}/www
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${WWWDIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR}
+
+.include <bsd.port.mk>
diff --git a/www/dasherr/distinfo b/www/dasherr/distinfo
new file mode 100644
index 000000000000..07df4adbe3f3
--- /dev/null
+++ b/www/dasherr/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1694623100
+SHA256 (dasherr.1.05.01.zip) = 58fb869bbacad155bdbd57e6f568986b7ced711136065d8c8eead6d87daf0ccd
+SIZE (dasherr.1.05.01.zip) = 265321
diff --git a/www/dasherr/pkg-descr b/www/dasherr/pkg-descr
new file mode 100644
index 000000000000..d3ce3ec3d965
--- /dev/null
+++ b/www/dasherr/pkg-descr
@@ -0,0 +1,17 @@
+Dasherr is a minimal and lightweight dashboard for your self-hosted
+services (and bookmarks).
+
+Features:
+
+* Loads instantly + Remains light on resources
+* Responsive design (uses Bootstrap framework)
+* Shows Temperature, CPU load and Memory used by tapping into Glances
+ API (default 5s updates)
+* Built-in online check of services (checked only at time of page
+ load/refresh, to minimize background activity & load)
+* Several built-in Themes (easy to edit & add your own)
+* Wallpaper backgrounds supported
+* FontAwesome icons (also supports Self-hosted/Web image icons)
+* All settings in a single easy to edit json file, with built-in editor
+* Support for alternate configurations without needing multiple Dasherr
+ installations
diff --git a/www/dasherr/pkg-plist b/www/dasherr/pkg-plist
new file mode 100644
index 000000000000..f4e589c35de0
--- /dev/null
+++ b/www/dasherr/pkg-plist
@@ -0,0 +1,19 @@
+%%WWWDIR%%/editor.php
+%%WWWDIR%%/include/bootstrap.bundle.min.js
+%%WWWDIR%%/include/bootstrap.bundle.min.js.map
+%%WWWDIR%%/include/bootstrap.min.css
+%%WWWDIR%%/include/bootstrap.min.css.map
+%%WWWDIR%%/include/custom.css
+%%WWWDIR%%/include/editor_js.php
+%%WWWDIR%%/include/filesave.php
+%%WWWDIR%%/include/jquery.json-editor.min.js
+%%WWWDIR%%/include/jquery.min.js
+%%WWWDIR%%/include/preload.js
+%%WWWDIR%%/include/samplesettings.php
+%%WWWDIR%%/include/theming.js
+%%WWWDIR%%/include/worker.js
+%%WWWDIR%%/index.php
+%%WWWDIR%%/res/favicon.svg
+%%WWWDIR%%/settings.sh.json
+@sample(www,www,) %%WWWDIR%%/settings.sample.json %%WWWDIR%%/settings.json
+@dir %%WWWDIR%%/icons