aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2022-01-04 14:20:25 +0000
committerDiane Bruce <db@FreeBSD.org>2022-01-04 14:20:25 +0000
commita8bd0d5cd8d1292780967b8c8a94f5db9f3b3f13 (patch)
treed1cfcb55748f862d39e6b113b0f3af863eab8ecd
parentdcb0e7570a4651c00da7ad62f9234e19f2e73642 (diff)
audio/codec2: Unbreak swig
Numerous tiny changes in the git log for codec2 but the big one for us is fixing swig. codec2 exposed a complex type in an interface that swig breaks on. This impacts other ports such as gnuradio. upstream moved the interface to private and this unbreaks swig. N.B. I have patched out the Octave CML testjig for now since this will take more time to resolve. Patches welcome.
-rw-r--r--audio/codec2/Makefile21
-rw-r--r--audio/codec2/distinfo6
-rw-r--r--audio/codec2/pkg-plist2
3 files changed, 16 insertions, 13 deletions
diff --git a/audio/codec2/Makefile b/audio/codec2/Makefile
index 736f1af4c82b..b06a9672ae5a 100644
--- a/audio/codec2/Makefile
+++ b/audio/codec2/Makefile
@@ -1,6 +1,6 @@
PORTNAME= codec2
DISTVERSIONPREFIX=v
-DISTVERSION= 1.0.1
+DISTVERSION= 1.0.3
CATEGORIES= audio hamradio
MAINTAINER= hamradio@FreeBSD.org
@@ -17,7 +17,7 @@ GH_ACCOUNT= drowe67
GH_PROJECT= codec2
USE_LDCONFIG= yes
-USE_GITHUB= yes
+USE_GITHUB= yes
OPTIONS_DEFINE= EXAMPLES TEST
OPTIONS_SUB= yes
@@ -34,16 +34,21 @@ TEST_UNITTESTFILES= compare_ints fdmdv_mem ofdm_mem ofdm_stack \
tfreedv_data_channel tfsk tfsk_llr thash tnewamp1 \
tofdm tofdm_acq tqam16 tst_codec2_fft_init tvq_mbest
-SHEBANG_FILES= ${WRKSRC}/script/gen_phi0 \
+SHEBANG_FILES= ${WRKSRC}/script/separate_all.sh \
+ ${WRKSRC}/demo/freedv_700d_rx.py \
+ ${WRKSRC}/script/gen_phi0 \
${WRKSRC}/script/phi0_plot.py \
- ${WRKSRC}/script/build_cml.sh \
${WRKSRC}/script/subsetvq.sh \
${WRKSRC}/script/train_700c_quant.sh \
${WRKSRC}/script/ofdm_stack_use.py \
- ${WRKSRC}/script/train_sub_quant.sh
-
-TEST_RUN_DEPENDS= octave:math/octave
-TEST_LIB_DEPENDS= libsamplerate.so:audio/libsamplerate
+ ${WRKSRC}/script/train_sub_quant.sh \
+ ${WRKSRC}/unittest/*.sh \
+ ${WRKSRC}/octave/fsk_demod_BER_test.py \
+ ${WRKSRC}/octave/fskdemodgui.py \
+ ${WRKSRC}/octave/plot_fsk_demod_stats.py
+
+#TEST_RUN_DEPENDS= octave:math/octave
+#TEST_LIB_DEPENDS= libsamplerate.so:audio/libsamplerate
PORTEXAMPLES= *
diff --git a/audio/codec2/distinfo b/audio/codec2/distinfo
index aa8b64e2be1e..bb50c4dd79fe 100644
--- a/audio/codec2/distinfo
+++ b/audio/codec2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1640012007
-SHA256 (drowe67-codec2-v1.0.1_GH0.tar.gz) = 14227963940d79e0ec5af810f37101b30e1c7e8555abd96c56b3c0473abac8ef
-SIZE (drowe67-codec2-v1.0.1_GH0.tar.gz) = 15062219
+TIMESTAMP = 1641299100
+SHA256 (drowe67-codec2-v1.0.3_GH0.tar.gz) = 48162d562ea3bf4ca273f3c45df04505a006bd9a2b376006c75706c4de957da7
+SIZE (drowe67-codec2-v1.0.3_GH0.tar.gz) = 15000736
diff --git a/audio/codec2/pkg-plist b/audio/codec2/pkg-plist
index bd516aef4a46..8c205c851e0d 100644
--- a/audio/codec2/pkg-plist
+++ b/audio/codec2/pkg-plist
@@ -70,7 +70,6 @@ libdata/pkgconfig/codec2.pc
%%EXAMPLES%%%%DATADIR%%/octave/channel_lib.m
%%EXAMPLES%%%%DATADIR%%/octave/closed_quant_slope.m
%%EXAMPLES%%%%DATADIR%%/octave/cma.m
-%%EXAMPLES%%%%DATADIR%%/octave/cml.patch
%%EXAMPLES%%%%DATADIR%%/octave/codec2_demo.m
%%EXAMPLES%%%%DATADIR%%/octave/cohpsk_ch_fading.m
%%EXAMPLES%%%%DATADIR%%/octave/cohpsk_demod_plot.m
@@ -238,7 +237,6 @@ libdata/pkgconfig/codec2.pc
%%EXAMPLES%%%%DATADIR%%/raw/ve9qrp.raw
%%EXAMPLES%%%%DATADIR%%/raw/ve9qrp_10s.raw
%%EXAMPLES%%%%DATADIR%%/raw/vk5qi.raw
-%%EXAMPLES%%%%DATADIR%%/script/build_cml.sh
%%EXAMPLES%%%%DATADIR%%/script/gen_phi0
%%EXAMPLES%%%%DATADIR%%/script/ofdm_stack_use.py
%%EXAMPLES%%%%DATADIR%%/script/phi0_plot.py