aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2023-03-15 11:44:54 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2023-03-15 11:44:54 +0000
commita92961d7fda3210aef4cff9e90d9bfb5a68754f1 (patch)
treed1471be36cd05dd1f8c1b94b0f36b8b5371b2f60
parent127492fcf5206d9d5cd4768cabedaaf13fdd07b2 (diff)
downloadports-a92961d7fda3210aef4cff9e90d9bfb5a68754f1.tar.gz
ports-a92961d7fda3210aef4cff9e90d9bfb5a68754f1.zip
games/flightgear: fix build with lld 15 on i386
Disable dynamic relations checks on i386 (see also 145ca54 and 85d704c)
-rw-r--r--games/flightgear/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index bafb9d97211b..e14d1c011467 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -57,4 +57,10 @@ post-patch:
# Avoid conflict with C++20 <version> - used version file is flightgear-version
@${RM} ${WRKSRC}/version
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${COMPILER_TYPE} == "clang" && ${COMPILER_VERSION} >= 150
+LDFLAGS_i386+= -Wl,--no-check-dynamic-relocations
+.endif
+
+.include <bsd.port.post.mk>