aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:11:46 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:11:46 +0000
commita9382bc24be5b5efed854e9a63c49eb4d2f9404a (patch)
tree9bc9bf96707a9452daaf3b5c2c950a79f516b54e
parent46d51a9b6532a764dc18ad4bbc74818247c462c9 (diff)
downloadports-a9382bc24be5b5efed854e9a63c49eb4d2f9404a.tar.gz
ports-a9382bc24be5b5efed854e9a63c49eb4d2f9404a.zip
www/py-caldav: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for package change
-rw-r--r--www/py-caldav/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/www/py-caldav/Makefile b/www/py-caldav/Makefile
index 157f00b944e1..98008e587068 100644
--- a/www/py-caldav/Makefile
+++ b/www/py-caldav/Makefile
@@ -1,5 +1,6 @@
PORTNAME= caldav
PORTVERSION= 1.2.1
+PORTREVISION= 1
CATEGORIES= www python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,6 +14,8 @@ LICENSE_COMB= dual
LICENSE_FILE_APACHE20= ${WRKSRC}/COPYING.APACHE
LICENSE_FILE_GPLv3= ${WRKSRC}/COPYING.GPL
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}icalendar>=0:devel/py-icalendar@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}lxml>=0:devel/py-lxml@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}recurring-ical-events>=2.0.0:devel/py-recurring-ical-events@${PY_FLAVOR} \
@@ -25,7 +28,7 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}coverage>=0:devel/py-coverage@${PY_FLAVOR}
${PYTHON_PKGNAMEPREFIX}xandikos>=0:www/py-xandikos@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist concurrent distutils pytest
+USE_PYTHON= autoplist concurrent pep517 pytest
NO_ARCH= yes
TEST_ENV= TZ=UTC