aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2024-03-02 10:26:32 +0000
committerThomas Zander <riggs@FreeBSD.org>2024-03-02 18:36:02 +0000
commita995b8b0ab54b250167531dafc38fc1342558446 (patch)
tree987226ba5739e8b2af414e339e067b661abbd650
parent12b1194da2215559ef87e448b94d55a0d2b0a123 (diff)
multimedia/{mplayer/mencoder}: Move DEBUG from OPTIONS to WITH_DEBUG
Details: This is a revert of c1e0f931e3ddecb86d83ffc14cb8b05a38922cdd plus removing the DEBUG OPTION from mencoder as well, following the trend to phase out DEBUG as an option.
-rw-r--r--multimedia/mencoder/Makefile2
-rw-r--r--multimedia/mplayer/Makefile2
-rw-r--r--multimedia/mplayer/Makefile.options4
-rw-r--r--multimedia/mplayer/Makefile.optvars2
4 files changed, 6 insertions, 4 deletions
diff --git a/multimedia/mencoder/Makefile b/multimedia/mencoder/Makefile
index 30a7b88d3e2a..659d30b6ee48 100644
--- a/multimedia/mencoder/Makefile
+++ b/multimedia/mencoder/Makefile
@@ -8,7 +8,7 @@ WWW= http://www.mplayerhq.hu/
.include "${.CURDIR}/../mplayer/Makefile.common"
-OPTIONS_DEFINE= AMR_NB AMR_WB ASS BLURAY CDIO DEBUG DV DVDNAV FAAC FONTCONFIG \
+OPTIONS_DEFINE= AMR_NB AMR_WB ASS BLURAY CDIO DV DVDNAV FAAC FONTCONFIG \
FRIBIDI GIF GNUTLS GSM IPV6 JACK JPEG LADSPA LIBMNG LZO \
MAD NAS NLS OPENAL OPENJPEG OPUS PULSEAUDIO \
RTMP SMB SPEEX THEORA TWOLAME V4L VPX \
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 126cfd597a82..b9d91327e2c4 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -8,7 +8,7 @@ WWW= http://www.mplayerhq.hu/
.include "${.CURDIR}/../../multimedia/mplayer/Makefile.common"
-OPTIONS_DEFINE= AALIB AMR_NB AMR_WB ASS BLURAY CACA CDIO DEBUG DV DVDNAV \
+OPTIONS_DEFINE= AALIB AMR_NB AMR_WB ASS BLURAY CACA CDIO DV DVDNAV \
ENCA FONTCONFIG FRIBIDI GIF GNUTLS GSM GUI IPV6 JACK \
JPEG LADSPA LIBMNG LIRC LZO NAS NLS OPENAL OPENGL \
OPENJPEG OPUS PULSEAUDIO RTMP \
diff --git a/multimedia/mplayer/Makefile.options b/multimedia/mplayer/Makefile.options
index ebb2a84d0987..fd2ec8e9c602 100644
--- a/multimedia/mplayer/Makefile.options
+++ b/multimedia/mplayer/Makefile.options
@@ -57,6 +57,10 @@ CFLAGS+= -no-integrated-as
CONFIGURE_ARGS+= --enable-altivec
.endif
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug=3
+.endif
+
LDFLAGS_i386+= -Wl,-z,notext
# Win32 DLL codecs support on i386, mostly superseded by ffmpeg
diff --git a/multimedia/mplayer/Makefile.optvars b/multimedia/mplayer/Makefile.optvars
index 110814732ad7..49b139d7a4a8 100644
--- a/multimedia/mplayer/Makefile.optvars
+++ b/multimedia/mplayer/Makefile.optvars
@@ -24,8 +24,6 @@ CACA_CONFIGURE_OFF= --disable-caca
CDIO_LIB_DEPENDS= libcdio_paranoia.so:sysutils/libcdio-paranoia
CDIO_CONFIGURE_OFF= --disable-libcdio
-DEBUG_CONFIGURE_ON= --enable-debug=3
-
DV_LIB_DEPENDS= libdv.so:multimedia/libdv
DV_CONFIGURE_ENABLE= libdv