aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2021-07-04 19:37:00 +0000
committerBernard Spil <brnrd@FreeBSD.org>2021-07-04 19:37:00 +0000
commitaa204dbc489a748aa4dc6c7e0810ec30f51139ad (patch)
tree6e761dc01174f058524272e22a4753965ee416c9
parenta8b054c25ee7e660681644f570a8f82fd90b3d11 (diff)
downloadports-aa204dbc489a748aa4dc6c7e0810ec30f51139ad.tar.gz
ports-aa204dbc489a748aa4dc6c7e0810ec30f51139ad.zip
security/nextcloud-twofactor_webauthn: Add new port
PR: 252491 Submitted by: Henrik Rosenke <rosenke dssgmbh de>
-rw-r--r--security/Makefile1
-rw-r--r--security/nextcloud-twofactor_webauthn/Makefile36
-rw-r--r--security/nextcloud-twofactor_webauthn/distinfo3
-rw-r--r--security/nextcloud-twofactor_webauthn/pkg-descr3
4 files changed, 43 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index fd7179149d85..ee872ea21ec1 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -380,6 +380,7 @@
SUBDIR += nextcloud-passman
SUBDIR += nextcloud-twofactor_totp
SUBDIR += nextcloud-twofactor_u2f
+ SUBDIR += nextcloud-twofactor_webauthn
SUBDIR += nflib
SUBDIR += ngrok
SUBDIR += nikto
diff --git a/security/nextcloud-twofactor_webauthn/Makefile b/security/nextcloud-twofactor_webauthn/Makefile
new file mode 100644
index 000000000000..7bbfb09ff088
--- /dev/null
+++ b/security/nextcloud-twofactor_webauthn/Makefile
@@ -0,0 +1,36 @@
+# $FreeBSD$
+
+PORTNAME= twofactor_webauthn
+PORTVERSION= 0.2.10
+CATEGORIES= security
+PKGNAMEPREFIX= nextcloud-
+PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
+
+MAINTAINER= rosenke@dssgmbh.de
+COMMENT= U2F webauthn app for Nextcloud
+
+LICENSE= AGPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= nextcloud${PHP_PKGNAMESUFFIX}>=16:www/nextcloud@${PHP_FLAVOR}
+
+USES= php:flavors
+
+MASTER_SITES= https://github.com/michib/nextcloud_twofactor_webauthn/releases/download/v${PORTVERSION}/
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+WWWDIR= ${PREFIX}/www/nextcloud/apps-pkg/${PORTNAME}
+
+PLIST_DIRS= ${WWWDIR}/vendor/bin \
+ ${WWWDIR}/vendor/ramsey/collection/bin
+do-install:
+ ${MKDIR} ${STAGEDIR}${WWWDIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR})
+ (cd ${WRKSRC}; ${FIND} . -not -type d) | ${SORT} | \
+ ${SED} -e 's,^\.,${WWWDIR_REL},' >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/security/nextcloud-twofactor_webauthn/distinfo b/security/nextcloud-twofactor_webauthn/distinfo
new file mode 100644
index 000000000000..5da705f9b9d5
--- /dev/null
+++ b/security/nextcloud-twofactor_webauthn/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1625419973
+SHA256 (twofactor_webauthn-0.2.10.tar.gz) = 0d42b6be330feb73898ef83ddf5c7b7714468a56d11ae9786b3a870acf844fd4
+SIZE (twofactor_webauthn-0.2.10.tar.gz) = 1926424
diff --git a/security/nextcloud-twofactor_webauthn/pkg-descr b/security/nextcloud-twofactor_webauthn/pkg-descr
new file mode 100644
index 000000000000..fe2c347f0bec
--- /dev/null
+++ b/security/nextcloud-twofactor_webauthn/pkg-descr
@@ -0,0 +1,3 @@
+A two-factor provider for Webauthn devices
+
+WWW: https://apps.nextcloud.com/apps/twofactor_webauthn