aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2025-02-02 08:20:42 +0000
committerLorenzo Salvadore <salvadore@FreeBSD.org>2025-02-04 08:16:34 +0000
commitaac6274e7a2e0d07771a1989be1ad73d2844afba (patch)
tree62bbc530a65488cbac231c0ae34a1ee0c223f2b5
parent62342ea20266b3697c0f0342bd8d35da7776ffc8 (diff)
lang/gcc14-devel: Fix segfaults for static binaries
Fix segmentation faults caused by -static flag into compiled binaries. Email thread: https://lists.freebsd.org/archives/freebsd-hackers/2025-January/004236.html Upstream bug report: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=118685 PR: 284441 Reported by: kargl
-rw-r--r--lang/gcc14-devel/Makefile1
-rw-r--r--lang/gcc14-devel/files/patch-libgcc-config.host11
2 files changed, 12 insertions, 0 deletions
diff --git a/lang/gcc14-devel/Makefile b/lang/gcc14-devel/Makefile
index 8e76d6209e27..aec541c452f4 100644
--- a/lang/gcc14-devel/Makefile
+++ b/lang/gcc14-devel/Makefile
@@ -1,5 +1,6 @@
PORTNAME= gcc
PORTVERSION= 14.2.1.s20250125
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= lang
MASTER_SITES= GCC/snapshots/${DIST_VERSION}
diff --git a/lang/gcc14-devel/files/patch-libgcc-config.host b/lang/gcc14-devel/files/patch-libgcc-config.host
new file mode 100644
index 000000000000..c371f0d1e40b
--- /dev/null
+++ b/lang/gcc14-devel/files/patch-libgcc-config.host
@@ -0,0 +1,11 @@
+--- libgcc/config.host.orig 2025-01-30 12:31:26.479569000 -0800
++++ libgcc/config.host 2025-01-30 12:32:03.732682000 -0800
+@@ -286,7 +286,7 @@
+ # machine-specific sections may refine and add to this
+ # configuration.
+ tmake_file="$tmake_file t-freebsd t-crtstuff-pic t-libgcc-pic t-eh-dw2-dip t-slibgcc t-slibgcc-gld t-slibgcc-elf-ver"
+- extra_parts="crtbegin.o crtend.o crtbeginS.o crtendS.o"
++ extra_parts="crtbegin.o crtend.o crtbeginS.o crtbeginT.o crtendS.o"
+ case ${target_thread_file} in
+ posix)
+ tmake_file="${tmake_file} t-freebsd-thread"