aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2022-11-25 14:09:40 +0000
committerNicola Vitale <nivit@FreeBSD.org>2022-11-25 14:09:40 +0000
commitaadbba4de5e3ce5ac04407b12678dfc48264a89e (patch)
tree38abc207f3d51a4af8dd10273ebb751edc279c4c
parentd2dcb06cbdba99f751a344df3d08389da73cf447 (diff)
downloadports-aadbba4de5e3ce5ac04407b12678dfc48264a89e.tar.gz
ports-aadbba4de5e3ce5ac04407b12678dfc48264a89e.zip
x11/rofi-emoji: New port: Emoji selector plugin for rofi
An emoji selector plugin for Rofi that copies the selected emoji to the clipboard, among other things. The plugin adds a Rofi mode that displays a menu of emojis and allows searching by emoji names and their tags. The selected emoji can be copied or inserted. See the project web site or the optional port documentation for more features and configuration options. The plugin can be used, for example, by running Rofi with the following flags: rofi -modi emoji -show emoji PR: 265577 Reported by: Maja Reberc <maja.reberc@freedommail.ch>
-rw-r--r--x11/Makefile1
-rw-r--r--x11/rofi-emoji/Makefile38
-rw-r--r--x11/rofi-emoji/distinfo3
-rw-r--r--x11/rofi-emoji/pkg-descr12
-rw-r--r--x11/rofi-emoji/pkg-message9
-rw-r--r--x11/rofi-emoji/pkg-plist3
6 files changed, 66 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index b7aa393861c6..77731ee4dd4d 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -317,6 +317,7 @@
SUBDIR += rgb
SUBDIR += rofi
SUBDIR += rofi-calc
+ SUBDIR += rofi-emoji
SUBDIR += rofi-pass
SUBDIR += rofi-wayland
SUBDIR += roxterm
diff --git a/x11/rofi-emoji/Makefile b/x11/rofi-emoji/Makefile
new file mode 100644
index 000000000000..b45a7a060aa3
--- /dev/null
+++ b/x11/rofi-emoji/Makefile
@@ -0,0 +1,38 @@
+PORTNAME= rofi-emoji
+DISTVERSIONPREFIX= v
+DISTVERSION= 3.0.1
+CATEGORIES= x11
+
+MAINTAINER= maja.reberc@freedommail.ch
+COMMENT= Emoji selector plugin for rofi
+WWW= https://github.com/Mange/rofi-emoji
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= rofi:x11/rofi
+RUN_DEPENDS= rofi:x11/rofi \
+ xclip:x11/xclip \
+ xdotool:x11/xdotool \
+ xsel:x11/xsel-conrad
+
+USES= autoreconf gettext-runtime gnome libtool pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= Mange
+USE_GNOME= cairo glib20
+
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+
+PORTDOCS= README.md
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ ${REINPLACE_CMD} -e '/^dist_pkgdata_DATA/s/README.md LICENSE//' ${WRKSRC}/Makefile.am
+
+post-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/x11/rofi-emoji/distinfo b/x11/rofi-emoji/distinfo
new file mode 100644
index 000000000000..67fae24fce31
--- /dev/null
+++ b/x11/rofi-emoji/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1659445975
+SHA256 (Mange-rofi-emoji-v3.0.1_GH0.tar.gz) = a773e62acac7cb1d2e10ba838149f6508a7541e36b15b620299bd8b8f2fd2056
+SIZE (Mange-rofi-emoji-v3.0.1_GH0.tar.gz) = 364940
diff --git a/x11/rofi-emoji/pkg-descr b/x11/rofi-emoji/pkg-descr
new file mode 100644
index 000000000000..abf2cffaf963
--- /dev/null
+++ b/x11/rofi-emoji/pkg-descr
@@ -0,0 +1,12 @@
+An emoji selector plugin for Rofi that copies the selected emoji to the
+clipboard, among other things.
+
+The plugin adds a Rofi mode that displays a menu of emojis and allows
+searching by emoji names and their tags. The selected emoji can be
+copied or inserted. See the project web site or the optional port
+documentation for more features and configuration options.
+
+The plugin can be used, for example, by running Rofi with the following
+flags:
+
+ rofi -modi emoji -show emoji
diff --git a/x11/rofi-emoji/pkg-message b/x11/rofi-emoji/pkg-message
new file mode 100644
index 000000000000..52a79ab7afce
--- /dev/null
+++ b/x11/rofi-emoji/pkg-message
@@ -0,0 +1,9 @@
+[
+{ type: install
+ message: <<EOM
+For copy and insert support on Wayland, install the following ports:
+ * x11/wl-clipboard
+ * x11/wtype
+EOM
+}
+]
diff --git a/x11/rofi-emoji/pkg-plist b/x11/rofi-emoji/pkg-plist
new file mode 100644
index 000000000000..4543356704e8
--- /dev/null
+++ b/x11/rofi-emoji/pkg-plist
@@ -0,0 +1,3 @@
+lib/rofi/emoji.so
+%%DATADIR%%/all_emojis.txt
+%%DATADIR%%/clipboard-adapter.sh