aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-03-25 13:04:53 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-03-25 13:37:17 +0000
commitaaf59e6e78c21a5c0fb917455c8a4b84a46e4572 (patch)
treeef6474780a25857d63b0f27c2eabc6bcf84a88a3
parent213add47de1a7e72d3f37dcadf68422fb34fbb73 (diff)
downloadports-aaf59e6e78c21a5c0fb917455c8a4b84a46e4572.tar.gz
ports-aaf59e6e78c21a5c0fb917455c8a4b84a46e4572.zip
www/py-bleach: Update to 4.1.0
- Remove LICENSE_FILE: it only has the link but no content - Update pkg-descr Changes: https://github.com/mozilla/bleach/blob/main/CHANGES
-rw-r--r--www/py-bleach/Makefile26
-rw-r--r--www/py-bleach/distinfo6
-rw-r--r--www/py-bleach/pkg-descr18
3 files changed, 29 insertions, 21 deletions
diff --git a/www/py-bleach/Makefile b/www/py-bleach/Makefile
index 7eef3bb0a048..9b71a380e0c3 100644
--- a/www/py-bleach/Makefile
+++ b/www/py-bleach/Makefile
@@ -1,7 +1,7 @@
# Created by: Kubilay Kocak <koobs@FreeBSD.org>
PORTNAME= bleach
-PORTVERSION= 3.1.5
+PORTVERSION= 4.1.0
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -10,26 +10,22 @@ MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Easy safelist-based HTML-sanitizing tool
LICENSE= APACHE20
-LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.9.0:devel/py-six@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}webencodings>0:converters/py-webencodings@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}packaging>0:devel/py-packaging@${PY_FLAVOR}
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=3.0.0:devel/py-pytest@${PY_FLAVOR}
+xRUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}packaging>=0:devel/py-packaging@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.9.0:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}webencodings>=0:converters/py-webencodings@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0,1:devel/py-pytest@${PY_FLAVOR}
-USES= cpe python:3.6+
-USE_PYTHON= autoplist distutils
-
-CPE_VENDOR= mozilla
+USES= cpe python:3.6+ shebangfix
+USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
-# This is a development script
-# TODO: Remove from sdist (via MANIFEST.ini)
-post-extract:
- ${RM} ${WRKSRC}/bleach/_vendor/pip_install_vendor.sh
+CPE_VENDOR= mozilla
+
+SHEBANG_FILES= bleach/_vendor/vendor_install.sh
do-test:
- @cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -v -rs -o addopts=
+ cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -rs -v
.include <bsd.port.mk>
diff --git a/www/py-bleach/distinfo b/www/py-bleach/distinfo
index 9bef3591ecd4..6ad3db7f84d8 100644
--- a/www/py-bleach/distinfo
+++ b/www/py-bleach/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1588872176
-SHA256 (bleach-3.1.5.tar.gz) = 3c4c520fdb9db59ef139915a5db79f8b51bc2a7257ea0389f30c846883430a4b
-SIZE (bleach-3.1.5.tar.gz) = 177972
+TIMESTAMP = 1647264688
+SHA256 (bleach-4.1.0.tar.gz) = 0900d8b37eba61a802ee40ac0061f8c2b5dee29c1927dd1d233e075ebf5a71da
+SIZE (bleach-4.1.0.tar.gz) = 195798
diff --git a/www/py-bleach/pkg-descr b/www/py-bleach/pkg-descr
index 2b4180e181f1..cd710a3f814c 100644
--- a/www/py-bleach/pkg-descr
+++ b/www/py-bleach/pkg-descr
@@ -1,5 +1,17 @@
-Bleach is a Python HTML sanitizing library that escapes or strips markup and
-attributes based on a white list. Bleach is intended for sanitizing text from
-untrusted sources.
+Bleach is an allowed-list-based HTML sanitizing library that escapes or strips
+markup and attributes.
+
+Bleach can also linkify text safely, applying filters that Django's urlize
+filter cannot, and optionally setting rel attributes, even on links already in
+the text.
+
+Bleach is intended for sanitizing text from untrusted sources. If you find
+yourself jumping through hoops to allow your site administrators to do lots of
+things, you're probably outside the use cases. Either trust those users, or
+don't.
+
+Because it relies on html5lib, Bleach is as good as modern browsers at dealing
+with weird, quirky HTML fragments. And any of Bleach's methods will fix
+unbalanced or mis-nested tags.
WWW: https://github.com/mozilla/bleach