aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2023-12-24 15:38:00 +0000
committerThierry Thomas <thierry@FreeBSD.org>2024-05-05 17:29:41 +0000
commitab0d503815a3e4df3b72cedc2d82e9f573f211d2 (patch)
treeef52a5a636f8d8ea4055a3b4ea80fdad8c87d36c
parente81ee93ff9acebbcd7c8e50b8b5b21fe50bc9759 (diff)
downloadports-ab0d503815a3e4df3b72cedc2d82e9f573f211d2.tar.gz
ports-ab0d503815a3e4df3b72cedc2d82e9f573f211d2.zip
math/hpcombi: upgrade to 1.0.1
-rw-r--r--math/hpcombi/Makefile21
-rw-r--r--math/hpcombi/distinfo6
-rw-r--r--math/hpcombi/pkg-plist120
3 files changed, 99 insertions, 48 deletions
diff --git a/math/hpcombi/Makefile b/math/hpcombi/Makefile
index 0b4ed63b1e11..0879f3c421be 100644
--- a/math/hpcombi/Makefile
+++ b/math/hpcombi/Makefile
@@ -1,5 +1,5 @@
PORTNAME= HPCombi
-PORTVERSION= 0.0.9
+PORTVERSION= 1.0.1
DISTVERSIONPREFIX= v
CATEGORIES= math devel
@@ -19,7 +19,10 @@ TEST_DEPENDS= boost-libs>0:devel/boost-libs
USE_GITHUB= yes
GH_ACCOUNT= hivert
-USES= cmake:testing compiler:c++11-lang localbase:ldflags pkgconfig
+USES= cmake:testing compiler:c++11-lang localbase:ldflags pathfix \
+ pkgconfig
+
+CMAKE_ARGS= -DHPCOMBI_DISABLE_MARCH_NATIVE:BOOL=on
NO_ARCH= yes
@@ -29,7 +32,10 @@ OPTIONS_SUB= yes
DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
DOXYGEN_CMAKE_ON= -DAPIDOC_DIR=${DOCSDIR}
TEST_CMAKE_ON= -DBUILD_TESTING=1
-TEST_LIB_DEPENDS= libboost_thread.so:devel/boost-libs
+TEST_LIB_DEPENDS= libCatch2.so:devel/catch2
+
+DATADIR= ${PREFIX}/share/${PORTNAME:tl}
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME:tl}
.include <bsd.port.options.mk>
@@ -37,12 +43,9 @@ pre-configure-DOXYGEN-off:
${REINPLACE_CMD} -e 's/add_subdirectory(doc)/# No doc/' \
${WRKSRC}/CMakeLists.txt
-post-stage:
- ${MKDIR} ${STAGEDIR}${DATADIR}
- ${MV} ${STAGEDIR}${PREFIX}/.VERSION ${STAGEDIR}${DATADIR}/VERSION
-
post-stage-DOXYGEN-on:
- ${MV} ${STAGEDIR}${PREFIX}/doc/${PORTNAME}/html ${STAGEDIR}${DOCSDIR}/
- ${RM} -r ${STAGEDIR}${PREFIX}/doc
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${BUILD_WRKSRC}/doc/html && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>
diff --git a/math/hpcombi/distinfo b/math/hpcombi/distinfo
index 03536b33f3f3..f83ebbe67739 100644
--- a/math/hpcombi/distinfo
+++ b/math/hpcombi/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1698081798
-SHA256 (hivert-HPCombi-v0.0.9_GH0.tar.gz) = f3560005c50bbc3ca5fab4380469292f7a10130d13fd06367d647d44e033498e
-SIZE (hivert-HPCombi-v0.0.9_GH0.tar.gz) = 116246
+TIMESTAMP = 1714924713
+SHA256 (hivert-HPCombi-v1.0.1_GH0.tar.gz) = cb4ca64c5daa0ba147832252ddc8f6162c1f3aefabda4dd139f3da1cb3cae987
+SIZE (hivert-HPCombi-v1.0.1_GH0.tar.gz) = 3118941
diff --git a/math/hpcombi/pkg-plist b/math/hpcombi/pkg-plist
index 09e3de32fa67..080e194cf7cb 100644
--- a/math/hpcombi/pkg-plist
+++ b/math/hpcombi/pkg-plist
@@ -1,29 +1,48 @@
-include/HPCombi/HPCombi-config.h
-include/HPCombi/bmat8.hpp
-include/HPCombi/bmat8_impl.hpp
-include/HPCombi/epu.hpp
-include/HPCombi/epu_impl.hpp
-include/HPCombi/fallback/gcdlcm.hpp
-include/HPCombi/fallback/seq.hpp
-include/HPCombi/hpcombi.hpp
-include/HPCombi/perm16.hpp
-include/HPCombi/perm16_impl.hpp
-include/HPCombi/perm_generic.hpp
-include/HPCombi/perm_generic_impl.hpp
-include/HPCombi/power.hpp
-include/HPCombi/testtools.hpp
-include/HPCombi/vect16.hpp
-include/HPCombi/vect_generic.hpp
-%%DATADIR%%/LICENSE
-%%DATADIR%%/README.md
-%%DATADIR%%/VERSION
-%%DATADIR%%/list_intrin.txt
+include/hpcombi/arch.hpp
+include/hpcombi/bmat8.hpp
+include/hpcombi/bmat8_impl.hpp
+include/hpcombi/builder.hpp
+include/hpcombi/debug.hpp
+include/hpcombi/epu8.hpp
+include/hpcombi/epu8_impl.hpp
+include/hpcombi/hpcombi.hpp
+include/hpcombi/perm16.hpp
+include/hpcombi/perm16_impl.hpp
+include/hpcombi/perm_generic.hpp
+include/hpcombi/perm_generic_impl.hpp
+include/hpcombi/power.hpp
+include/hpcombi/simde/arm/neon.h
+include/hpcombi/simde/arm/sve.h
+include/hpcombi/simde/mips/msa.h
+include/hpcombi/simde/wasm/relaxed-simd.h
+include/hpcombi/simde/wasm/simd128.h
+include/hpcombi/simde/x86/avx.h
+include/hpcombi/simde/x86/avx2.h
+include/hpcombi/simde/x86/avx512.h
+include/hpcombi/simde/x86/clmul.h
+include/hpcombi/simde/x86/f16c.h
+include/hpcombi/simde/x86/fma.h
+include/hpcombi/simde/x86/gfni.h
+include/hpcombi/simde/x86/mmx.h
+include/hpcombi/simde/x86/sse.h
+include/hpcombi/simde/x86/sse2.h
+include/hpcombi/simde/x86/sse3.h
+include/hpcombi/simde/x86/sse4.1.h
+include/hpcombi/simde/x86/sse4.2.h
+include/hpcombi/simde/x86/ssse3.h
+include/hpcombi/simde/x86/svml.h
+include/hpcombi/simde/x86/xop.h
+include/hpcombi/vect16.hpp
+include/hpcombi/vect_generic.hpp
+libdata/pkgconfig/hpcombi.pc
%%DOXYGEN%%%%DOCSDIR%%/CF_8cpp.html
%%DOXYGEN%%%%DOCSDIR%%/RD_8cpp.html
%%DOXYGEN%%%%DOCSDIR%%/README_8md.html
%%DOXYGEN%%%%DOCSDIR%%/Renner_8cpp.html
%%DOXYGEN%%%%DOCSDIR%%/Trans_8cpp.html
%%DOXYGEN%%%%DOCSDIR%%/annotated.html
+%%DOXYGEN%%%%DOCSDIR%%/arch_8hpp.html
+%%DOXYGEN%%%%DOCSDIR%%/arch_8hpp_source.html
%%DOXYGEN%%%%DOCSDIR%%/bc_s.png
%%DOXYGEN%%%%DOCSDIR%%/bc_sd.png
%%DOXYGEN%%%%DOCSDIR%%/bdwn.png
@@ -31,26 +50,50 @@ include/HPCombi/vect_generic.hpp
%%DOXYGEN%%%%DOCSDIR%%/bmat8_8hpp_source.html
%%DOXYGEN%%%%DOCSDIR%%/bmat8__impl_8hpp.html
%%DOXYGEN%%%%DOCSDIR%%/bmat8__impl_8hpp_source.html
+%%DOXYGEN%%%%DOCSDIR%%/builder_8hpp.html
+%%DOXYGEN%%%%DOCSDIR%%/builder_8hpp_source.html
%%DOXYGEN%%%%DOCSDIR%%/classEqEpu8-members.html
%%DOXYGEN%%%%DOCSDIR%%/classEqEpu8.html
%%DOXYGEN%%%%DOCSDIR%%/classHPCombi_1_1BMat8-members.html
%%DOXYGEN%%%%DOCSDIR%%/classHPCombi_1_1BMat8.html
+%%DOXYGEN%%%%DOCSDIR%%/classcommon__eval16.html
+%%DOXYGEN%%%%DOCSDIR%%/classcommon__first__diff.html
+%%DOXYGEN%%%%DOCSDIR%%/classcommon__horiz__max.html
+%%DOXYGEN%%%%DOCSDIR%%/classcommon__horiz__min.html
+%%DOXYGEN%%%%DOCSDIR%%/classcommon__horiz__sum.html
+%%DOXYGEN%%%%DOCSDIR%%/classcommon__inverse.html
+%%DOXYGEN%%%%DOCSDIR%%/classcommon__inverse__pperm.html
+%%DOXYGEN%%%%DOCSDIR%%/classcommon__is__permutation.html
+%%DOXYGEN%%%%DOCSDIR%%/classcommon__last__diff.html
+%%DOXYGEN%%%%DOCSDIR%%/classcommon__left__weak__leq.html
+%%DOXYGEN%%%%DOCSDIR%%/classcommon__lehmer.html
+%%DOXYGEN%%%%DOCSDIR%%/classcommon__length.html
+%%DOXYGEN%%%%DOCSDIR%%/classcommon__merge.html
+%%DOXYGEN%%%%DOCSDIR%%/classcommon__nb__cycles.html
+%%DOXYGEN%%%%DOCSDIR%%/classcommon__nb__descent.html
+%%DOXYGEN%%%%DOCSDIR%%/classcommon__partial__max.html
+%%DOXYGEN%%%%DOCSDIR%%/classcommon__partial__min.html
+%%DOXYGEN%%%%DOCSDIR%%/classcommon__partial__sums.html
+%%DOXYGEN%%%%DOCSDIR%%/classcommon__permutation__of.html
%%DOXYGEN%%%%DOCSDIR%%/classes.html
%%DOXYGEN%%%%DOCSDIR%%/classlibsemigroups_1_1Timer-members.html
%%DOXYGEN%%%%DOCSDIR%%/classlibsemigroups_1_1Timer.html
%%DOXYGEN%%%%DOCSDIR%%/closed.png
-%%DOXYGEN%%%%DOCSDIR%%/dir_0db0c2784d05c3f959cfa752b3f7abf0.html
-%%DOXYGEN%%%%DOCSDIR%%/dir_16297faf57ecca27a43d4fe4826672df.html
-%%DOXYGEN%%%%DOCSDIR%%/dir_399fcd459c39eaea27e062c0b625bd94.html
+%%DOXYGEN%%%%DOCSDIR%%/debug_8hpp.html
+%%DOXYGEN%%%%DOCSDIR%%/debug_8hpp_source.html
+%%DOXYGEN%%%%DOCSDIR%%/dir_1e34260fbe3e2c78524d115df3415a52.html
+%%DOXYGEN%%%%DOCSDIR%%/dir_31749fb8972ad8a7386205728c9be108.html
+%%DOXYGEN%%%%DOCSDIR%%/dir_5c6484f6ec767dff3e262e005d99c715.html
+%%DOXYGEN%%%%DOCSDIR%%/dir_d0fe14f1bc4ab32e9041cb4d0f1cc6ae.html
%%DOXYGEN%%%%DOCSDIR%%/doc.png
%%DOXYGEN%%%%DOCSDIR%%/docd.png
%%DOXYGEN%%%%DOCSDIR%%/doxygen.css
%%DOXYGEN%%%%DOCSDIR%%/doxygen.svg
%%DOXYGEN%%%%DOCSDIR%%/dynsections.js
-%%DOXYGEN%%%%DOCSDIR%%/epu_8hpp.html
-%%DOXYGEN%%%%DOCSDIR%%/epu_8hpp_source.html
-%%DOXYGEN%%%%DOCSDIR%%/epu__impl_8hpp.html
-%%DOXYGEN%%%%DOCSDIR%%/epu__impl_8hpp_source.html
+%%DOXYGEN%%%%DOCSDIR%%/epu8_8hpp.html
+%%DOXYGEN%%%%DOCSDIR%%/epu8_8hpp_source.html
+%%DOXYGEN%%%%DOCSDIR%%/epu8__impl_8hpp.html
+%%DOXYGEN%%%%DOCSDIR%%/epu8__impl_8hpp_source.html
%%DOXYGEN%%%%DOCSDIR%%/examples.html
%%DOXYGEN%%%%DOCSDIR%%/files.html
%%DOXYGEN%%%%DOCSDIR%%/folderclosed.png
@@ -111,6 +154,7 @@ include/HPCombi/vect_generic.hpp
%%DOXYGEN%%%%DOCSDIR%%/menu.js
%%DOXYGEN%%%%DOCSDIR%%/menudata.js
%%DOXYGEN%%%%DOCSDIR%%/namespaceHPCombi.html
+%%DOXYGEN%%%%DOCSDIR%%/namespaceHPCombi_1_1detail.html
%%DOXYGEN%%%%DOCSDIR%%/namespaceHPCombi_1_1power__helper.html
%%DOXYGEN%%%%DOCSDIR%%/namespacelibsemigroups.html
%%DOXYGEN%%%%DOCSDIR%%/namespacemembers.html
@@ -125,6 +169,7 @@ include/HPCombi/vect_generic.hpp
%%DOXYGEN%%%%DOCSDIR%%/nav_h.png
%%DOXYGEN%%%%DOCSDIR%%/nav_hd.png
%%DOXYGEN%%%%DOCSDIR%%/open.png
+%%DOXYGEN%%%%DOCSDIR%%/pattern_8cpp.html
%%DOXYGEN%%%%DOCSDIR%%/perm16_8hpp.html
%%DOXYGEN%%%%DOCSDIR%%/perm16_8hpp_source.html
%%DOXYGEN%%%%DOCSDIR%%/perm16__impl_8hpp.html
@@ -142,7 +187,6 @@ include/HPCombi/vect_generic.hpp
%%DOXYGEN%%%%DOCSDIR%%/search/all_12.js
%%DOXYGEN%%%%DOCSDIR%%/search/all_13.js
%%DOXYGEN%%%%DOCSDIR%%/search/all_14.js
-%%DOXYGEN%%%%DOCSDIR%%/search/all_15.js
%%DOXYGEN%%%%DOCSDIR%%/search/all_2.js
%%DOXYGEN%%%%DOCSDIR%%/search/all_3.js
%%DOXYGEN%%%%DOCSDIR%%/search/all_4.js
@@ -166,10 +210,10 @@ include/HPCombi/vect_generic.hpp
%%DOXYGEN%%%%DOCSDIR%%/search/classes_6.js
%%DOXYGEN%%%%DOCSDIR%%/search/classes_7.js
%%DOXYGEN%%%%DOCSDIR%%/search/classes_8.js
+%%DOXYGEN%%%%DOCSDIR%%/search/classes_9.js
%%DOXYGEN%%%%DOCSDIR%%/search/close.svg
%%DOXYGEN%%%%DOCSDIR%%/search/defines_0.js
%%DOXYGEN%%%%DOCSDIR%%/search/defines_1.js
-%%DOXYGEN%%%%DOCSDIR%%/search/defines_2.js
%%DOXYGEN%%%%DOCSDIR%%/search/files_0.js
%%DOXYGEN%%%%DOCSDIR%%/search/files_1.js
%%DOXYGEN%%%%DOCSDIR%%/search/files_2.js
@@ -180,6 +224,8 @@ include/HPCombi/vect_generic.hpp
%%DOXYGEN%%%%DOCSDIR%%/search/files_7.js
%%DOXYGEN%%%%DOCSDIR%%/search/files_8.js
%%DOXYGEN%%%%DOCSDIR%%/search/files_9.js
+%%DOXYGEN%%%%DOCSDIR%%/search/files_a.js
+%%DOXYGEN%%%%DOCSDIR%%/search/files_b.js
%%DOXYGEN%%%%DOCSDIR%%/search/functions_0.js
%%DOXYGEN%%%%DOCSDIR%%/search/functions_1.js
%%DOXYGEN%%%%DOCSDIR%%/search/functions_10.js
@@ -231,7 +277,6 @@ include/HPCombi/vect_generic.hpp
%%DOXYGEN%%%%DOCSDIR%%/search/variables_9.js
%%DOXYGEN%%%%DOCSDIR%%/search/variables_a.js
%%DOXYGEN%%%%DOCSDIR%%/search/variables_b.js
-%%DOXYGEN%%%%DOCSDIR%%/search/variables_c.js
%%DOXYGEN%%%%DOCSDIR%%/splitbar.png
%%DOXYGEN%%%%DOCSDIR%%/splitbard.png
%%DOXYGEN%%%%DOCSDIR%%/stringmonoid_8cpp-example.html
@@ -248,6 +293,8 @@ include/HPCombi/vect_generic.hpp
%%DOXYGEN%%%%DOCSDIR%%/structHPCombi_1_1PermGeneric-members.html
%%DOXYGEN%%%%DOCSDIR%%/structHPCombi_1_1PermGeneric.html
%%DOXYGEN%%%%DOCSDIR%%/structHPCombi_1_1PermGeneric.png
+%%DOXYGEN%%%%DOCSDIR%%/structHPCombi_1_1TPUBuild-members.html
+%%DOXYGEN%%%%DOCSDIR%%/structHPCombi_1_1TPUBuild.html
%%DOXYGEN%%%%DOCSDIR%%/structHPCombi_1_1Transf16-members.html
%%DOXYGEN%%%%DOCSDIR%%/structHPCombi_1_1Transf16.html
%%DOXYGEN%%%%DOCSDIR%%/structHPCombi_1_1Transf16.png
@@ -273,14 +320,14 @@ include/HPCombi/vect_generic.hpp
%%DOXYGEN%%%%DOCSDIR%%/structstd_1_1hash_3_01HPCombi_1_1PTransf16_01_4.html
%%DOXYGEN%%%%DOCSDIR%%/structstd_1_1hash_3_01HPCombi_1_1Perm16_01_4-members.html
%%DOXYGEN%%%%DOCSDIR%%/structstd_1_1hash_3_01HPCombi_1_1Perm16_01_4.html
-%%DOXYGEN%%%%DOCSDIR%%/structstd_1_1hash_3_01HPCombi_1_1PermGeneric_3_01__Size_00_01Expo_01_4_01_4-members.html
-%%DOXYGEN%%%%DOCSDIR%%/structstd_1_1hash_3_01HPCombi_1_1PermGeneric_3_01__Size_00_01Expo_01_4_01_4.html
+%%DOXYGEN%%%%DOCSDIR%%/structstd_1_1hash_3_01HPCombi_1_1PermGeneric_3_01Size_00_01Expo_01_4_01_4-members.html
+%%DOXYGEN%%%%DOCSDIR%%/structstd_1_1hash_3_01HPCombi_1_1PermGeneric_3_01Size_00_01Expo_01_4_01_4.html
%%DOXYGEN%%%%DOCSDIR%%/structstd_1_1hash_3_01HPCombi_1_1Transf16_01_4-members.html
%%DOXYGEN%%%%DOCSDIR%%/structstd_1_1hash_3_01HPCombi_1_1Transf16_01_4.html
%%DOXYGEN%%%%DOCSDIR%%/structstd_1_1hash_3_01HPCombi_1_1Vect16_01_4-members.html
%%DOXYGEN%%%%DOCSDIR%%/structstd_1_1hash_3_01HPCombi_1_1Vect16_01_4.html
-%%DOXYGEN%%%%DOCSDIR%%/structstd_1_1hash_3_01HPCombi_1_1VectGeneric_3_01__Size_00_01Expo_01_4_01_4-members.html
-%%DOXYGEN%%%%DOCSDIR%%/structstd_1_1hash_3_01HPCombi_1_1VectGeneric_3_01__Size_00_01Expo_01_4_01_4.html
+%%DOXYGEN%%%%DOCSDIR%%/structstd_1_1hash_3_01HPCombi_1_1VectGeneric_3_01Size_00_01Expo_01_4_01_4-members.html
+%%DOXYGEN%%%%DOCSDIR%%/structstd_1_1hash_3_01HPCombi_1_1VectGeneric_3_01Size_00_01Expo_01_4_01_4.html
%%DOXYGEN%%%%DOCSDIR%%/structstd_1_1hash_3_01HPCombi_1_1epu8_01_4-members.html
%%DOXYGEN%%%%DOCSDIR%%/structstd_1_1hash_3_01HPCombi_1_1epu8_01_4.html
%%DOXYGEN%%%%DOCSDIR%%/structstd_1_1less_3_01HPCombi_1_1epu8_01_4-members.html
@@ -298,11 +345,12 @@ include/HPCombi/vect_generic.hpp
%%DOXYGEN%%%%DOCSDIR%%/tab_s.png
%%DOXYGEN%%%%DOCSDIR%%/tab_sd.png
%%DOXYGEN%%%%DOCSDIR%%/tabs.css
-%%DOXYGEN%%%%DOCSDIR%%/testtools_8hpp.html
-%%DOXYGEN%%%%DOCSDIR%%/testtools_8hpp_source.html
%%DOXYGEN%%%%DOCSDIR%%/timer_8h.html
%%DOXYGEN%%%%DOCSDIR%%/timer_8h_source.html
%%DOXYGEN%%%%DOCSDIR%%/vect16_8hpp.html
%%DOXYGEN%%%%DOCSDIR%%/vect16_8hpp_source.html
%%DOXYGEN%%%%DOCSDIR%%/vect__generic_8hpp.html
%%DOXYGEN%%%%DOCSDIR%%/vect__generic_8hpp_source.html
+%%DATADIR%%/HPCOMBI_VERSION
+%%DATADIR%%/LICENSE
+%%DATADIR%%/README.md