aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-07-21 17:20:30 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-07-21 17:20:30 +0000
commitab3f6b12dbf2df281f6ec5f724e1fe03c803f16f (patch)
tree7cbcd4e32ad6c3ac05b1e224e033dac0dfa21942
parent06bfa6d13ea998e617e2ba7b263c63d867520344 (diff)
downloadports-ab3f6b12dbf2df281f6ec5f724e1fe03c803f16f.tar.gz
ports-ab3f6b12dbf2df281f6ec5f724e1fe03c803f16f.zip
science/elmerfem: Fix bug that build selected arbitrary Python versions
When built from port it selected a higher Python version when it was available producing broken binaries. Approved by: portmgr (bugfix)
-rw-r--r--science/elmerfem/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/science/elmerfem/Makefile b/science/elmerfem/Makefile
index 246db5a1d858..69c198240fb5 100644
--- a/science/elmerfem/Makefile
+++ b/science/elmerfem/Makefile
@@ -63,7 +63,8 @@ OCC_LIB_DEPENDS= libexpat.so:textproc/expat2 \
libvtksys-9.1.so:math/vtk9
OCC_USES= python
OCC_CMAKE_BOOL= WITH_OCC
-OCC_CMAKE_ON= -DVTK_DIR=${LOCALBASE}/lib/cmake/vtk-9.0
+OCC_CMAKE_ON= -DVTK_DIR=${LOCALBASE}/lib/cmake/vtk-9.0 \
+ -DPython3_EXECUTABLE=${PYTHON_CMD}
_LIBSTAGEDIR= ${STAGEDIR}/${PREFIX}/lib/elmersolver
_PYVERSION= ${PYTHON_VER}${PYTHON_ABIVER}