aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladyslav Movchan <vladislav.movchan@gmail.com>2024-09-03 07:32:04 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2024-09-04 20:34:32 +0000
commitab5064ebfda3bcf014a348da88e4bb63b962c92e (patch)
treed51be51dbfa339c645a41f134e9d18fb1b77a76f
parent2e5eef9e103594b9396a69b26e14bc135aa4c2e7 (diff)
downloadports-ab5064ebfda3bcf014a348da88e4bb63b962c92e.tar.gz
ports-ab5064ebfda3bcf014a348da88e4bb63b962c92e.zip
x11/wezterm: Fix build with Rust 1.80.1
PR: 281212 Reported by: vladislav.movchan@gmail.com (maintainer)
-rw-r--r--x11/wezterm/Makefile4
-rw-r--r--x11/wezterm/Makefile.crates2
-rw-r--r--x11/wezterm/distinfo6
-rw-r--r--x11/wezterm/files/patch-Cargo.lock14
-rw-r--r--x11/wezterm/files/patch-cargo-crates_time-0.3.31_src_format__description_parse_mod.rs19
-rw-r--r--x11/wezterm/files/patch-window_Cargo.toml11
-rw-r--r--x11/wezterm/pkg-descr5
7 files changed, 51 insertions, 10 deletions
diff --git a/x11/wezterm/Makefile b/x11/wezterm/Makefile
index 3f7e685151e7..044413efaf2b 100644
--- a/x11/wezterm/Makefile
+++ b/x11/wezterm/Makefile
@@ -1,6 +1,6 @@
PORTNAME= wezterm
DISTVERSION= 20240203-110809-5046fc22
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 wayland
MAINTAINER= vladislav.movchan@gmail.com
@@ -18,7 +18,7 @@ LIB_DEPENDS= libzstd.so:archivers/zstd \
libxcb-util.so:x11/xcb-util \
libxcb-image.so:x11/xcb-util-image
-USES= cargo ssl xorg
+USES= cargo desktop-file-utils ssl xorg
USE_GITHUB= yes
USE_GITLAB= nodefault
USE_XORG= x11 xcb
diff --git a/x11/wezterm/Makefile.crates b/x11/wezterm/Makefile.crates
index abd7d466fb58..93ec62713fc5 100644
--- a/x11/wezterm/Makefile.crates
+++ b/x11/wezterm/Makefile.crates
@@ -199,7 +199,7 @@ CARGO_CRATES= addr2line-0.21.0 \
gimli-0.28.1 \
git2-0.16.1 \
gl_generator-0.14.0 \
- glium-0.31.0 \
+ glium-0.32.1 \
glob-0.3.1 \
globset-0.4.14 \
globwalk-0.9.1 \
diff --git a/x11/wezterm/distinfo b/x11/wezterm/distinfo
index 47ba4060d197..2fbeaaf87442 100644
--- a/x11/wezterm/distinfo
+++ b/x11/wezterm/distinfo
@@ -1,4 +1,4 @@
-TIMESTAMP = 1715853494
+TIMESTAMP = 1725297326
SHA256 (rust/crates/addr2line-0.21.0.crate) = 8a30b2e23b9e17a9f90641c7ab1549cd9b44f296d3ccbf309d2863cfe398a0cb
SIZE (rust/crates/addr2line-0.21.0.crate) = 40807
SHA256 (rust/crates/adler-1.0.2.crate) = f26201604c87b1e01bd3d98f8d5d9a8fcbb815e8cedb41ffccbeb4bf593a35fe
@@ -401,8 +401,8 @@ SHA256 (rust/crates/git2-0.16.1.crate) = ccf7f68c2995f392c49fffb4f95ae2c87329783
SIZE (rust/crates/git2-0.16.1.crate) = 199956
SHA256 (rust/crates/gl_generator-0.14.0.crate) = 1a95dfc23a2b4a9a2f5ab41d194f8bfda3cabec42af4e39f08c339eb2a0c124d
SIZE (rust/crates/gl_generator-0.14.0.crate) = 22330
-SHA256 (rust/crates/glium-0.31.0.crate) = 0ab4f09b43d8ee427a700cb9ed3b20e0e858d62a509edded1a98ca5707d68e19
-SIZE (rust/crates/glium-0.31.0.crate) = 915561
+SHA256 (rust/crates/glium-0.32.1.crate) = d2766728ecb86014b91d3d687614b32d65aacbbdc887f424a7b03cba3ab593bf
+SIZE (rust/crates/glium-0.32.1.crate) = 925217
SHA256 (rust/crates/glob-0.3.1.crate) = d2fabcfbdc87f4758337ca535fb41a6d701b65693ce38287d856d1674551ec9b
SIZE (rust/crates/glob-0.3.1.crate) = 18880
SHA256 (rust/crates/globset-0.4.14.crate) = 57da3b9b5b85bd66f31093f8c408b90a74431672542466497dcbdfdc02034be1
diff --git a/x11/wezterm/files/patch-Cargo.lock b/x11/wezterm/files/patch-Cargo.lock
new file mode 100644
index 000000000000..b963d079a765
--- /dev/null
+++ b/x11/wezterm/files/patch-Cargo.lock
@@ -0,0 +1,14 @@
+--- Cargo.lock.orig 2024-02-03 18:08:09 UTC
++++ Cargo.lock
+@@ -2165,9 +2165,9 @@ name = "glium"
+
+ [[package]]
+ name = "glium"
+-version = "0.31.0"
++version = "0.32.1"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+-checksum = "0ab4f09b43d8ee427a700cb9ed3b20e0e858d62a509edded1a98ca5707d68e19"
++checksum = "d2766728ecb86014b91d3d687614b32d65aacbbdc887f424a7b03cba3ab593bf"
+ dependencies = [
+ "backtrace",
+ "fnv",
diff --git a/x11/wezterm/files/patch-cargo-crates_time-0.3.31_src_format__description_parse_mod.rs b/x11/wezterm/files/patch-cargo-crates_time-0.3.31_src_format__description_parse_mod.rs
new file mode 100644
index 000000000000..9c7ef275849a
--- /dev/null
+++ b/x11/wezterm/files/patch-cargo-crates_time-0.3.31_src_format__description_parse_mod.rs
@@ -0,0 +1,19 @@
+From 5b0c627366babea1636b35db641c0fec964ddbd1 Mon Sep 17 00:00:00 2001
+From: David Tolnay <dtolnay@gmail.com>
+Date: Fri, 15 Mar 2024 20:47:22 -0700
+Subject: [PATCH] Delete identity conversion in format_description::parse_owned
+ (#671)
+
+--- cargo-crates/time-0.3.31/src/format_description/parse/mod.rs.orig 2006-07-24 01:21:28 UTC
++++ cargo-crates/time-0.3.31/src/format_description/parse/mod.rs
+@@ -80,9 +80,7 @@ pub fn parse_owned<const VERSION: usize>(
+ let mut lexed = lexer::lex::<VERSION>(s.as_bytes());
+ let ast = ast::parse::<_, VERSION>(&mut lexed);
+ let format_items = format_item::parse(ast);
+- let items = format_items
+- .map(|res| res.map(Into::into))
+- .collect::<Result<Box<_>, _>>()?;
++ let items = format_items.collect::<Result<Box<_>, _>>()?;
+ Ok(items.into())
+ }
+
diff --git a/x11/wezterm/files/patch-window_Cargo.toml b/x11/wezterm/files/patch-window_Cargo.toml
new file mode 100644
index 000000000000..0835cdaa989a
--- /dev/null
+++ b/x11/wezterm/files/patch-window_Cargo.toml
@@ -0,0 +1,11 @@
+--- window/Cargo.toml.orig 2024-02-03 18:08:09 UTC
++++ window/Cargo.toml
+@@ -40,7 +40,7 @@ tiny-skia = "0.11"
+ resize = "0.5"
+ serde = {version="1.0", features = ["rc", "derive"]}
+ tiny-skia = "0.11"
+-glium = { version = "0.31", default-features = false }
++glium = { version = "0.32", default-features = false }
+ url = "2"
+ wezterm-bidi = { path = "../bidi" }
+ wezterm-color-types = { path = "../color-types" }
diff --git a/x11/wezterm/pkg-descr b/x11/wezterm/pkg-descr
index 3e0e189aa716..67126972a76a 100644
--- a/x11/wezterm/pkg-descr
+++ b/x11/wezterm/pkg-descr
@@ -12,12 +12,9 @@ multiplexer written by @wez and implemented in Rust.
Shift-Insert (bracketed paste is supported!)
- SGR style mouse reporting (works in vim and tmux)
- Render underline, double-underline, italic, bold, strikethrough
- (most other terminal emulators do not support as many render
- attributes)
- Configuration via a file with hot reloading
- Multiple Windows (Hotkey: Super-N)
-- Splits/Panes
-- Tabs (Hotkey: Super-T, next/prev: Super-Shift-[ and Super-Shift-], go-to: Super-[1-9])
+- Splits/Panes and Tabs
- SSH client with native tabs
- Connect to serial ports for embedded/Arduino work
- Connect to a local multiplexer server over unix domain sockets