aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2017-11-24 19:02:50 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2017-11-24 19:02:50 +0000
commitabdbad66be33e2b41894fc92b69a0d892fca1c7c (patch)
tree8bd88ad1fcecbd0d26206b4128ae14d906e211e9
parent742ed9faab3a201a077c7afe0a1604614a869513 (diff)
downloadports-abdbad66be33e2b4.tar.gz
ports-abdbad66be33e2b4.zip
New port: devel/blitz: Blitz++ Multi-Dimensional Array Library for C++
Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D13222
Notes
Notes: svn path=/head/; revision=454833
-rw-r--r--devel/Makefile1
-rw-r--r--devel/blitz/Makefile42
-rw-r--r--devel/blitz/distinfo3
-rw-r--r--devel/blitz/files/patch-blitz_generate_Makefile.in11
-rw-r--r--devel/blitz/pkg-descr4
-rw-r--r--devel/blitz/pkg-plist123
6 files changed, 184 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 24ae4ff9ec93..f4670102cf81 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -201,6 +201,7 @@
SUBDIR += bison
SUBDIR += bisoncpp
SUBDIR += blame
+ SUBDIR += blitz
SUBDIR += bmake
SUBDIR += bmkdep
SUBDIR += bnf
diff --git a/devel/blitz/Makefile b/devel/blitz/Makefile
new file mode 100644
index 000000000000..73e9a8fd62fc
--- /dev/null
+++ b/devel/blitz/Makefile
@@ -0,0 +1,42 @@
+# $FreeBSD$
+
+PORTNAME= blitz
+DISTVERSION= 1.0.1
+CATEGORIES= devel science
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Blitz++ Multi-Dimensional Array Library for C++
+
+LICENSE= ART20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= gmake libtool localbase python:build
+USE_GITHUB= yes
+GH_ACCOUNT= blitzpp
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+TEST_TARGET= check-testsuite
+INSTALL_TARGET= install-strip
+
+CONFIGURE_ARGS= --enable-shared
+MAKE_ARGS= CXXFLAGS="${CXXFLAGS}" FREEBSD_PYTHON_CMD=${PYTHON_CMD}
+
+OPTIONS_DEFINE= APAD FORTRAN SERIALIZATION TBB THREADSAFE
+APAD_DESC= Pad all lowest-rank lengths to nearest larger SIMD width
+SERIALIZATION_DESC= Enable serialization support using Boost::Serialization
+TBB_DESC= Use Intel Threading Building Blocks atomic types
+THREADSAFE_DESC= Enable thread-safety features
+
+APAD_CONFIGURE_ENABLE= array-length-padding
+FORTRAN_CONFIGURE_ENABLE= fortran
+FORTRAN_USES= fortran
+SERIALIZATION_CONFIGURE_ENABLE= serialization
+SERIALIZATION_BUILD_DEPENDS= ${LOCALBASE}/include/boost/mpi.hpp:devel/boost-libs
+TBB_CONFIGURE_ON= --with-tbb # TBB_CONFIGURE_WITH=tbb doesn't work: https://github.com/blitzpp/blitz/issues/20
+TBB_BUILD_DEPENDS= ${LOCALBASE}/include/tbb/atomic.h:devel/tbb
+THREADSAFE_CONFIGURE_ENABLE= threadsafe
+
+post-install:
+ @${RM} -r ${STAGEDIR}${DOCSDIR}* # https://github.com/blitzpp/blitz/issues/21
+
+.include <bsd.port.mk>
diff --git a/devel/blitz/distinfo b/devel/blitz/distinfo
new file mode 100644
index 000000000000..f11b73c07a1e
--- /dev/null
+++ b/devel/blitz/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1511509658
+SHA256 (blitzpp-blitz-1.0.1_GH0.tar.gz) = b62fc3f07b64b264307b01fec5e4f2793e09a68dcb5378984aedbc2e4b3adcef
+SIZE (blitzpp-blitz-1.0.1_GH0.tar.gz) = 4645082
diff --git a/devel/blitz/files/patch-blitz_generate_Makefile.in b/devel/blitz/files/patch-blitz_generate_Makefile.in
new file mode 100644
index 000000000000..9b2a9e7674a8
--- /dev/null
+++ b/devel/blitz/files/patch-blitz_generate_Makefile.in
@@ -0,0 +1,11 @@
+--- blitz/generate/Makefile.in.orig 2017-10-02 16:04:43 UTC
++++ blitz/generate/Makefile.in
+@@ -619,7 +619,7 @@ uninstall-am:
+
+
+ $(top_srcdir)/blitz/array/stencil-classes.cc: genstencils.py
+- python $< $@
++ $(FREEBSD_PYTHON_CMD) $< $@
+
+ generate-headers: $(top_srcdir)/blitz/array/stencil-classes.cc
+
diff --git a/devel/blitz/pkg-descr b/devel/blitz/pkg-descr
new file mode 100644
index 000000000000..e9ecfdfe31f5
--- /dev/null
+++ b/devel/blitz/pkg-descr
@@ -0,0 +1,4 @@
+Blitz++ is a C++ template class library that provides array objects for
+scientific computing. It is not a linear algebra or fft library.
+
+WWW: https://github.com/blitzpp/blitz
diff --git a/devel/blitz/pkg-plist b/devel/blitz/pkg-plist
new file mode 100644
index 000000000000..324a03cb8618
--- /dev/null
+++ b/devel/blitz/pkg-plist
@@ -0,0 +1,123 @@
+include/blitz/array-impl.h
+include/blitz/array.cc
+include/blitz/array.h
+include/blitz/array/asexpr.cc
+include/blitz/array/asexpr.h
+include/blitz/array/cartesian.h
+include/blitz/array/cgsolve.h
+include/blitz/array/complex.cc
+include/blitz/array/convolve.cc
+include/blitz/array/convolve.h
+include/blitz/array/cycle.cc
+include/blitz/array/domain.h
+include/blitz/array/et.h
+include/blitz/array/expr.cc
+include/blitz/array/expr.h
+include/blitz/array/fastiter.h
+include/blitz/array/funcs.h
+include/blitz/array/functorExpr.h
+include/blitz/array/geometry.h
+include/blitz/array/indirect.h
+include/blitz/array/interlace.cc
+include/blitz/array/io.cc
+include/blitz/array/iter.h
+include/blitz/array/map.h
+include/blitz/array/methods.cc
+include/blitz/array/misc.cc
+include/blitz/array/multi.h
+include/blitz/array/newet-macros.h
+include/blitz/array/newet.h
+include/blitz/array/ops.cc
+include/blitz/array/ops.h
+include/blitz/array/reduce.cc
+include/blitz/array/reduce.h
+include/blitz/array/resize.cc
+include/blitz/array/shape.h
+include/blitz/array/slice.h
+include/blitz/array/slicing.cc
+include/blitz/array/stencil-classes.cc
+include/blitz/array/stencil-et-macros.h
+include/blitz/array/stencil-et.h
+include/blitz/array/stencilops.h
+include/blitz/array/stencils.cc
+include/blitz/array/stencils.h
+include/blitz/array/storage.h
+include/blitz/array/where.h
+include/blitz/array/zip.h
+include/blitz/bench.cc
+include/blitz/bench.h
+include/blitz/benchext.cc
+include/blitz/benchext.h
+include/blitz/blitz.h
+include/blitz/bounds.h
+include/blitz/bzconfig.h
+include/blitz/bzdebug.h
+include/blitz/compiler.h
+include/blitz/constpointerstack.h
+include/blitz/et-forward.h
+include/blitz/etbase.h
+include/blitz/funcs.h
+include/blitz/globeval.cc
+include/blitz/gnu/bzconfig.h
+include/blitz/indexexpr.h
+include/blitz/indexmap-forward.h
+include/blitz/levicivita.h
+include/blitz/limits-hack.h
+include/blitz/listinit.h
+include/blitz/memblock.cc
+include/blitz/memblock.h
+include/blitz/meta/dot.h
+include/blitz/meta/matassign.h
+include/blitz/meta/matmat.h
+include/blitz/meta/matvec.h
+include/blitz/meta/metaprog.h
+include/blitz/meta/product.h
+include/blitz/meta/sum.h
+include/blitz/meta/vecassign.h
+include/blitz/minmax.h
+include/blitz/numinquire.h
+include/blitz/numtrait.h
+include/blitz/ops.h
+include/blitz/prettyprint.h
+include/blitz/promote.h
+include/blitz/range.cc
+include/blitz/range.h
+include/blitz/ranks.h
+include/blitz/reduce.h
+include/blitz/shapecheck.h
+include/blitz/simdtypes.h
+include/blitz/tau.h
+include/blitz/timer.h
+include/blitz/tinymat2.cc
+include/blitz/tinymat2.h
+include/blitz/tinymat2io.cc
+include/blitz/tinyvec2.cc
+include/blitz/tinyvec2.h
+include/blitz/tinyvec2io.cc
+include/blitz/tm2fastiter.h
+include/blitz/tmevaluate.h
+include/blitz/traversal.cc
+include/blitz/traversal.h
+include/blitz/tuning.h
+include/blitz/tv2fastiter.h
+include/blitz/tvcross.h
+include/blitz/tvecglobs.h
+include/blitz/tvevaluate.h
+include/blitz/update.h
+include/blitz/wrap-climits.h
+include/random/F.h
+include/random/beta.h
+include/random/chisquare.h
+include/random/default.h
+include/random/discrete-uniform.h
+include/random/exponential.h
+include/random/gamma.h
+include/random/mt.h
+include/random/mtparam.cc
+include/random/normal.h
+include/random/uniform.h
+lib/libblitz.a
+lib/libblitz.so
+lib/libblitz.so.0
+lib/libblitz.so.0.0.0
+libdata/pkgconfig/blitz.pc