aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2022-04-18 01:15:03 +0000
committerWen Heping <wen@FreeBSD.org>2022-04-18 01:15:03 +0000
commitac3547c9990f7890d0f52f9a75b8439cf6390f23 (patch)
treedc689e8266545c49130a8a0aa1b2f76db54e3c64
parent814181787db02f27e0e5ce31750b9774226a4cb3 (diff)
downloadports-ac3547c9990f7890d0f52f9a75b8439cf6390f23.tar.gz
ports-ac3547c9990f7890d0f52f9a75b8439cf6390f23.zip
www/moodle40: Add new port
Repocopied from www/moodle311 Moodle is a course management system (CMS) - a free, Open Source software package designed using sound pedagogical principles, to help educators create effective online learning communities. You can use it on any computer you have handy (including webhosts), yet it can scale from a single-teacher site to a 40,000-student University.
-rw-r--r--www/Makefile1
-rw-r--r--www/moodle40/Makefile62
-rw-r--r--www/moodle40/distinfo3
-rw-r--r--www/moodle40/files/pkg-message.in59
-rw-r--r--www/moodle40/pkg-descr7
5 files changed, 132 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 14ed26efe9cf..36c0962004e5 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -422,6 +422,7 @@
SUBDIR += moodle310
SUBDIR += moodle311
SUBDIR += moodle39
+ SUBDIR += moodle40
SUBDIR += morty
SUBDIR += mozplugger
SUBDIR += multisort
diff --git a/www/moodle40/Makefile b/www/moodle40/Makefile
new file mode 100644
index 000000000000..9d7961bc27c4
--- /dev/null
+++ b/www/moodle40/Makefile
@@ -0,0 +1,62 @@
+# Created by: Javier Martin Rueda <jmrueda@diatel.upm.es>
+
+PORTNAME= moodle
+PORTVERSION= 4.0
+CATEGORIES= www education
+MASTER_SITES= SF/moodle/Moodle/stable400/
+PKGNAMESUFFIX= ${PKGORIGIN:T:S/moodle//}${PHP_PKGNAMESUFFIX}
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Course management system based on social constructionism
+
+LICENSE= GPLv3
+
+CONFLICTS= moodle39-3.9.[0-9]* moodle310-3.10.[0-9]* moodle311-3.11.[0-9]*
+
+USES= cpe php:flavors tar:tgz
+USE_PHP= ctype curl dom fileinfo filter gd hash iconv intl json mbstring \
+ opcache openssl pcre session simplexml soap sodium spl tokenizer \
+ xml xmlreader xmlrpc zip zlib
+IGNORE_WITH_PHP= 81
+
+WRKSRC= ${WRKDIR}/moodle
+
+OPTIONS_SINGLE= BACKEND
+OPTIONS_SINGLE_BACKEND= MYSQL PGSQL MSSQL
+OPTIONS_DEFINE= LDAP
+OPTIONS_DEFAULT= MYSQL
+
+MYSQL_USES= mysql
+MYSQL_USE= php=mysqli
+PGSQL_USE= php=pgsql
+MSSQL_USE= php=mssql
+LDAP_USE= php=ldap
+
+NO_BUILD= yes
+PLIST= ${WRKDIR}/plist
+SUB_FILES= pkg-message
+SUB_LIST= MOODLEDIR=${MOODLEDIR} \
+ MOODLEDATADIR=${MOODLEDATADIR}
+
+MOODLEDIR?= www/moodle
+MOODLEDATADIR?= moodledata
+
+pre-install:
+ @${ECHO_CMD} "@owner ${WWWOWN}" >> ${PLIST}
+ @${ECHO_CMD} "@group ${WWWGRP}" >> ${PLIST}
+ @${ECHO_CMD} "@mode 755" >> ${PLIST}
+ @${ECHO} @dir ${MOODLEDATADIR} >> ${PLIST}
+ @${ECHO_CMD} "@mode" >> ${PLIST}
+ @${ECHO_CMD} "@group" >> ${PLIST}
+ @${ECHO_CMD} "@owner" >> ${PLIST}
+
+# Here for safety I do not set moodle diretory 0755 permission
+# It require user write config.php manually then.
+ @${FIND} -s -d ${WRKSRC} -type f | ${SED} "s?${WRKSRC}?${MOODLEDIR}?g" >>${PLIST}
+ @${FIND} -s -d ${WRKSRC} -type d | ${SED} "s?${WRKSRC}?@dir ${MOODLEDIR}?g" >> ${PLIST}
+
+do-install:
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/${MOODLEDIR}
+ @${INSTALL} -d ${STAGEDIR}${PREFIX}/${MOODLEDATADIR}
+
+.include <bsd.port.mk>
diff --git a/www/moodle40/distinfo b/www/moodle40/distinfo
new file mode 100644
index 000000000000..32b3e6865234
--- /dev/null
+++ b/www/moodle40/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1650242057
+SHA256 (moodle-4.0.tgz) = 89db03d19c33a31b95c45861a45cbcc563482f880eec6a279c19a549e461a1e3
+SIZE (moodle-4.0.tgz) = 61778671
diff --git a/www/moodle40/files/pkg-message.in b/www/moodle40/files/pkg-message.in
new file mode 100644
index 000000000000..149d236084ec
--- /dev/null
+++ b/www/moodle40/files/pkg-message.in
@@ -0,0 +1,59 @@
+[
+{ type: install
+ message: <<EOM
+1) Create a user and a database for Moodle to store all
+ its tables in (or choose an existing database).
+ It doesn't matter what the database or user names are,
+ as this will be configured in a later step.
+ NOTE: this package assumes that either the phpX-pgsql,
+ phpX-mysql, or phpX-mssql packages are installed.
+
+2) Add the following to your Apache configuration file
+ httpd.conf, and restart the server:
+
+ Alias /moodle %%PREFIX%%/%%MOODLEDIR%%/
+ AcceptPathInfo On
+ <Directory %%PREFIX%%/%%MOODLEDIR%%/>
+ AllowOverride None
+ Require all granted
+ </Directory>
+
+3) Visit your Moodle site with a browser (i.e.,
+ http://your.server.com/moodle/), and you should
+ be taken to the install.php script, which will lead
+ you through creating a config.php file and then
+ setting up Moodle, creating an admin account, etc.
+
+ At one step, you will get a message saying that the
+ installer script was not able to automatically create
+ the config.php file. Just download it and copy it to
+ %%PREFIX%%/%%MOODLEDIR%%/config.php. Beware that it
+ will contain the database password in cleartext, so
+ set up whatever file permissions you deem more adequate.
+ For instance, user=root, group=www, mask=640.
+
+4) Set up a cron task to invoke the file admin/cron.php
+ every five minutes or so. For instance:
+ */5 * * * * fetch http://your.server.com/moodle/admin/cron.php
+
+For more information, see the INSTALL DOCUMENTATION:
+
+ http://docs.moodle.org/en/Installing_Moodle
+
+It may be worth reading the installation docs even if Moodle seems
+to be working at first, to ensure your PHP settings and database
+configuration will allow Moodle to operate properly.
+EOM
+}
+{ type: upgrade
+ message: <<EOM
+If you are upgrading from an earlier version of Moodle, check out
+possible additional steps at:
+
+ https://docs.moodle.org/40/en/Upgrading
+
+If you have real trouble, please visit the Moodle course
+"Using Moodle" on moodle.org.
+EOM
+}
+]
diff --git a/www/moodle40/pkg-descr b/www/moodle40/pkg-descr
new file mode 100644
index 000000000000..fe30e0d25bab
--- /dev/null
+++ b/www/moodle40/pkg-descr
@@ -0,0 +1,7 @@
+Moodle is a course management system (CMS) - a free, Open Source software
+package designed using sound pedagogical principles, to help educators
+create effective online learning communities. You can use it on any
+computer you have handy (including webhosts), yet it can scale from a
+single-teacher site to a 40,000-student University.
+
+WWW: http://www.moodle.org/