aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-12-30 05:49:03 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-12-30 06:16:21 +0000
commitac67a13cf74ee250ea844a9c2bba4ce79402d489 (patch)
tree1e2054e9e0e34a0b03ea53366234f788bb8f8b64
parent642aae8f5d157873bcf0d26a5b75287491154f40 (diff)
misc/py-ast-comments: New port: Extension to the built-in ast module
-rw-r--r--misc/Makefile1
-rw-r--r--misc/py-ast-comments/Makefile22
-rw-r--r--misc/py-ast-comments/distinfo3
-rw-r--r--misc/py-ast-comments/pkg-descr2
4 files changed, 28 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index af01e5ac4f58..419a4c9414fc 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -402,6 +402,7 @@
SUBDIR += py-alive-progress
SUBDIR += py-apache-beam
SUBDIR += py-ascii-magic
+ SUBDIR += py-ast-comments
SUBDIR += py-boost-histogram
SUBDIR += py-censys
SUBDIR += py-cinder
diff --git a/misc/py-ast-comments/Makefile b/misc/py-ast-comments/Makefile
new file mode 100644
index 000000000000..426bb00df096
--- /dev/null
+++ b/misc/py-ast-comments/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= ast-comments
+DISTVERSION= 1.2.1
+CATEGORIES= misc
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME:S/-/_/}-${PORTVERSION}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Extension to the built-in ast module
+WWW= https://github.com/t3rn0/ast-comments
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}poetry-core>=1.0.0:devel/py-poetry-core@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= pep517 autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/misc/py-ast-comments/distinfo b/misc/py-ast-comments/distinfo
new file mode 100644
index 000000000000..cb8137eb187c
--- /dev/null
+++ b/misc/py-ast-comments/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1703911538
+SHA256 (ast_comments-1.2.1.tar.gz) = 28f356ed2d5943e39a25ba12038d6210b01ce9363c42101216fc61561d318d3a
+SIZE (ast_comments-1.2.1.tar.gz) = 5288
diff --git a/misc/py-ast-comments/pkg-descr b/misc/py-ast-comments/pkg-descr
new file mode 100644
index 000000000000..e3ceb7a30b28
--- /dev/null
+++ b/misc/py-ast-comments/pkg-descr
@@ -0,0 +1,2 @@
+ast-comments is an extension to the built-in ast module. Finds comments in
+source code and adds them to the parsed tree.