aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2023-06-16 09:46:17 +0000
committerJason E. Hale <jhale@FreeBSD.org>2023-06-16 09:47:03 +0000
commitac8809e41cc31bba8873a017d0dd7ff88f94502d (patch)
tree5553d3a100c230040246dd03b0070f4b057a6f88
parentbc63b3f9ca8b308d1b268e8ce3c2267b45cbf337 (diff)
downloadports-ac8809e41cc31bba8873a017d0dd7ff88f94502d.tar.gz
ports-ac8809e41cc31bba8873a017d0dd7ff88f94502d.zip
archivers/libunrar6: Update to 6.2.8
Bump PORTREVISION on sysutils/fusefs-rar2fs which builds against the source.
-rw-r--r--archivers/libunrar6/Makefile2
-rw-r--r--archivers/libunrar6/distinfo6
-rw-r--r--archivers/libunrar6/files/patch-os.hpp4
-rw-r--r--archivers/libunrar6/files/patch-rijndael.cpp28
-rw-r--r--archivers/libunrar6/files/patch-rijndael.hpp4
-rw-r--r--sysutils/fusefs-rar2fs/Makefile2
6 files changed, 23 insertions, 23 deletions
diff --git a/archivers/libunrar6/Makefile b/archivers/libunrar6/Makefile
index 1253e645ca82..2e746185298c 100644
--- a/archivers/libunrar6/Makefile
+++ b/archivers/libunrar6/Makefile
@@ -1,5 +1,5 @@
PORTNAME= libunrar6
-PORTVERSION= 6.1.7
+PORTVERSION= 6.2.8
CATEGORIES= archivers
MASTER_SITES= http://www.rarlab.com/rar/
DISTNAME= unrarsrc-${PORTVERSION}
diff --git a/archivers/libunrar6/distinfo b/archivers/libunrar6/distinfo
index 1a3c449ee7ae..b35936afea0e 100644
--- a/archivers/libunrar6/distinfo
+++ b/archivers/libunrar6/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1653701807
-SHA256 (unrarsrc-6.1.7.tar.gz) = de75b6136958173fdfc530d38a0145b72342cf0d3842bf7bb120d336602d88ed
-SIZE (unrarsrc-6.1.7.tar.gz) = 236798
+TIMESTAMP = 1686905718
+SHA256 (unrarsrc-6.2.8.tar.gz) = 1777e3d3b073815ff68a411ddb1ab76d0a4e1f58ecc7080035b27b52967ff911
+SIZE (unrarsrc-6.2.8.tar.gz) = 246249
diff --git a/archivers/libunrar6/files/patch-os.hpp b/archivers/libunrar6/files/patch-os.hpp
index c0a0c1604907..ef633fb42257 100644
--- a/archivers/libunrar6/files/patch-os.hpp
+++ b/archivers/libunrar6/files/patch-os.hpp
@@ -1,6 +1,6 @@
---- os.hpp.orig 2022-01-24 07:33:18 UTC
+--- os.hpp.orig 2023-01-17 16:25:54 UTC
+++ os.hpp
-@@ -168,6 +168,10 @@
+@@ -173,6 +173,10 @@
#include <locale.h>
diff --git a/archivers/libunrar6/files/patch-rijndael.cpp b/archivers/libunrar6/files/patch-rijndael.cpp
index 19749b3b7403..92b411d99b5c 100644
--- a/archivers/libunrar6/files/patch-rijndael.cpp
+++ b/archivers/libunrar6/files/patch-rijndael.cpp
@@ -1,4 +1,4 @@
---- rijndael.cpp.orig 2022-01-24 07:33:18 UTC
+--- rijndael.cpp.orig 2023-01-17 16:25:54 UTC
+++ rijndael.cpp
@@ -3,6 +3,8 @@
**************************************************************************/
@@ -56,18 +56,18 @@
+ EVP_CIPHER_CTX_set_padding(ctx, 0);
+#endif
+#else // OPENSSL_AES
- #ifdef USE_SSE
- // Check SSE here instead of constructor, so if object is a part of some
- // structure memset'ed before use, this variable is not lost.
-@@ -139,6 +169,7 @@ void Rijndael::Init(bool Encrypt,const byte *key,uint
+ // Check SIMD here instead of constructor, so if object is a part of some
+ // structure memset'ed before use, these variables are not lost.
+ #if defined(USE_SSE)
+@@ -141,6 +171,7 @@ void Rijndael::Init(bool Encrypt,const byte *key,uint
if(!Encrypt)
keyEncToDec();
+#endif // OPENSSL_AES
}
- void Rijndael::blockEncrypt(const byte *input,size_t inputLen,byte *outBuffer)
-@@ -146,6 +177,15 @@ void Rijndael::blockEncrypt(const byte *input,size_t i
+
+@@ -149,6 +180,15 @@ void Rijndael::blockEncrypt(const byte *input,size_t i
if (inputLen <= 0)
return;
@@ -81,9 +81,9 @@
+ return;
+#else // OPENSSL_AES
size_t numBlocks = inputLen/16;
- #ifdef USE_SSE
+ #if defined(USE_SSE)
if (AES_NI)
-@@ -204,6 +244,7 @@ void Rijndael::blockEncrypt(const byte *input,size_t i
+@@ -213,6 +253,7 @@ void Rijndael::blockEncrypt(const byte *input,size_t i
input += 16;
}
Copy128(m_initVector,prevBlock);
@@ -91,7 +91,7 @@
}
-@@ -245,6 +286,15 @@ void Rijndael::blockDecrypt(const byte *input, size_t
+@@ -288,6 +329,15 @@ void Rijndael::blockDecrypt(const byte *input, size_t
if (inputLen <= 0)
return;
@@ -105,9 +105,9 @@
+ return;
+#else // OPENSSL_AES
size_t numBlocks=inputLen/16;
- #ifdef USE_SSE
+ #if defined(USE_SSE)
if (AES_NI)
-@@ -307,6 +357,8 @@ void Rijndael::blockDecrypt(const byte *input, size_t
+@@ -356,6 +406,8 @@ void Rijndael::blockDecrypt(const byte *input, size_t
}
memcpy(m_initVector,iv,16);
@@ -116,7 +116,7 @@
}
-@@ -342,7 +394,7 @@ void Rijndael::blockDecryptSSE(const byte *input, size
+@@ -426,7 +478,7 @@ void Rijndael::blockDecryptNeon(const byte *input, siz
}
#endif
@@ -125,7 +125,7 @@
//////////////////////////////////////////////////////////////////////////////////////////////////////////////////
// ALGORITHM
//////////////////////////////////////////////////////////////////////////////////////////////////////////////////
-@@ -471,7 +523,7 @@ void Rijndael::GenerateTables()
+@@ -555,7 +607,7 @@ void Rijndael::GenerateTables()
U1[b][0]=U2[b][1]=U3[b][2]=U4[b][3]=T5[I][0]=T6[I][1]=T7[I][2]=T8[I][3]=gmul(b,0xe);
}
}
diff --git a/archivers/libunrar6/files/patch-rijndael.hpp b/archivers/libunrar6/files/patch-rijndael.hpp
index 3c375833ef8e..0e1ccbfbd379 100644
--- a/archivers/libunrar6/files/patch-rijndael.hpp
+++ b/archivers/libunrar6/files/patch-rijndael.hpp
@@ -1,4 +1,4 @@
---- rijndael.hpp.orig 2022-01-24 07:33:18 UTC
+--- rijndael.hpp.orig 2023-01-17 16:25:54 UTC
+++ rijndael.hpp
@@ -12,6 +12,13 @@
class Rijndael
@@ -14,7 +14,7 @@
#ifdef USE_SSE
void blockEncryptSSE(const byte *input,size_t numBlocks,byte *outBuffer);
void blockDecryptSSE(const byte *input, size_t numBlocks, byte *outBuffer);
-@@ -21,6 +28,7 @@ class Rijndael
+@@ -31,6 +38,7 @@ class Rijndael
void keySched(byte key[_MAX_KEY_COLUMNS][4]);
void keyEncToDec();
void GenerateTables();
diff --git a/sysutils/fusefs-rar2fs/Makefile b/sysutils/fusefs-rar2fs/Makefile
index 68268024cfcd..c75f638c187a 100644
--- a/sysutils/fusefs-rar2fs/Makefile
+++ b/sysutils/fusefs-rar2fs/Makefile
@@ -1,7 +1,7 @@
PORTNAME= rar2fs
DISTVERSION= 1.29.5
DISTVERSIONPREFIX= v
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= sysutils
PKGNAMEPREFIX= fusefs-