aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-09-13 21:30:44 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-09-13 21:31:28 +0000
commitac8a659bb5e8ef13722304095d73f97e4f72fe5f (patch)
tree561bb4f1b952e914df3d1a5df5ca1d73d6f2b318
parentdc4e011ace6acd033db6ecc14ef7d074ad252b7c (diff)
math/py-keras: Fix WWW location; Fix formatting
-rw-r--r--math/py-keras/Makefile22
-rw-r--r--math/py-keras/pkg-descr2
2 files changed, 11 insertions, 13 deletions
diff --git a/math/py-keras/Makefile b/math/py-keras/Makefile
index 4cccb73aadbf..af328985024e 100644
--- a/math/py-keras/Makefile
+++ b/math/py-keras/Makefile
@@ -5,16 +5,12 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= yuri@FreeBSD.org
COMMENT= Deep learning library for Python
-
-USE_GITHUB= yes
-GH_ACCOUNT= keras-team
-GH_PROJECT= ${PORTNAME}
-GH_TAGNAME= r2.9
+WWW= https://keras.io/
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYNUMPY} \
+RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}absl-py>=1.0.0:devel/py-absl-py \
${PYTHON_PKGNAMEPREFIX}h5py>=0:science/py-h5py@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pandas>=1.3.5:math/py-pandas@${PY_FLAVOR} \
@@ -33,6 +29,11 @@ BUILD_DEPENDS= ${RUN_DEPENDS} \
USES= python:3.7+
+USE_GITHUB= yes
+GH_ACCOUNT= keras-team
+GH_PROJECT= ${PORTNAME}
+GH_TAGNAME= r2.9
+
.include "Makefile.MASTER_SITES"
post-patch:
@@ -49,7 +50,7 @@ post-patch:
@${MKDIR} ${WRKDIR}/whl
# These files are from my tensorflow port
- # if both make it into the port they can be shared
+ # if both make it into the port they can be shared
# copy the toolchain over
@${CP} -R ${PATCHDIR}/freebsd \
@@ -75,7 +76,7 @@ post-patch:
# auto generated files will sometimes ignore our py_runtime toolchain and our PYTHON_BIN_PATH
# causing it to still set the shebang line to bin/env python3. Even on the github page the solution
# has been to use a symlink to work around so do that here as a fix
- @${MKDIR} ${WRKDIR}/.bin
+ @${MKDIR} ${WRKDIR}/.bin
${LN} -s ${PYTHON_CMD} ${WRKDIR}/.bin/python3
@${REINPLACE_CMD} "s#%%PYTHON%%#${PYTHON_CMD}#" \
@@ -83,8 +84,8 @@ post-patch:
do-build:
@cd ${WRKSRC} && ${SETENV} \
- PYTHON_BIN_PATH=${PYTHON_CMD} \
- PYTHON_LIB_PATH="${PYTHON_SITELIBDIR}" \
+ PYTHON_BIN_PATH=${PYTHON_CMD} \
+ PYTHON_LIB_PATH="${PYTHON_SITELIBDIR}" \
PYTHON_BINARY=${PYTHON_CMD} \
bazel --bazelrc="${WRKSRC}/bazelrc" \
build --config=freebsd \
@@ -96,7 +97,6 @@ do-build:
@cd ${WRKSRC} && \
bazel-bin/keras/tools/pip_package/build_pip_package \
${WRKDIR}/whl
-
do-install:
@${MKDIR} ${STAGEDIR}/${PYTHON_SITELIBDIR}
diff --git a/math/py-keras/pkg-descr b/math/py-keras/pkg-descr
index 9b7820801350..405e9f8eb8fb 100644
--- a/math/py-keras/pkg-descr
+++ b/math/py-keras/pkg-descr
@@ -1,4 +1,2 @@
Deep Learning library for Python. Convnets, recurrent neural networks, and
more. Runs on Theano and TensorFlow.
-
-WWW: https://keras.io/