aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPat Maddox <pat@patmaddox.com>2024-01-14 15:43:53 +0000
committerKoichiro Iwao <meta@FreeBSD.org>2024-06-09 12:57:40 +0000
commitaca963f179baa977a9ee2fcdafa564b30959817b (patch)
tree49ca1c5169f3bf2d94778357e906ed3fcbfdc383
parentff8d5c3cefbb3da52f05f93409bc1091189ede48 (diff)
devel/go-mode.el: new port
This is go-mode, the Emacs mode for editing Go code. It is a complete rewrite of the go-mode that shipped with Go 1.0.3 and before, and was part of Go 1.1 until Go 1.3. Beginning with Go 1.4, editor integration will not be part of the Go distribution anymore, making this repository the canonical place for go-mode. PR: 276329
-rw-r--r--devel/Makefile1
-rw-r--r--devel/go-mode.el/Makefile32
-rw-r--r--devel/go-mode.el/distinfo3
-rw-r--r--devel/go-mode.el/pkg-descr6
-rw-r--r--devel/go-mode.el/pkg-plist4
5 files changed, 46 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4db18f9b2393..8037ae7e3440 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -874,6 +874,7 @@
SUBDIR += go-bindata
SUBDIR += go-bindata-assetfs
SUBDIR += go-git
+ SUBDIR += go-mode.el
SUBDIR += go-perf
SUBDIR += go-protobuf
SUBDIR += go-tools
diff --git a/devel/go-mode.el/Makefile b/devel/go-mode.el/Makefile
new file mode 100644
index 000000000000..2df4b5d4a864
--- /dev/null
+++ b/devel/go-mode.el/Makefile
@@ -0,0 +1,32 @@
+PORTNAME= go-mode.el
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.6.0
+CATEGORIES= devel
+
+MAINTAINER= pat@patmaddox.com
+COMMENT= Emacs mode for the Go programming language
+WWW= https://github.com/dominikh/go-mode.el
+
+LICENSE= BSD3CLAUSE
+
+USES= emacs
+EMACS_NO_DEPENDS= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= dominikh
+GH_PROJECT= go-mode.el
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+OPTIONS_DEFINE= DOCS
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${EMACS_SITE_LISPDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.el ${STAGEDIR}${PREFIX}/${EMACS_SITE_LISPDIR}
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/devel/go-mode.el/distinfo b/devel/go-mode.el/distinfo
new file mode 100644
index 000000000000..2e3246055d23
--- /dev/null
+++ b/devel/go-mode.el/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1705246850
+SHA256 (dominikh-go-mode.el-v1.6.0_GH0.tar.gz) = d480f332bb0e286e41d1592bbce29a70637487788d1ae4ad36f6e7c75eb667d4
+SIZE (dominikh-go-mode.el-v1.6.0_GH0.tar.gz) = 51329
diff --git a/devel/go-mode.el/pkg-descr b/devel/go-mode.el/pkg-descr
new file mode 100644
index 000000000000..d1c9c86e8be3
--- /dev/null
+++ b/devel/go-mode.el/pkg-descr
@@ -0,0 +1,6 @@
+This is go-mode, the Emacs mode for editing Go code.
+
+It is a complete rewrite of the go-mode that shipped with Go 1.0.3 and
+before, and was part of Go 1.1 until Go 1.3. Beginning with Go 1.4,
+editor integration will not be part of the Go distribution anymore,
+making this repository the canonical place for go-mode.
diff --git a/devel/go-mode.el/pkg-plist b/devel/go-mode.el/pkg-plist
new file mode 100644
index 000000000000..0516aebefb8b
--- /dev/null
+++ b/devel/go-mode.el/pkg-plist
@@ -0,0 +1,4 @@
+%%PORTDOCS%%%%DOCSDIR%%/README.md
+%%EMACS_SITE_LISPDIR%%/go-guru.el
+%%EMACS_SITE_LISPDIR%%/go-mode.el
+%%EMACS_SITE_LISPDIR%%/go-rename.el