aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2022-11-22 16:38:31 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2022-11-22 16:39:22 +0000
commitacb3a0de6468b1fe930e53af1894505e9b8d64c7 (patch)
tree87844081bc183607d091b17a191921e8eafb2be1
parentaf39b50f6bf7c60f51fa2dcabcd628b7c68d299a (diff)
downloadports-acb3a0de6468b1fe930e53af1894505e9b8d64c7.tar.gz
ports-acb3a0de6468b1fe930e53af1894505e9b8d64c7.zip
biology/megahit: Ultra-fast single-node metagenomics assembly
MEGAHIT is a single node assembler for large and complex metagenomics NGS reads, such as soil. It makes use of succinct de Bruijn graph (SdBG) to achieve low memory assembly. MEGAHIT can optionally utilize a CUDA-enabled GPU to accelerate its SdBG contstruction.
-rw-r--r--biology/Makefile1
-rw-r--r--biology/megahit/Makefile23
-rw-r--r--biology/megahit/distinfo3
-rw-r--r--biology/megahit/pkg-descr4
-rw-r--r--biology/megahit/pkg-plist14
5 files changed, 45 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index 25ed50f54925..2ba55e0738ae 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -90,6 +90,7 @@
SUBDIR += linux-foldingathome
SUBDIR += mafft
SUBDIR += mapm3
+ SUBDIR += megahit
SUBDIR += migrate
SUBDIR += minimap2
SUBDIR += mmseqs2
diff --git a/biology/megahit/Makefile b/biology/megahit/Makefile
new file mode 100644
index 000000000000..30080e9d2564
--- /dev/null
+++ b/biology/megahit/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= megahit
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.2.9
+CATEGORIES= biology
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= Ultra-fast single-node large and complex metagenomics assembly
+WWW= https://github.com/voutcn/megahit
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+ONLY_FOR_ARCHS= amd64 powerpc64 powerpc64le riscv64
+ONLY_FOR_ARCHS_REASON= "Uses specific 64-bit CPU features"
+
+USES= cmake python shebangfix
+SHEBANG_FILES= src/megahit
+USE_GITHUB= yes
+GH_ACCOUNT= voutcn
+
+CFLAGS+= -pthread
+
+.include <bsd.port.mk>
diff --git a/biology/megahit/distinfo b/biology/megahit/distinfo
new file mode 100644
index 000000000000..a70a74294d7a
--- /dev/null
+++ b/biology/megahit/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1669058254
+SHA256 (voutcn-megahit-v1.2.9_GH0.tar.gz) = 09026eb07cc4e2d24f58b0a13f7a826ae8bb73da735a47cb1cbe6e4693118852
+SIZE (voutcn-megahit-v1.2.9_GH0.tar.gz) = 268591
diff --git a/biology/megahit/pkg-descr b/biology/megahit/pkg-descr
new file mode 100644
index 000000000000..8bf2914062fd
--- /dev/null
+++ b/biology/megahit/pkg-descr
@@ -0,0 +1,4 @@
+MEGAHIT is a single node assembler for large and complex metagenomics NGS
+reads, such as soil. It makes use of succinct de Bruijn graph (SdBG) to achieve
+low memory assembly. MEGAHIT can optionally utilize a CUDA-enabled GPU to
+accelerate its SdBG contstruction.
diff --git a/biology/megahit/pkg-plist b/biology/megahit/pkg-plist
new file mode 100644
index 000000000000..cda27e5d670d
--- /dev/null
+++ b/biology/megahit/pkg-plist
@@ -0,0 +1,14 @@
+bin/megahit
+bin/megahit_core
+bin/megahit_core_no_hw_accel
+bin/megahit_core_popcnt
+bin/megahit_toolkit
+%%DATADIR%%/test_data/empty.fa
+%%DATADIR%%/test_data/generate_random_fasta.py
+%%DATADIR%%/test_data/loop.fa
+%%DATADIR%%/test_data/r1.il.fa.gz
+%%DATADIR%%/test_data/r2.il.fa.bz2
+%%DATADIR%%/test_data/r3_1.fa
+%%DATADIR%%/test_data/r3_2.fa
+%%DATADIR%%/test_data/r4.fa
+%%DATADIR%%/test_data/ref.fa