aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2023-09-19 17:41:39 +0000
committerBernard Spil <brnrd@FreeBSD.org>2023-09-19 17:41:39 +0000
commitad77fc1557451dece53364b196017ad2af1b9de0 (patch)
tree7fe696cc0d14c88b802cd6d74ca8c737a4ff049d
parent405edc14353141200a7c215da713ffa86e1795bc (diff)
downloadports-ad77fc1557451dece53364b196017ad2af1b9de0.tar.gz
ports-ad77fc1557451dece53364b196017ad2af1b9de0.zip
security/openssl30: Enable RFC3779 by default
* As in base OpenSSL Reported by: Juraj Lutter
-rw-r--r--security/openssl30/Makefile3
-rw-r--r--security/openssl31/Makefile3
2 files changed, 4 insertions, 2 deletions
diff --git a/security/openssl30/Makefile b/security/openssl30/Makefile
index 992777e7b1b2..6a9300d60d5d 100644
--- a/security/openssl30/Makefile
+++ b/security/openssl30/Makefile
@@ -1,5 +1,6 @@
PORTNAME= openssl
PORTVERSION= 3.0.11
+PORTREVISION= 1
CATEGORIES= security devel
MASTER_SITES= https://www.openssl.org/source/ \
ftp://ftp.cert.dfn.de/pub/tools/net/openssl/source/
@@ -40,7 +41,7 @@ OPTIONS_GROUP_PROTOCOLS=NEXTPROTONEG SCTP SSL3 TLS1 TLS1_1 TLS1_2
OPTIONS_DEFINE= ASYNC CRYPTODEV CT KTLS MAN3 RFC3779 SHARED ZLIB
OPTIONS_DEFAULT=ASM ASYNC CT DES EC FIPS GOST KTLS MAN3 MD4 NEXTPROTONEG \
- RC2 RC4 RMD160 SCTP SHARED SSE2 THREADS TLS1 TLS1_1 TLS1_2
+ RFC3779 RC2 RC4 RMD160 SCTP SHARED SSE2 THREADS TLS1 TLS1_1 TLS1_2
OPTIONS_EXCLUDE=${${OSVERSION} < 1300042:?KTLS:} \
${${OSVERSION} > 1300000:?CRYPTODEV:}
diff --git a/security/openssl31/Makefile b/security/openssl31/Makefile
index f540e95f8d30..bea63e395a88 100644
--- a/security/openssl31/Makefile
+++ b/security/openssl31/Makefile
@@ -1,5 +1,6 @@
PORTNAME= openssl
PORTVERSION= 3.1.3
+PORTREVISION= 1
CATEGORIES= security devel
MASTER_SITES= https://www.openssl.org/source/ \
ftp://ftp.cert.dfn.de/pub/tools/net/openssl/source/
@@ -40,7 +41,7 @@ OPTIONS_GROUP_PROTOCOLS=NEXTPROTONEG SCTP SSL3 TLS1 TLS1_1 TLS1_2
OPTIONS_DEFINE= ASYNC CRYPTODEV CT KTLS MAN3 RFC3779 SHARED ZLIB
OPTIONS_DEFAULT=ASM ASYNC CT DES EC FIPS GOST KTLS MAN3 MD4 NEXTPROTONEG \
- RC2 RC4 RMD160 SCTP SHARED SSE2 THREADS TLS1 TLS1_1 TLS1_2
+ RFC3779 RC2 RC4 RMD160 SCTP SHARED SSE2 THREADS TLS1 TLS1_1 TLS1_2
OPTIONS_EXCLUDE=${${OSVERSION} < 1300042:?KTLS:} \
${${OSVERSION} > 1300000:?CRYPTODEV:}