aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2022-03-03 09:05:08 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2022-03-03 09:05:08 +0000
commitae0a77505bfbad636374341fc235cb3e45c24f62 (patch)
treef8cf22cc13049e7237f7bc23f26d851eb1b9d602
parent546f158ae941a59b07bc11b5aec2bd42983b8bbe (diff)
downloadports-ae0a77505bfbad636374341fc235cb3e45c24f62.tar.gz
ports-ae0a77505bfbad636374341fc235cb3e45c24f62.zip
graphics/telak: Update to 0.7
- Update WWW - Update URL to sample config
-rw-r--r--graphics/telak/Makefile11
-rw-r--r--graphics/telak/distinfo5
-rw-r--r--graphics/telak/files/install-user2
-rw-r--r--graphics/telak/files/patch-Makefile8
-rw-r--r--graphics/telak/files/patch-toon.c11
-rw-r--r--graphics/telak/files/patch-toon.h10
-rw-r--r--graphics/telak/pkg-descr2
7 files changed, 15 insertions, 34 deletions
diff --git a/graphics/telak/Makefile b/graphics/telak/Makefile
index 0d863c1e9488..a73ba9bb7d80 100644
--- a/graphics/telak/Makefile
+++ b/graphics/telak/Makefile
@@ -1,11 +1,9 @@
# Created by: Emanuel Haupt <ehaupt@critical.ch>
PORTNAME= telak
-PORTVERSION= 0.6
-PORTREVISION= 8
+PORTVERSION= 0.7
+DISTVERSIONPREFIX= v
CATEGORIES= graphics
-MASTER_SITES= http://julien.danjou.info/telak/ \
- LOCAL/ehaupt
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Tool to draw pictures on your root window
@@ -17,11 +15,14 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libImlib2.so:graphics/imlib2
USES= gmake xorg
+USE_GITHUB= yes
+GH_ACCOUNT= jd
USE_XORG= x11
ALL_TARGET= ${PORTNAME}
-PLIST_FILES= bin/telak man/man1/telak.1.gz
+PLIST_FILES= bin/telak \
+ man/man1/telak.1.gz
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
diff --git a/graphics/telak/distinfo b/graphics/telak/distinfo
index 7035276436b9..f87432110950 100644
--- a/graphics/telak/distinfo
+++ b/graphics/telak/distinfo
@@ -1,2 +1,3 @@
-SHA256 (telak-0.6.tar.gz) = 6737e15307b580ce61e3b4293c7a68ff46998f1e44051c83920f072c365ec22e
-SIZE (telak-0.6.tar.gz) = 18425
+TIMESTAMP = 1646293024
+SHA256 (jd-telak-v0.7_GH0.tar.gz) = 864c0de98434138058471b91f3ab3a40dca859cb2878b731a11befbab9929ee0
+SIZE (jd-telak-v0.7_GH0.tar.gz) = 144237
diff --git a/graphics/telak/files/install-user b/graphics/telak/files/install-user
index 8110b67ab02d..4730b99a861b 100644
--- a/graphics/telak/files/install-user
+++ b/graphics/telak/files/install-user
@@ -8,7 +8,7 @@ cat << "EOF" > $HOME/.telak/telakrc
# telakrc - see telak(1) for more config options
[example]
-url = http://www.critical.ch/telak/d-mon.gif
+url = https://critical.ch/telak/d-mon.png
x = 15
y = 15
diff --git a/graphics/telak/files/patch-Makefile b/graphics/telak/files/patch-Makefile
index e1091860e173..8dc33de4ba06 100644
--- a/graphics/telak/files/patch-Makefile
+++ b/graphics/telak/files/patch-Makefile
@@ -1,13 +1,13 @@
---- Makefile.orig 2008-03-20 15:05:59 UTC
+--- Makefile.orig 2021-11-19 07:48:49 UTC
+++ Makefile
@@ -1,8 +1,8 @@
VERSION = $(shell grep '^Version' ChangeLog | head -n 1 | cut -d' ' -f2 | tr -d ' ')
BIN = telak
O = telak.o fetch.o image.o parse.o toon.o
--LDFLAGS = $(shell imlib2-config --libs) $(shell curl-config --libs) -lgcrypt
+-LDFLAGS = $(shell imlib2-config --libs) $(shell curl-config --libs) -lgcrypt -lX11
-CFLAGS = -pg -W -Wall $(shell curl-config --cflags) $(shell imlib2-config --cflags) -DTELAK_USER_AGENT="\"$(BIN) $(VERSION)\"" -DTELAK_VERSION="\"$(VERSION)\"" -g
-+LDFLAGS = $(shell imlib2-config --libs) $(shell curl-config --libs) -lgcrypt -lX11
-+CFLAGS += $(shell curl-config --cflags) $(shell imlib2-config --cflags) -DTELAK_USER_AGENT="\"$(BIN) $(VERSION)\"" -DTELAK_VERSION="\"$(VERSION)\""
++LDFLAGS += $(shell imlib2-config --libs) $(shell curl-config --libs) -lgcrypt -lX11
++CFLAGS += -pg -W -Wall $(shell curl-config --cflags) $(shell imlib2-config --cflags) -DTELAK_USER_AGENT="\"$(BIN) $(VERSION)\"" -DTELAK_VERSION="\"$(VERSION)\""
BINDIR=$(DESTDIR)/usr/bin
MANDIR=$(DESTDIR)/usr/share/man/man1
diff --git a/graphics/telak/files/patch-toon.c b/graphics/telak/files/patch-toon.c
deleted file mode 100644
index 98f3ceba2f03..000000000000
--- a/graphics/telak/files/patch-toon.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- toon.c.orig 2008-02-25 16:41:19 UTC
-+++ toon.c
-@@ -95,6 +95,8 @@
- #include <stdio.h>
- #include <string.h>
-
-+char toon_message[TOON_MESSAGE_LENGTH];
-+
- /* Time to throw up. Here is a kludgey function that recursively calls
- * itself (up to a limit) to find the window ID of the KDE desktop to
- * draw on. It works with KDE 2.0, but since KDE 2.0 is less stable
diff --git a/graphics/telak/files/patch-toon.h b/graphics/telak/files/patch-toon.h
deleted file mode 100644
index e1e9e07b38d5..000000000000
--- a/graphics/telak/files/patch-toon.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- toon.h.orig 2008-02-25 16:41:19 UTC
-+++ toon.h
-@@ -1,6 +1,6 @@
- #include <X11/Xlib.h>
-
- #define TOON_MESSAGE_LENGTH 128
--char toon_message[TOON_MESSAGE_LENGTH];
-+/* char toon_message[TOON_MESSAGE_LENGTH]; */
-
- Window ToonGetRootWindow(Display *display, int screen, Window *clientparent);
diff --git a/graphics/telak/pkg-descr b/graphics/telak/pkg-descr
index 2615a21edf90..f55a112760a3 100644
--- a/graphics/telak/pkg-descr
+++ b/graphics/telak/pkg-descr
@@ -1,4 +1,4 @@
Telak is a small tool to draw local or remote pictures on your root window.
This is very useful if you want to have RRD graphs drawn above your wallpaper.
-WWW: http://julien.danjou.info/projects/telak
+WWW: https://github.com/jd/telak