aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2022-02-10 11:43:19 +0000
committerKai Knoblich <kai@FreeBSD.org>2022-02-10 11:43:19 +0000
commitae3632f35c7f23f191e252a5836356c15f505fd1 (patch)
treed51eef785e9819ff5717535243fc2258f53a84e4
parent2a67ec4b5093fba26243fa056851172540582d39 (diff)
downloadports-ae3632f35c7f23f191e252a5836356c15f505fd1.tar.gz
ports-ae3632f35c7f23f191e252a5836356c15f505fd1.zip
www/py-django-filer: Update to 2.1.2
Changelog: https://github.com/django-cms/django-filer/compare/1.7.0...2.1.2 PR: 261478 Approved by: maintainer timeout (2+ weeks)
-rw-r--r--www/py-django-filer/Makefile17
-rw-r--r--www/py-django-filer/distinfo6
-rw-r--r--www/py-django-filer/files/patch-setup.py23
3 files changed, 34 insertions, 12 deletions
diff --git a/www/py-django-filer/Makefile b/www/py-django-filer/Makefile
index b5ea0e7b9c1c..f6bc53ddb2f2 100644
--- a/www/py-django-filer/Makefile
+++ b/www/py-django-filer/Makefile
@@ -1,7 +1,7 @@
# Created by: Matthew X. Economou <xenophon+fbsdports@irtnog.org>
PORTNAME= django-filer
-PORTVERSION= 1.7.0
+PORTVERSION= 2.1.2
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -10,17 +10,16 @@ MAINTAINER= xenophon+fbsdports@irtnog.org
COMMENT= File and Image Management Application for django
LICENSE= BSD2CLAUSE
-LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django22>=1.11<4.0:www/py-django22@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}django-easy-thumbnails>=2<3.0:graphics/py-django-easy-thumbnails@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django22>=2.2<4.0:www/py-django22@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}django-easy-thumbnails>=2.8.0:graphics/py-django-easy-thumbnails@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}django-mptt>=0.6<1.0:www/py-django-mptt@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}django-polymorphic>=0.7<2.2:www/py-django-polymorphic@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}unidecode>=0.04<1.2:converters/py-unidecode@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} \
- ${PY_PILLOW}
+ ${PYTHON_PKGNAMEPREFIX}django-polymorphic>=2:www/py-django-polymorphic@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}unidecode>=0.04<1.2:converters/py-unidecode@${PY_FLAVOR}
-USES= python:3.5+
+USES= python:3.6+
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/www/py-django-filer/distinfo b/www/py-django-filer/distinfo
index c7101d559315..b97f93cf250f 100644
--- a/www/py-django-filer/distinfo
+++ b/www/py-django-filer/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1586258045
-SHA256 (django-filer-1.7.0.tar.gz) = 3da256ab69edc0daed0ccc9a7de37d0548b16037d57684b5524ec34cf3e203fe
-SIZE (django-filer-1.7.0.tar.gz) = 1252215
+TIMESTAMP = 1643097180
+SHA256 (django-filer-2.1.2.tar.gz) = 50f9da3b40e106de084dc6e18c19a7a54397fbee60b7ddd2568b1281ed2a24b4
+SIZE (django-filer-2.1.2.tar.gz) = 1003487
diff --git a/www/py-django-filer/files/patch-setup.py b/www/py-django-filer/files/patch-setup.py
new file mode 100644
index 000000000000..cd61b43b9761
--- /dev/null
+++ b/www/py-django-filer/files/patch-setup.py
@@ -0,0 +1,23 @@
+Relax requirements for www/py-django-polymorphic and avoid the installation of
+the test suite in the top-level directory of ${PYTHON_SITELIBDIR}.
+
+--- setup.py.orig 2021-11-09 13:48:04 UTC
++++ setup.py
+@@ -7,7 +7,7 @@ from filer import __version__
+ REQUIREMENTS = [
+ 'django>=2.2,<4.0',
+ 'django-mptt>=0.6,<1.0', # the exact version depends on Django
+- 'django-polymorphic>=2,<3.1',
++ 'django-polymorphic>=2',
+ 'easy-thumbnails>=2.8.0',
+ 'Unidecode>=0.04,<1.2',
+ ]
+@@ -51,7 +51,7 @@ setup(
+ description='A file management application for django that makes handling '
+ 'of files and images a breeze.',
+ long_description=open('README.rst').read(),
+- packages=find_packages(),
++ packages=find_packages(exclude=['tests*']),
+ include_package_data=True,
+ zip_safe=False,
+ install_requires=REQUIREMENTS,