aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2024-11-29 20:54:51 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2024-11-29 20:54:51 +0000
commitae832bb01e85d4c72907ea069532971f83a14987 (patch)
tree2dd63e07565a2d3542186f1caa0f63b2eca67b78
parent0065d33851dcecefcb57fe727621cf36cfed751d (diff)
downloadports-ae832bb01e85d4c72907ea069532971f83a14987.tar.gz
ports-ae832bb01e85d4c72907ea069532971f83a14987.zip
devel/got: update to 0.106
No user-visible changes.
-rw-r--r--devel/got/Makefile2
-rw-r--r--devel/got/distinfo6
-rw-r--r--devel/got/files/patch-lib_fetch.c22
3 files changed, 26 insertions, 4 deletions
diff --git a/devel/got/Makefile b/devel/got/Makefile
index 686ac607dc77..0609adeefe77 100644
--- a/devel/got/Makefile
+++ b/devel/got/Makefile
@@ -1,5 +1,5 @@
PORTNAME= got
-DISTVERSION= 0.105
+DISTVERSION= 0.106
CATEGORIES= devel
MASTER_SITES= https://gameoftrees.org/releases/portable/
DISTNAME= got-portable-${DISTVERSION}
diff --git a/devel/got/distinfo b/devel/got/distinfo
index 92352bb92e59..0924a0a0c37c 100644
--- a/devel/got/distinfo
+++ b/devel/got/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1731669642
-SHA256 (got-portable-0.105.tar.gz) = 3173e360dcd06fa241bec31fc4df862843ffedf2b010605680680b0dfd5ca244
-SIZE (got-portable-0.105.tar.gz) = 1500417
+TIMESTAMP = 1732899001
+SHA256 (got-portable-0.106.tar.gz) = 3079d742c125047de339dd923d75d0b960995a3a4b567ed08ef36d112bdb07cc
+SIZE (got-portable-0.106.tar.gz) = 1510753
diff --git a/devel/got/files/patch-lib_fetch.c b/devel/got/files/patch-lib_fetch.c
new file mode 100644
index 000000000000..bcb575f253fc
--- /dev/null
+++ b/devel/got/files/patch-lib_fetch.c
@@ -0,0 +1,22 @@
+Upstream commit 55569948434c65bb416f2d0f2a400a1bf3da5a78
+
+--- lib/fetch.c.orig 2024-11-28 17:28:16 UTC
++++ lib/fetch.c
+@@ -166,7 +166,7 @@ got_fetch_pack(struct got_object_id **pack_hash, struc
+
+ TAILQ_FOREACH(re, &my_refs, entry) {
+ struct got_object_id *id;
+- const char *refname;
++ char *refname;
+
+ if (got_ref_is_symbolic(re->ref))
+ continue;
+@@ -183,7 +183,7 @@ got_fetch_pack(struct got_object_id **pack_hash, struc
+ if (err)
+ goto done;
+ if (new == NULL){
+- free(&refname);
++ free(refname);
+ free(id);
+ }
+