aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-06-21 19:29:29 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-06-21 22:09:35 +0000
commitaea455822ffc77bd04c5b405a08e3a4f0e87dd9d (patch)
tree25c4450f7f1af852ca2c131f4670e7bdb2c0912b
parent400c1af36e44f6ad699125526c70668745482c98 (diff)
downloadports-aea455822ffc77bd04c5b405a08e3a4f0e87dd9d.tar.gz
ports-aea455822ffc77bd04c5b405a08e3a4f0e87dd9d.zip
x11/nwg-menu: add new port
nwg-menu displays the system menu with simplified FreeDesktop Main Categories (8 instead of 13). It also provides the search entry, to look for installed application on the basis of .desktop files, and for files in XDG user directories. It's being developed with sway in mind, but should also work with other wlroots-based Wayland compositors such as Wayfire. https://github.com/nwg-piotr/nwg-menu
-rw-r--r--x11/Makefile1
-rw-r--r--x11/nwg-menu/Makefile42
-rw-r--r--x11/nwg-menu/distinfo19
-rw-r--r--x11/nwg-menu/pkg-descr9
4 files changed, 71 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index fa49a0f12506..8e57835f604a 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -249,6 +249,7 @@
SUBDIR += nwg-dock
SUBDIR += nwg-drawer
SUBDIR += nwg-launchers
+ SUBDIR += nwg-menu
SUBDIR += nxcomp
SUBDIR += p5-Clipboard
SUBDIR += p5-X11-GUITest
diff --git a/x11/nwg-menu/Makefile b/x11/nwg-menu/Makefile
new file mode 100644
index 000000000000..b24264e5aa03
--- /dev/null
+++ b/x11/nwg-menu/Makefile
@@ -0,0 +1,42 @@
+PORTNAME= nwg-menu
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.1.1
+CATEGORIES= x11
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= MenuStart plugin to nwg-panel, also capable of working standalone
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libgtk-layer-shell.so:x11-toolkits/gtk-layer-shell
+
+USES= gnome go:modules pkgconfig
+USE_GITHUB= yes
+USE_GNOME= cairo gdkpixbuf2 gtk30
+GH_ACCOUNT= nwg-piotr
+GH_TUPLE= allan-simon:go-singleinstance:d0997106ab37:allan_simon_go_singleinstance/vendor/github.com/allan-simon/go-singleinstance \
+ dlasky:gotk3-layershell:5cca0b819261:dlasky_gotk3_layershell/vendor/github.com/dlasky/gotk3-layershell \
+ golang:sync:56d357773e84:golang_sync/vendor/golang.org/x/sync \
+ gotk3:gotk3:v0.6.0:gotk3_gotk3/vendor/github.com/gotk3/gotk3 \
+ joshuarubin:go-sway:v0.0.4:joshuarubin_go_sway/vendor/github.com/joshuarubin/go-sway \
+ joshuarubin:lifecycle:v1.0.0:joshuarubin_lifecycle/vendor/github.com/joshuarubin/lifecycle \
+ uber-go:atomic:v1.3.2:uber_go_atomic/vendor/go.uber.org/atomic \
+ uber-go:multierr:v1.1.0:uber_go_multierr/vendor/go.uber.org/multierr
+CGO_LDFLAGS+= -Wl,--as-needed # harfbuzz, freetype2
+PLIST_FILES= bin/${PORTNAME}
+PORTDATA= desktop-directories *.css
+
+post-patch:
+# Respect PREFIX for *.desktop and system configs
+ @${REINPLACE_CMD} 's,/usr/share,${DATADIR:H},' \
+ ${WRKSRC}/main.go \
+ ${WRKSRC}/tools.go
+
+post-install:
+# Based on install from WRKSRC/Makefile
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDATA}" \
+ ${STAGEDIR}${DATADIR})
+
+.include <bsd.port.mk>
diff --git a/x11/nwg-menu/distinfo b/x11/nwg-menu/distinfo
new file mode 100644
index 000000000000..7a6e7b02b01e
--- /dev/null
+++ b/x11/nwg-menu/distinfo
@@ -0,0 +1,19 @@
+TIMESTAMP = 1624145856
+SHA256 (nwg-piotr-nwg-menu-v0.1.1_GH0.tar.gz) = bc286e014eaad39d12aaad71ca48bfe2c93353114263c6fd71a0ab8cf0f2ac02
+SIZE (nwg-piotr-nwg-menu-v0.1.1_GH0.tar.gz) = 6474189
+SHA256 (allan-simon-go-singleinstance-d0997106ab37_GH0.tar.gz) = f8cee874873fe9fc1a81e8a7ca83df85c57aa86279c09cb8cba10d5feb7ed295
+SIZE (allan-simon-go-singleinstance-d0997106ab37_GH0.tar.gz) = 2819
+SHA256 (dlasky-gotk3-layershell-5cca0b819261_GH0.tar.gz) = a4548130c9fcc87302568b382fc4952aaaea262e04540480dddfd220f878c4fc
+SIZE (dlasky-gotk3-layershell-5cca0b819261_GH0.tar.gz) = 2282
+SHA256 (golang-sync-56d357773e84_GH0.tar.gz) = b30ecf4394f01a492423b41e3815d84711c29d679ee4dd5118fc2c9bcf433b3f
+SIZE (golang-sync-56d357773e84_GH0.tar.gz) = 16832
+SHA256 (gotk3-gotk3-v0.6.0_GH0.tar.gz) = 73e33cf291cc7d071e29af15482c4b45794ad614d6dcecac716df0959126a0ce
+SIZE (gotk3-gotk3-v0.6.0_GH0.tar.gz) = 272701
+SHA256 (joshuarubin-go-sway-v0.0.4_GH0.tar.gz) = bde4f59a99937f5a4128cdbc8c06107a41f72324a88de6d1d0cd666df0750820
+SIZE (joshuarubin-go-sway-v0.0.4_GH0.tar.gz) = 9158
+SHA256 (joshuarubin-lifecycle-v1.0.0_GH0.tar.gz) = 01ae9623078c568cefbda7c2dd973024382cdbf598f5efa4ac5578bb4bd0dff7
+SIZE (joshuarubin-lifecycle-v1.0.0_GH0.tar.gz) = 7265
+SHA256 (uber-go-atomic-v1.3.2_GH0.tar.gz) = ee2ec763758d8ab2095ee927086a1ed057212fa27660614448d4bbcbdc4ffe61
+SIZE (uber-go-atomic-v1.3.2_GH0.tar.gz) = 8047
+SHA256 (uber-go-multierr-v1.1.0_GH0.tar.gz) = 45405583513302d57d4715fada5ef8c8dbd9c9992956f2d0faa8758d9d885851
+SIZE (uber-go-multierr-v1.1.0_GH0.tar.gz) = 9234
diff --git a/x11/nwg-menu/pkg-descr b/x11/nwg-menu/pkg-descr
new file mode 100644
index 000000000000..035be6441f7e
--- /dev/null
+++ b/x11/nwg-menu/pkg-descr
@@ -0,0 +1,9 @@
+nwg-menu displays the system menu with simplified FreeDesktop Main
+Categories (8 instead of 13). It also provides the search entry, to
+look for installed application on the basis of .desktop files, and for
+files in XDG user directories.
+
+It's being developed with sway in mind, but should also work with
+other wlroots-based Wayland compositors such as Wayfire.
+
+WWW: https://github.com/nwg-piotr/nwg-menu