aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2022-09-15 17:46:40 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2022-09-15 18:04:30 +0000
commitaea78597733861d56eec8eb0e5f7d1d2b260fcd7 (patch)
treee733a0035238cb0313d7f4c1bf935f7350a848c7
parent3e5df2b9edb9847073411cf7cd1d10ec96008b77 (diff)
net-im/profanity: Update to 0.13.0
- Remove dependency on libmesode (deprecated) - Add dependency on qrencode - Add patch to fix bug in configure, and is reported upstream Reported by: portscout
-rw-r--r--net-im/profanity/Makefile14
-rw-r--r--net-im/profanity/distinfo6
-rw-r--r--net-im/profanity/files/patch-configure.ac39
-rw-r--r--net-im/profanity/pkg-plist3
4 files changed, 52 insertions, 10 deletions
diff --git a/net-im/profanity/Makefile b/net-im/profanity/Makefile
index dd8818361aff..a4991c631310 100644
--- a/net-im/profanity/Makefile
+++ b/net-im/profanity/Makefile
@@ -1,5 +1,5 @@
PORTNAME= profanity
-PORTVERSION= 0.12.1
+PORTVERSION= 0.13.0
CATEGORIES= net-im
MAINTAINER= ashish@FreeBSD.org
@@ -10,8 +10,7 @@ LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
BUILD_DEPENDS= autoconf-archive>=0:devel/autoconf-archive
-LIB_DEPENDS= libmesode.so:net-im/libmesode \
- libcurl.so:ftp/curl \
+LIB_DEPENDS= libcurl.so:ftp/curl \
libotr.so:security/libotr \
libuuid.so:misc/e2fsprogs-libuuid \
libgpgme.so:security/gpgme \
@@ -19,7 +18,8 @@ LIB_DEPENDS= libmesode.so:net-im/libmesode \
libgpg-error.so:security/libgpg-error \
libgcrypt.so:security/libgcrypt \
libsignal-protocol-c.so:net/libsignal-protocol-c \
- libstrophe.so:net-im/libstrophe
+ libstrophe.so:net-im/libstrophe \
+ libqrencode.so:graphics/libqrencode
USES= cpe ncurses pkgconfig ssl python:3.8+ readline autoreconf libtool gnome \
sqlite:3
@@ -30,9 +30,9 @@ GH_ACCOUNT= profanity-im
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-otr --enable-python-plugins --enable-c-plugins \
- --enable-pgp --enable-icons-and-clipboard=no \
- --with-xscreensaver=no \
- --enable-omemo
+ --enable-pgp --disable-icons-and-clipboard \
+ --without-xscreensaver --disable-gdk-pixbuf \
+ --enable-omemo --enable-omemo-qrcode
CONFIGURE_ENV= LIBS="${CFLAGS} -lcrypto"
INSTALL_TARGET= install-strip
OPTIONS_DEFINE= NOTIFY
diff --git a/net-im/profanity/distinfo b/net-im/profanity/distinfo
index b4ec47f790a9..e7548db0e9ec 100644
--- a/net-im/profanity/distinfo
+++ b/net-im/profanity/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1649101132
-SHA256 (profanity-im-profanity-0.12.1_GH0.tar.gz) = 2a271e17dfb7b556d76eb69fb6e8b9676da6f78869172e62339937c9b774b6ea
-SIZE (profanity-im-profanity-0.12.1_GH0.tar.gz) = 556300
+TIMESTAMP = 1663179502
+SHA256 (profanity-im-profanity-0.13.0_GH0.tar.gz) = ee38119ed3bd3995675d7da787f52c7576403be678bc9a8f5170812597547d7b
+SIZE (profanity-im-profanity-0.13.0_GH0.tar.gz) = 566611
diff --git a/net-im/profanity/files/patch-configure.ac b/net-im/profanity/files/patch-configure.ac
new file mode 100644
index 000000000000..fc5a6b1f631c
--- /dev/null
+++ b/net-im/profanity/files/patch-configure.ac
@@ -0,0 +1,39 @@
+--- configure.ac.orig 2022-09-13 09:50:49 UTC
++++ configure.ac
+@@ -104,7 +104,7 @@ elif test "x$enable_python_plugins" != xno; then
+ rm -f Python.framework
+ ln -s $PYTHON_FRAMEWORK Python.framework ])
+ PKG_CHECK_MODULES([python], [python-embed], [PYTHON_CONFIG_EXISTS=yes], [PYTHON_CONFIG_EXISTS=no])
+- PKG_CHECK_MODULES([python], [python3-embed], [PYTHON3_CONFIG_EXISTS=yes; AC_DEFINE(PY_IS_PYTHON3, [1], [Is Python version 3])], [PYTHON3_CONFIG_EXISTS=no])
++ PKG_CHECK_MODULES([python], [python-3.9-embed], [PYTHON3_CONFIG_EXISTS=yes; AC_DEFINE(PY_IS_PYTHON3, [1], [Is Python version 3])], [PYTHON3_CONFIG_EXISTS=no])
+ if test "$PYTHON_CONFIG_EXISTS" = "yes" || test "$PYTHON3_CONFIG_EXISTS" = "yes"; then
+ AM_CONDITIONAL([BUILD_PYTHON_API], [true])
+ AC_DEFINE([HAVE_PYTHON], [1], [Python support])
+@@ -272,11 +272,11 @@ AS_IF([test "x$PLATFORM" = xosx],
+ [AC_MSG_NOTICE([libnotify support will be disabled])])])])])
+
+ dnl feature: xscreensaver
+-AS_IF([test "x$enable_xscreensaver" != xno],
++AS_IF([test "x$with_xscreensaver" != xno],
+ [PKG_CHECK_MODULES([xscrnsaver], [xscrnsaver],
+ [AC_MSG_NOTICE([xscreensaver support is enabled]);
+ LIBS="$xscrnsaver_LIBS $LIBS" CFLAGS="$CFLAGS $xscrnsaver_CFLAGS"],
+- [AS_IF([test "x$enable_xscreensaver" = xyes],
++ [AS_IF([test "x$with_xscreensaver" = xyes],
+ [AC_MSG_ERROR([xscreensaver is required but does not exist])],
+ [AC_MSG_NOTICE([xscreensaver support is disabled])])])])
+
+@@ -311,11 +311,11 @@ if test "x$enable_otr" != xno; then
+ fi
+
+ dnl feature: pixbuf / used for scaling avatars before uploading via `/avatar set`
+-AS_IF([test "x$enable_pixbuf" != xno],
++AS_IF([test "x$enable_gdk_pixbuf" != xno],
+ [PKG_CHECK_MODULES([gdk_pixbuf], [gdk-pixbuf-2.0 >= 2.4],
+ [AC_DEFINE([HAVE_PIXBUF], [1], [gdk-pixbuf module])
+ LIBS="$gdk_pixbuf_LIBS $LIBS" CFLAGS="$gdk_pixbuf_CFLAGS $CFLAGS"],
+- [AS_IF([test "x$enable_pixbuf" = xyes],
++ [AS_IF([test "x$enable_gdk_pixbuf" = xyes],
+ [AC_MSG_ERROR([gdk-pixbuf-2.0 >= 2.4 is required to scale avatars before uploading])],
+ [AC_MSG_NOTICE([gdk-pixbuf-2.0 >= 2.4 not found, GDK Pixbuf support not enabled])])])])
+
diff --git a/net-im/profanity/pkg-plist b/net-im/profanity/pkg-plist
index da172591009d..fce95199db98 100644
--- a/net-im/profanity/pkg-plist
+++ b/net-im/profanity/pkg-plist
@@ -13,6 +13,7 @@ man/man1/profanity.1.gz
%%DATADIR%%/themes/gruvbox
%%DATADIR%%/themes/hacker
%%DATADIR%%/themes/headache
+%%DATADIR%%/themes/irssi
%%DATADIR%%/themes/joker
%%DATADIR%%/themes/jubalian
%%DATADIR%%/themes/orange
@@ -87,6 +88,7 @@ man/man1/profanity-os.1.gz
man/man1/profanity-otr.1.gz
man/man1/profanity-outtype.1.gz
man/man1/profanity-ox.1.gz
+man/man1/profanity-ox-setup.1.gz
man/man1/profanity-paste.1.gz
man/man1/profanity-pgp.1.gz
man/man1/profanity-ping.1.gz
@@ -113,6 +115,7 @@ man/man1/profanity-silence.1.gz
man/man1/profanity-slashguard.1.gz
man/man1/profanity-software.1.gz
man/man1/profanity-splash.1.gz
+man/man1/profanity-stamp.1.gz
man/man1/profanity-states.1.gz
man/man1/profanity-status.1.gz
man/man1/profanity-statusbar.1.gz