aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-03-09 13:46:07 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-03-09 14:05:30 +0000
commitaeb7cbac8e9c4be20342765508ba2fe57e6e753b (patch)
treeff42c2560c17f33dcae587f117b16d1b7eb84186
parent9c18de328c055cfa6f899e6a18c370f89e184cbc (diff)
downloadports-aeb7cbac8e9c4be20342765508ba2fe57e6e753b.tar.gz
ports-aeb7cbac8e9c4be20342765508ba2fe57e6e753b.zip
sysutils/pciutils: Update to 3.11.1
-rw-r--r--sysutils/pciutils/Makefile2
-rw-r--r--sysutils/pciutils/distinfo6
-rw-r--r--sysutils/pciutils/files/patch-Makefile49
3 files changed, 24 insertions, 33 deletions
diff --git a/sysutils/pciutils/Makefile b/sysutils/pciutils/Makefile
index 1a1b73f2196c..dc7ee61d96a8 100644
--- a/sysutils/pciutils/Makefile
+++ b/sysutils/pciutils/Makefile
@@ -1,5 +1,5 @@
PORTNAME= pciutils
-PORTVERSION= 3.10.0
+PORTVERSION= 3.11.1
CATEGORIES= sysutils
MASTER_SITES= KERNEL_ORG/software/utils/pciutils \
LOCAL/sunpoet
diff --git a/sysutils/pciutils/distinfo b/sysutils/pciutils/distinfo
index 4490fcd78285..541d4cabc9b0 100644
--- a/sysutils/pciutils/distinfo
+++ b/sysutils/pciutils/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1683227595
-SHA256 (pciutils-3.10.0.tar.xz) = 238a2e27166730e53a17fe07bfad229e07fa39b618117e5944b6d7eda9fbb0e9
-SIZE (pciutils-3.10.0.tar.xz) = 444080
+TIMESTAMP = 1709390366
+SHA256 (pciutils-3.11.1.tar.xz) = 3f472ad864473de5ba17f765cc96ef5f33e1b730918d3adda6f945a2a9290df4
+SIZE (pciutils-3.11.1.tar.xz) = 470428
diff --git a/sysutils/pciutils/files/patch-Makefile b/sysutils/pciutils/files/patch-Makefile
index 536b904e3597..929b2b822316 100644
--- a/sysutils/pciutils/files/patch-Makefile
+++ b/sysutils/pciutils/files/patch-Makefile
@@ -1,17 +1,17 @@
---- Makefile.orig 2023-05-01 12:59:54 UTC
+--- Makefile.orig 2024-02-24 23:10:18 UTC
+++ Makefile
@@ -1,8 +1,8 @@
# Makefile for The PCI Utilities
- # (c) 1998--2023 Martin Mares <mj@ucw.cz>
+ # (c) 1998--2024 Martin Mares <mj@ucw.cz>
-OPT=-O2
-CFLAGS=$(OPT) -Wall -W -Wno-parentheses -Wstrict-prototypes -Wmissing-prototypes
+#OPT=-O2
+CFLAGS+=$(OPT) -Wall -W -Wno-parentheses -Wstrict-prototypes -Wmissing-prototypes
- VERSION=3.10.0
- DATE=2023-05-01
-@@ -32,11 +32,11 @@ HWDB=
+ VERSION=3.11.1
+ DATE=2024-02-25
+@@ -32,11 +32,11 @@ ABI_VERSION=3
ABI_VERSION=3
# Installation directories
@@ -25,37 +25,28 @@
MANDIR:=$(shell if [ -d $(PREFIX)/share/man ] ; then echo $(PREFIX)/share/man ; else echo $(PREFIX)/man ; fi)
INCDIR=$(PREFIX)/include
LIBDIR=$(PREFIX)/lib
-@@ -45,13 +45,13 @@ PKGCFDIR=$(LIBDIR)/pkgconfig
- # Commands
- INSTALL=install
- DIRINSTALL=install -d
--ifdef CROSS_COMPILE
--STRIP=--strip-program $(CROSS_COMPILE)-strip
+@@ -48,9 +48,9 @@ STRIP+=--strip-program $(CROSS_COMPILE)strip
+ STRIP=-s
+ ifdef CROSS_COMPILE
+ STRIP+=--strip-program $(CROSS_COMPILE)strip
-CC=$(CROSS_COMPILE)gcc
--else
--STRIP=-s
++CC?=$(CROSS_COMPILE)gcc
+ else
-CC=cc
--endif
-+#ifdef CROSS_COMPILE
-+#STRIP=--strip-program $(CROSS_COMPILE)-strip
-+#CC=$(CROSS_COMPILE)gcc
-+#else
-+#STRIP=-s
-+#CC=cc
-+#endif
++CC?=cc
+ endif
AR=$(CROSS_COMPILE)ar
RANLIB=$(CROSS_COMPILE)ranlib
- DLLTOOL=$(CROSS_COMPILE)dlltool
-@@ -67,7 +67,7 @@ PCIINC_INS=lib/config.h lib/header.h lib/pci.h lib/typ
+@@ -73,7 +73,7 @@ export
export
--all: lib/$(PCIIMPLIB) lspci$(EXEEXT) setpci$(EXEEXT) example$(EXEEXT) lspci.8 setpci.8 pcilib.7 pci.ids.5 update-pciids update-pciids.8 $(PCI_IDS)
-+all: lspci$(EXEEXT) setpci$(EXEEXT) example$(EXEEXT) lspci.8 setpci.8 pcilib.7 pci.ids.5 update-pciids update-pciids.8 $(PCI_IDS)
+-all: lib/$(PCIIMPLIB) lspci$(EXEEXT) setpci$(EXEEXT) example$(EXEEXT) lspci.8 setpci.8 pcilib.7 pci.ids.5 update-pciids update-pciids.8 $(PCI_IDS) pcilmr$(EXEEXT) pcilmr.8
++all: lspci$(EXEEXT) setpci$(EXEEXT) example$(EXEEXT) lspci.8 setpci.8 pcilib.7 pci.ids.5 update-pciids update-pciids.8 $(PCI_IDS) pcilmr$(EXEEXT) pcilmr.8
lib/$(PCIIMPLIB): $(PCIINC) force
$(MAKE) -C lib all
-@@ -83,8 +83,8 @@ PCIINC+=compat/getopt.h
+@@ -89,8 +89,8 @@ endif
COMMON+=compat/getopt.o
endif
@@ -64,9 +55,9 @@
+lspci$(EXEEXT): lspci.o ls-vpd.o ls-caps.o ls-caps-vendor.o ls-ecaps.o ls-kernel.o ls-tree.o ls-map.o $(COMMON)
+setpci$(EXEEXT): setpci.o $(COMMON)
- LSPCIINC=lspci.h pciutils.h $(PCIINC)
+ LSPCIINC=lspci.h $(UTILINC)
lspci.o: lspci.c $(LSPCIINC)
-@@ -107,7 +107,7 @@ update-pciids: update-pciids.sh
+@@ -113,7 +113,7 @@ update-pciids: update-pciids.sh
chmod +x $@
# The example of use of libpci
@@ -74,4 +65,4 @@
+example$(EXEEXT): example.o
example.o: example.c $(PCIINC)
- %$(EXEEXT): %.o
+ $(LMROBJS) pcilmr.o: override CFLAGS+=-I .