aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-08-24 13:24:42 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-08-24 13:24:52 +0000
commitaefc3881db633e12c980ed0043596363796f1da1 (patch)
tree3fc42afa99f069e74bc0291c00770b5522775d24
parentb667aef876324cadd30c1cfda48d779cc94b34df (diff)
downloadports-aefc3881db633e12c980ed0043596363796f1da1.tar.gz
ports-aefc3881db633e12c980ed0043596363796f1da1.zip
net/rssguard: new port had been added (+)
RSS Guard is simple, lightweight, and easy-to-use RSS/Atom feed aggregator developed using Qt framework which supports online feed synchronization with several services: Feedly, Gmail, Google Reader, Inoreader, Nextcloud News, and Tiny Tiny RSS. WWW: https://github.com/martinrotter/rssguard
-rw-r--r--net/Makefile1
-rw-r--r--net/rssguard/Makefile40
-rw-r--r--net/rssguard/distinfo3
-rw-r--r--net/rssguard/pkg-descr6
-rw-r--r--net/rssguard/pkg-plist18
5 files changed, 68 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 2866c992bbbe..446583ca23f7 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1197,6 +1197,7 @@
SUBDIR += rscsi
SUBDIR += rsocket-cpp
SUBDIR += rsplib
+ SUBDIR += rssguard
SUBDIR += rsync
SUBDIR += rsync-bpc
SUBDIR += rtg
diff --git a/net/rssguard/Makefile b/net/rssguard/Makefile
new file mode 100644
index 000000000000..e24f27223721
--- /dev/null
+++ b/net/rssguard/Makefile
@@ -0,0 +1,40 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+
+PORTNAME= rssguard
+PORTVERSION= 3.9.2
+CATEGORIES= net www
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Simple (yet powerful) Qt5 feed reader
+
+LICENSE= GPLv3+
+
+USES= qmake qt:5
+USE_QT= buildtools_build linguisttools_build \
+ core declarative gui network sql widgets xml
+USE_GITHUB= yes
+GH_ACCOUNT= martinrotter
+
+OPTIONS_DEFINE= WEBENGINE
+OPTIONS_DEFAULT= WEBENGINE
+
+WEBENGINE_DESC= Use QtWebEngine module for internal web browser
+WEBENGINE_USE= QT=location,printsupport,webchannel,webengine
+WEBENGINE_QMAKE_OFF= USE_WEBENGINE=false
+
+post-patch:
+# Remove unused #include <QtConcurrent/QtConcurrentRun> to avoid needless
+# USE_QT+=concurrent_build dependency
+ ${REINPLACE_CMD} -e '/QtConcurrent/d' \
+ ${WRKSRC}/src/librssguard/miscellaneous/feedreader.cpp \
+ ${WRKSRC}/src/librssguard/services/gmail/gui/formaddeditemail.cpp
+# Drop executable bits to prevent bogus stripping attempts
+ cd ${WRKSRC}/src/librssguard/services/abstract && ${CHMOD} -x \
+ gui/authenticationdetails.h importantnode.h label.h \
+ labelsnode.h
+ ${CHMOD} -x ${WRKSRC}/resources/graphics/rssguard.png
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/librssguard.so
+
+.include <bsd.port.mk>
diff --git a/net/rssguard/distinfo b/net/rssguard/distinfo
new file mode 100644
index 000000000000..415fb68eb617
--- /dev/null
+++ b/net/rssguard/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1618205956
+SHA256 (martinrotter-rssguard-3.9.2_GH0.tar.gz) = 05eb628ff085ff10056289fd83b5e3b0583c19e3711795ade024bdfe71de5d97
+SIZE (martinrotter-rssguard-3.9.2_GH0.tar.gz) = 13607587
diff --git a/net/rssguard/pkg-descr b/net/rssguard/pkg-descr
new file mode 100644
index 000000000000..939423f2485f
--- /dev/null
+++ b/net/rssguard/pkg-descr
@@ -0,0 +1,6 @@
+RSS Guard is simple, lightweight, and easy-to-use RSS/Atom feed aggregator
+developed using Qt framework which supports online feed synchronization
+with several services: Feedly, Gmail, Google Reader, Inoreader, Nextcloud
+News, and Tiny Tiny RSS.
+
+WWW: https://github.com/martinrotter/rssguard
diff --git a/net/rssguard/pkg-plist b/net/rssguard/pkg-plist
new file mode 100644
index 000000000000..a7c9d8829750
--- /dev/null
+++ b/net/rssguard/pkg-plist
@@ -0,0 +1,18 @@
+bin/rssguard
+include/librssguard/services/abstract/accountcheckmodel.h
+include/librssguard/services/abstract/cacheforserviceroot.h
+include/librssguard/services/abstract/category.h
+include/librssguard/services/abstract/feed.h
+include/librssguard/services/abstract/gui/authenticationdetails.h
+include/librssguard/services/abstract/gui/formfeeddetails.h
+include/librssguard/services/abstract/importantnode.h
+include/librssguard/services/abstract/label.h
+include/librssguard/services/abstract/labelsnode.h
+include/librssguard/services/abstract/recyclebin.h
+include/librssguard/services/abstract/rootitem.h
+include/librssguard/services/abstract/serviceentrypoint.h
+include/librssguard/services/abstract/serviceroot.h
+lib/librssguard.so
+share/applications/com.github.rssguard.desktop
+share/icons/hicolor/512x512/apps/rssguard.png
+share/metainfo/com.github.rssguard.appdata.xml